summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-04-03 22:59:52 -0500
committerAmy Liffey <amynka@gentoo.org>2018-04-15 16:05:30 +0200
commit6540867b3b8836e1dcf090ae3c1c55091af557b9 (patch)
tree450d53cc2322e002c9c7deccf52d29e0d7e5bfcb /media-gfx/cura
parentdev-java/javahelp: Remove 2.0.05_p63 (diff)
downloadgentoo-6540867b3b8836e1dcf090ae3c1c55091af557b9.tar.gz
gentoo-6540867b3b8836e1dcf090ae3c1c55091af557b9.tar.bz2
gentoo-6540867b3b8836e1dcf090ae3c1c55091af557b9.zip
media-gfx/cura: fdo-mime migration
Plus some minor formatting changes to be more in accord with the rest of the ::gentoo tree, and removal of eutils in favor of desktop. Closes: https://github.com/gentoo/gentoo/pull/7800 Package-Manager: Portage-2.3.27, Repoman-2.3.9
Diffstat (limited to 'media-gfx/cura')
-rw-r--r--media-gfx/cura/cura-0.15.04.4.ebuild17
-rw-r--r--media-gfx/cura/cura-0.15.04.5_rc5.ebuild18
-rw-r--r--media-gfx/cura/cura-2.1.0_beta.ebuild21
-rw-r--r--media-gfx/cura/cura-2.3.1.ebuild23
-rw-r--r--media-gfx/cura/cura-2.6.0.ebuild21
5 files changed, 61 insertions, 39 deletions
diff --git a/media-gfx/cura/cura-0.15.04.4.ebuild b/media-gfx/cura/cura-0.15.04.4.ebuild
index 59f9fbf4f8b3..fa9ddb4d2518 100644
--- a/media-gfx/cura/cura-0.15.04.4.ebuild
+++ b/media-gfx/cura/cura-0.15.04.4.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit eutils fdo-mime gnome2-utils python-single-r1
+inherit desktop gnome2-utils python-single-r1 xdg-utils
MY_PV=${PV#0.}
MY_PN=Cura
@@ -30,9 +30,12 @@ RDEPEND="${PYTHON_DEPS}
DEPEND="${RDEPEND}
>=dev-python/setuptools-0.6.34[${PYTHON_USEDEP}]"
-PATCHES=( "${FILESDIR}/${P}-nopower.patch" )
S="${WORKDIR}/${MY_PN}-${MY_PV}"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.15.04.4-nopower.patch"
+)
+
src_prepare() {
cat > "${T}"/cura <<- CURAEOF || die
#!/bin/sh
@@ -62,13 +65,13 @@ pkg_preinst() {
}
pkg_postinst() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
gnome2_icon_cache_update
}
pkg_postrm() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
gnome2_icon_cache_update
}
diff --git a/media-gfx/cura/cura-0.15.04.5_rc5.ebuild b/media-gfx/cura/cura-0.15.04.5_rc5.ebuild
index ac952093c028..c35602d8d18b 100644
--- a/media-gfx/cura/cura-0.15.04.5_rc5.ebuild
+++ b/media-gfx/cura/cura-0.15.04.5_rc5.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit eutils fdo-mime gnome2-utils python-single-r1
+
+inherit desktop gnome2-utils python-single-r1 xdg-utils
MY_PV=${PV#0.}
MY_PV=${MY_PV/_rc/-RC}
@@ -30,9 +31,12 @@ RDEPEND="${PYTHON_DEPS}
DEPEND="${RDEPEND}
>=dev-python/setuptools-0.6.34[${PYTHON_USEDEP}]"
-PATCHES=( "${FILESDIR}/${PN}-0.15.04.4-nopower.patch" )
S="${WORKDIR}/${MY_PN}-${MY_PV}"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.15.04.4-nopower.patch"
+)
+
src_prepare() {
cat > "${T}"/cura <<- CURAEOF || die
#!/bin/sh
@@ -62,13 +66,13 @@ pkg_preinst() {
}
pkg_postinst() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
gnome2_icon_cache_update
}
pkg_postrm() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
gnome2_icon_cache_update
}
diff --git a/media-gfx/cura/cura-2.1.0_beta.ebuild b/media-gfx/cura/cura-2.1.0_beta.ebuild
index 9a28b902e3e9..db1610abbb6f 100644
--- a/media-gfx/cura/cura-2.1.0_beta.ebuild
+++ b/media-gfx/cura/cura-2.1.0_beta.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=6
PYTHON_COMPAT=( python3_4 python3_5 )
-inherit cmake-utils fdo-mime gnome2-utils python-single-r1
+
+inherit cmake-utils gnome2-utils python-single-r1 xdg-utils
MY_PN=Cura
MY_PV=${PV/_beta}
@@ -28,7 +29,11 @@ DEPEND="${RDEPEND}
sys-devel/gettext"
S="${WORKDIR}/${MY_PN}-${MY_PV}"
-PATCHES=( "${FILESDIR}/${P}-fix-install-paths.patch" )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.1.0_beta-fix-install-paths.patch"
+)
+
DOCS=( README.md )
src_configure() {
@@ -52,13 +57,13 @@ pkg_preinst() {
}
pkg_postinst() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
gnome2_icon_cache_update
}
pkg_postrm() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
gnome2_icon_cache_update
}
diff --git a/media-gfx/cura/cura-2.3.1.ebuild b/media-gfx/cura/cura-2.3.1.ebuild
index 39b5a6d05144..9af78aaedc32 100644
--- a/media-gfx/cura/cura-2.3.1.ebuild
+++ b/media-gfx/cura/cura-2.3.1.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=6
-PYTHON_COMPAT=( python3_4 python3_5 )
-inherit cmake-utils fdo-mime gnome2-utils python-single-r1
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit cmake-utils gnome2-utils python-single-r1 xdg-utils
MY_PN=Cura
MY_PV=${PV/_beta}
@@ -29,7 +30,11 @@ DEPEND="${RDEPEND}
sys-devel/gettext"
S="${WORKDIR}/${MY_PN}-${MY_PV}"
-PATCHES=( "${FILESDIR}/${P}-fix-install-paths.patch" )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.3.1-fix-install-paths.patch"
+)
+
DOCS=( README.md )
src_configure() {
@@ -53,13 +58,13 @@ pkg_preinst() {
}
pkg_postinst() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
gnome2_icon_cache_update
}
pkg_postrm() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
gnome2_icon_cache_update
}
diff --git a/media-gfx/cura/cura-2.6.0.ebuild b/media-gfx/cura/cura-2.6.0.ebuild
index 0f92d0ff5de6..bf9f44699fb2 100644
--- a/media-gfx/cura/cura-2.6.0.ebuild
+++ b/media-gfx/cura/cura-2.6.0.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=6
PYTHON_COMPAT=( python3_{4,5,6} )
-inherit cmake-utils fdo-mime gnome2-utils python-single-r1
+
+inherit cmake-utils gnome2-utils python-single-r1 xdg-utils
MY_PN=Cura
MY_PV=${PV/_beta}
@@ -29,7 +30,11 @@ DEPEND="${RDEPEND}
sys-devel/gettext"
S="${WORKDIR}/${MY_PN}-${MY_PV}"
-PATCHES=( "${FILESDIR}/${PN}-2.3.1-fix-install-paths.patch" )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.3.1-fix-install-paths.patch"
+)
+
DOCS=( README.md )
src_configure() {
@@ -53,13 +58,13 @@ pkg_preinst() {
}
pkg_postinst() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
gnome2_icon_cache_update
}
pkg_postrm() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
gnome2_icon_cache_update
}