summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-06-18 16:52:38 +0200
committerMarek Szuba <marecki@gentoo.org>2020-06-18 18:29:07 +0200
commit10cc105b82d53d20fc48ba340ea0a99266df9cc7 (patch)
tree43405aba2919ca9abf090a963932d68bfa4756c7 /media-gfx/darktable/darktable-3.0.2.ebuild
parentmedia-gfx/darktable: allow enabling LTO in RawSpeed via USE=lto (diff)
downloadgentoo-10cc105b82d53d20fc48ba340ea0a99266df9cc7.tar.gz
gentoo-10cc105b82d53d20fc48ba340ea0a99266df9cc7.tar.bz2
gentoo-10cc105b82d53d20fc48ba340ea0a99266df9cc7.zip
media-gfx/darktable: if building with gcc, check for Graphite support
Closes: https://bugs.gentoo.org/695658 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'media-gfx/darktable/darktable-3.0.2.ebuild')
-rw-r--r--media-gfx/darktable/darktable-3.0.2.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/media-gfx/darktable/darktable-3.0.2.ebuild b/media-gfx/darktable/darktable-3.0.2.ebuild
index e35f592dbc50..1ab8842d12a2 100644
--- a/media-gfx/darktable/darktable-3.0.2.ebuild
+++ b/media-gfx/darktable/darktable-3.0.2.ebuild
@@ -63,7 +63,6 @@ DEPEND="${COMMON_DEPEND}
>=sys-devel/clang-4
>=sys-devel/llvm-4
)
- openmp? ( >=sys-devel/gcc-6[openmp,graphite] )
"
RDEPEND="${COMMON_DEPEND}
kwallet? ( >=kde-frameworks/kwallet-5.34.0-r1 )
@@ -77,6 +76,12 @@ PATCHES=(
S="${WORKDIR}/${P/_/~}"
pkg_pretend() {
+ # Bug #695658
+ if tc-is-gcc; then
+ test-flags-CC -floop-block &> /dev/null || \
+ die "Please switch to a gcc version built with USE=graphite"
+ fi
+
if use openmp ; then
tc-has-openmp || die "Please switch to an openmp compatible compiler"
fi