summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/enblend/enblend-4.1.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/enblend/enblend-4.1.1.ebuild')
-rw-r--r--media-gfx/enblend/enblend-4.1.1.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/media-gfx/enblend/enblend-4.1.1.ebuild b/media-gfx/enblend/enblend-4.1.1.ebuild
new file mode 100644
index 000000000000..20e6ba7447ab
--- /dev/null
+++ b/media-gfx/enblend/enblend-4.1.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit eutils
+
+MY_P="${PN}-enfuse-${PV/_rc/rc}"
+
+DESCRIPTION="Image Blending with Multiresolution Splines"
+HOMEPAGE="http://enblend.sourceforge.net/"
+SRC_URI="mirror://sourceforge/enblend/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 VIGRA"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="debug doc gpu +image-cache +openexr openmp"
+
+RDEPEND="
+ media-libs/glew
+ =media-libs/lcms-2*
+ >=media-libs/libpng-1.2.43
+ media-libs/plotutils[X]
+ media-libs/tiff
+ >=media-libs/vigra-1.8.0
+ sci-libs/gsl
+ virtual/jpeg
+ gpu? ( media-libs/freeglut )
+ openexr? ( >=media-libs/openexr-1.0 )"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.31.0
+ virtual/pkgconfig
+ doc? (
+ media-gfx/transfig
+ sci-visualization/gnuplot[gd]
+ virtual/latex-base
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use image-cache && use openmp; then
+ ewarn "the openmp and image-cache USE-flags are mutually exclusive"
+ ewarn "image-cache will be disabled in favour of openmp"
+ fi
+}
+
+src_configure() {
+ local myconf="--with-boost-filesystem"
+ if use image-cache && use openmp; then
+ myconf="${myconf} --disable-image-cache --enable-openmp"
+ else
+ myconf="${myconf} $(use_enable image-cache) $(use_enable openmp)"
+ fi
+
+ use doc && myconf="${myconf} --with-gnuplot=$(type -p gnuplot)" \
+ || myconf="${myconf} --with-gnuplot=false"
+
+ econf \
+ --with-x \
+ $(use_enable debug) \
+ $(use_enable gpu gpu-support) \
+ $(use_with openexr) \
+ ${myconf}
+}
+
+src_compile() {
+ # forcing -j1 as every parallel compilation process needs about 1 GB RAM.
+ emake -j1 || die
+ if use doc; then
+ cd doc
+ make enblend.pdf enfuse.pdf || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README || die
+ use doc && dodoc doc/en{blend,fuse}.pdf
+}