summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/engauge
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/engauge')
-rw-r--r--media-gfx/engauge/Manifest2
-rw-r--r--media-gfx/engauge/engauge-5.1.ebuild50
-rw-r--r--media-gfx/engauge/engauge-5.2.ebuild48
-rw-r--r--media-gfx/engauge/metadata.xml11
4 files changed, 111 insertions, 0 deletions
diff --git a/media-gfx/engauge/Manifest b/media-gfx/engauge/Manifest
new file mode 100644
index 000000000000..87349cdb384f
--- /dev/null
+++ b/media-gfx/engauge/Manifest
@@ -0,0 +1,2 @@
+DIST engauge-5.1.tar.gz 10612879 SHA256 64ec75af53a757622da786835f4cc70c09fc491e69aafc6e69dbfd54bfdc3a59 SHA512 595ac3c96c88d20e2405019efadaff802c0c85079314ec955475b16aec3763f3cb954f5e072678fc1b155bd339b2b758c8963087e4e09e390e29ffea0f7b9a5a WHIRLPOOL fa4dbea7617bae87d7b32b025a2182bfa9ce194850748b98464fe15a3fe3375d259a3af72df71ab859ce9294a25739d96a117254991d0b14ac5a2b4609eaa39c
+DIST engauge_5.2.tgz 5708224 SHA256 2defe5f06a78cbb9e3361e649de6b84b90fa85e3f587245e240b8efb8df78b36 SHA512 b1839a223c93866f880ca090b6dd5a9ab45a89b5f6f470fd6abba3e2aa4b108ed228c8b06c3888fa463316798c2d157e20b2e22975bd65a1124d007bb36d2d88 WHIRLPOOL 528cc08a6c6d2dcef39ca0bcbc221f29131ae47e1b28b5b727a1336d15ed9c5a6045fd62a853a423ca5edd3a4a369bd1dc76847396c0d51036a4c6bc33ff9004
diff --git a/media-gfx/engauge/engauge-5.1.ebuild b/media-gfx/engauge/engauge-5.1.ebuild
new file mode 100644
index 000000000000..722690fe41c8
--- /dev/null
+++ b/media-gfx/engauge/engauge-5.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit versionator qt4-r2 eutils
+
+DESCRIPTION="Convert an image file showing a graph or map into numbers"
+HOMEPAGE="http://digitizer.sourceforge.net/"
+SRC_URI="mirror://sourceforge/digitizer/digit-src-$(replace_version_separator . _).tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-qt/qt3support:4
+ dev-qt/qtgui:4[gif(+)]
+ sci-libs/fftw:3.0
+ x11-libs/libXft"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ # Some patching and using the DEBIAN_PACKAGE ifdef is necessary to make sure the
+ # documentation is looked for in the proper directory
+ sed -i -e "s:/usr/share/doc/engauge-digitizer-doc/html:${ROOT}/usr/share/doc/${PF}/usermanual:" \
+ src/digitmain.cpp || die "sed failed"
+ sed -i -e '/unix {/a DEFINES += DEBIAN_PACKAGE' \
+ digitizer.pro || die "sed failed"
+}
+
+src_configure() {
+ eqmake4 digitizer.pro
+}
+
+src_install() {
+ dobin bin/engauge
+ newicon src/img/lo32-app-digitizer.png "${PN}.png"
+ make_desktop_entry engauge "Engauge Digitizer" ${PN} Graphics
+ insinto /usr/share/doc/${PF}
+ if use doc; then
+ doins -r usermanual || die "install documentation failed"
+ fi
+ if use examples; then
+ doins -r samples || die "install examples failed"
+ fi
+}
diff --git a/media-gfx/engauge/engauge-5.2.ebuild b/media-gfx/engauge/engauge-5.2.ebuild
new file mode 100644
index 000000000000..45138748723e
--- /dev/null
+++ b/media-gfx/engauge/engauge-5.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit versionator qt4-r2 eutils
+
+DESCRIPTION="Convert an image file showing a graph or map into numbers"
+HOMEPAGE="http://digitizer.sourceforge.net/"
+SRC_URI="mirror://sourceforge/digitizer/${PN}_${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-qt/qt3support:4
+ dev-qt/qtgui:4[gif(+)]
+ sci-libs/fftw:3.0
+ x11-libs/libXft"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # Some patching and using the DEBIAN_PACKAGE ifdef is necessary to make sure the
+ # documentation is looked for in the proper directory
+ sed -i -e "s:/usr/share/doc/engauge-digitizer-doc/html:${ROOT}/usr/share/doc/${PF}/usermanual:" \
+ src/digitmain.cpp || die "sed failed"
+ sed -i -e '/unix {/a DEFINES += DEBIAN_PACKAGE' \
+ digitizer.pro || die "sed failed"
+}
+
+src_configure() {
+ eqmake4 digitizer.pro
+}
+
+src_install() {
+ dobin bin/engauge
+ newicon src/img/lo32-app-digitizer.png "${PN}.png"
+ make_desktop_entry engauge "Engauge Digitizer" ${PN} Graphics
+ insinto /usr/share/doc/${PF}
+ if use doc; then
+ doins -r usermanual || die "install documentation failed"
+ fi
+ if use examples; then
+ doins -r samples || die "install examples failed"
+ fi
+}
diff --git a/media-gfx/engauge/metadata.xml b/media-gfx/engauge/metadata.xml
new file mode 100644
index 000000000000..d1d947c94631
--- /dev/null
+++ b/media-gfx/engauge/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>calchan@gentoo.org</email>
+ <name>Denis Dupeyron</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">digitizer</remote-id>
+ </upstream>
+</pkgmetadata>