summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-01-09 11:14:50 -0800
committerMatt Turner <mattst88@gentoo.org>2022-01-09 11:41:40 -0800
commitfc4992044cd948217c3db12ee994cc0a14e06a8b (patch)
treea18a2417b8ea25ebac4a6436d785318850b020f0 /media-gfx/eog-plugins
parentmail-client/evolution: Version bump to 3.42.3 (diff)
downloadgentoo-fc4992044cd948217c3db12ee994cc0a14e06a8b.tar.gz
gentoo-fc4992044cd948217c3db12ee994cc0a14e06a8b.tar.bz2
gentoo-fc4992044cd948217c3db12ee994cc0a14e06a8b.zip
media-gfx/eog-plugins: Version bump to 3.26.8
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-gfx/eog-plugins')
-rw-r--r--media-gfx/eog-plugins/Manifest1
-rw-r--r--media-gfx/eog-plugins/eog-plugins-3.26.8.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/media-gfx/eog-plugins/Manifest b/media-gfx/eog-plugins/Manifest
index f3e10c91fcc1..a2909f1ae8da 100644
--- a/media-gfx/eog-plugins/Manifest
+++ b/media-gfx/eog-plugins/Manifest
@@ -1 +1,2 @@
DIST eog-plugins-3.26.7.tar.xz 482336 BLAKE2B 9cd1d7e16f8e7f1fe06c3bc2ea79ab06c397beaf9d9bfb26568ad5fb90a144ceab11f6250c7dd51ebb5d3962fff47a4c855b85725b95abca07cdc4de739a2b7e SHA512 c9312eccc5529b01cb285a165c833243ea60bb12f8be6f40ccc6da0db1bd951916000a48aa31705b048659e8d637aa7e56d761fe0f9be720a4e0ce81289d2b83
+DIST eog-plugins-3.26.8.tar.xz 479356 BLAKE2B ab781311473e045ffbb88e741427ac59f129fa53e6c551231d7b6edae81d21483dd1f1e7874561dfa29c9e9b2ba01fbdb174302bf8363478b785ec2ce38c53ec SHA512 a58aa849b09761dd0c7f7d31098560969872b03788f3f3ee81445dfb9be653b29e0e6646abc4e0164e4146abf7a9d2e6aadf56071f71c119493dcf1fd706a069
diff --git a/media-gfx/eog-plugins/eog-plugins-3.26.8.ebuild b/media-gfx/eog-plugins/eog-plugins-3.26.8.ebuild
new file mode 100644
index 000000000000..bb6d66aaee22
--- /dev/null
+++ b/media-gfx/eog-plugins/eog-plugins-3.26.8.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Eye of GNOME plugins"
+HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+exif map picasa +python"
+REQUIRED_USE="
+ map? ( exif )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/libpeas-0.7.4:=
+ >=media-gfx/eog-3.15.90
+ >=x11-libs/gtk+-3.14:3
+ exif? ( >=media-libs/libexif-0.6.16 )
+ map? (
+ media-libs/libchamplain:0.12[gtk]
+ >=media-libs/clutter-1.9.4:1.0
+ >=media-libs/clutter-gtk-1.1.2:1.0 )
+ picasa? ( >=dev-libs/libgdata-0.9.1:= )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.32:2[dbus]
+ dev-libs/libpeas:=[gtk,python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ gnome-base/gsettings-desktop-schemas
+ media-gfx/eog[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local plugins="fit-to-width,send-by-mail,hide-titlebar,light-theme"
+ use exif && plugins="${plugins},exif-display"
+ use map && plugins="${plugins},map"
+ use picasa && plugins="${plugins},postasa"
+ use python && plugins="${plugins},slideshowshuffle,pythonconsole,fullscreenbg,export-to-folder,maximize-windows"
+ gnome2_src_configure \
+ $(use_enable python) \
+ --with-plugins=${plugins}
+}
+
+src_install() {
+ default
+ mv "${ED}"/usr/share/{appdata,metainfo}
+ find "${ED}" -type f -name "*.la" -delete || die
+}