summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEttore Di Giacinto <mudler@gentoo.org>2016-10-21 21:20:47 +0200
committerEttore Di Giacinto <mudler@gentoo.org>2016-11-24 23:21:07 +0100
commitacbad4c0ebdbea19de68d0a51f782e3f719dd1ce (patch)
tree7d15f6c5d7d050e7f7e6e96b31eef4840f753680 /media-gfx/eom/files
parentapp-arch/engrampa: Drop 1.10.x (diff)
downloadgentoo-acbad4c0ebdbea19de68d0a51f782e3f719dd1ce.tar.gz
gentoo-acbad4c0ebdbea19de68d0a51f782e3f719dd1ce.tar.bz2
gentoo-acbad4c0ebdbea19de68d0a51f782e3f719dd1ce.zip
media-gfx/eom: Drop 1.10.x
Package-Manager: portage-2.3.1
Diffstat (limited to 'media-gfx/eom/files')
-rw-r--r--media-gfx/eom/files/eom-1.10-fix-introspection.patch169
-rw-r--r--media-gfx/eom/files/eom-cve-2013-7447.patch28
2 files changed, 0 insertions, 197 deletions
diff --git a/media-gfx/eom/files/eom-1.10-fix-introspection.patch b/media-gfx/eom/files/eom-1.10-fix-introspection.patch
deleted file mode 100644
index 71e20ea02ccb..000000000000
--- a/media-gfx/eom/files/eom-1.10-fix-introspection.patch
+++ /dev/null
@@ -1,169 +0,0 @@
-From 3d34cc10a5e62686f661a6653d43e2c42e6a26a2 Mon Sep 17 00:00:00 2001
-From: Sorokin Alexei <sor.alexei@meowr.ru>
-Date: Sat, 12 Dec 2015 16:49:22 +0300
-Subject: [PATCH] Fix compilation with enabled GObject Introspection
-
----
- configure.ac | 2 ++
- src/main.c | 2 +-
- 2 files changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index 9b829d0..b3d398f 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -142,6 +142,8 @@ else
- have_introspection=no
- fi
-
-+AM_CONDITIONAL(HAVE_INTROSPECTION, test "x$have_introspection" = xyes)
-+
- # ***************
- # ZLIB (required)
- # ***************
-diff --git a/src/main.c b/src/main.c
-index cc999e2..f1b92f7 100644
---- a/src/main.c
-+++ b/src/main.c
-@@ -30,7 +30,7 @@
- #include <dbus/dbus-glib-bindings.h>
- #include <gdk/gdkx.h>
- #endif
--#ifdef HAVE_INSTROSPECTION
-+#ifdef HAVE_INTROSPECTION
- #include <girepository.h>
- #endif
-
-From d6f68de8ed0722fdfecca9f81d68f2a0ff9b82bd Mon Sep 17 00:00:00 2001
-From: Wolfgang Ulbrich <chat-to-me@raveit.de>
-Date: Sun, 6 Dec 2015 23:58:24 +0100
-Subject: [PATCH] fix some gobject-introspection build warnings
-
----
- src/uta.c | 30 ++++++++++++++----------------
- 1 file changed, 14 insertions(+), 16 deletions(-)
-
-diff --git a/src/uta.c b/src/uta.c
-index 8df97bc..c44834d 100644
---- a/src/uta.c
-+++ b/src/uta.c
-@@ -38,9 +38,7 @@
- be variables. They can also be pstruct->el lvalues. */
- #define eom_expand(p, type, max) do { if(max) { p = eom_renew (p, type, max <<= 1); } else { max = 1; p = g_new(type, 1); } } while (0)
-
--
--
--/**
-+/*
- * eom_uta_new: Allocate a new uta.
- * @x0: Left coordinate of uta.
- * @y0: Top coordinate of uta.
-@@ -51,7 +49,7 @@
- * tiles, not pixels.
- *
- * Returns: the newly allocated #EomUta.
-- **/
-+ */
- static EomUta *
- eom_uta_new (int x0, int y0, int x1, int y1)
- {
-@@ -68,13 +66,13 @@ eom_uta_new (int x0, int y0, int x1, int y1)
- return uta;
- }
-
--/**
-+/*
- * eom_uta_free: Free a uta.
- * @uta: The uta to free.
- *
- * Frees the microtile array structure, including the actual microtile
- * data.
-- **/
-+ */
- void
- eom_uta_free (EomUta *uta)
- {
-@@ -82,14 +80,14 @@ eom_uta_free (EomUta *uta)
- g_free (uta);
- }
-
--/**
-+/*
- * eom_irect_intersect: Find intersection of two integer rectangles.
- * @dest: Where the result is stored.
- * @src1: A source rectangle.
- * @src2: Another source rectangle.
- *
- * Finds the intersection of @src1 and @src2.
-- **/
-+ */
- void
- eom_irect_intersect (EomIRect *dest, const EomIRect *src1, const EomIRect *src2) {
- dest->x0 = MAX (src1->x0, src2->x0);
-@@ -98,18 +96,18 @@ eom_irect_intersect (EomIRect *dest, const EomIRect *src1, const EomIRect *src2)
- dest->y1 = MIN (src1->y1, src2->y1);
- }
-
--/**
-+/*
- * eom_irect_empty: Determine whether integer rectangle is empty.
- * @src: The source rectangle.
- *
- * Return value: TRUE if @src is an empty rectangle, FALSE otherwise.
-- **/
-+ */
- int
- eom_irect_empty (const EomIRect *src) {
- return (src->x1 <= src->x0 || src->y1 <= src->y0);
- }
-
--/**
-+/*
- * eom_uta_from_irect: Generate uta covering a rectangle.
- * @bbox: The source rectangle.
- *
-@@ -117,7 +115,7 @@ eom_irect_empty (const EomIRect *src) {
- * function with a @bbox with zero height or width.
- *
- * Return value: the new uta.
-- **/
-+ */
- static EomUta *
- eom_uta_from_irect (EomIRect *bbox)
- {
-@@ -217,7 +215,7 @@ eom_uta_from_irect (EomIRect *bbox)
- * big enough to fit the specified microtile coordinates, or a new array if
- * it needed to be grown. In the second case, the original @uta will be
- * freed automatically.
-- **/
-+ */
- EomUta *
- uta_ensure_size (EomUta *uta, int x1, int y1, int x2, int y2)
- {
-@@ -284,7 +282,7 @@ uta_ensure_size (EomUta *uta, int x1, int y1, int x2, int y2)
- * Return value: The original @uta, or a new microtile array if the original one
- * needed to be grown to fit the specified rectangle. In the second case, the
- * original @uta will be freed automatically.
-- **/
-+ */
- EomUta *
- uta_add_rect (EomUta *uta, int x1, int y1, int x2, int y2)
- {
-@@ -552,7 +550,7 @@ uta_add_rect (EomUta *uta, int x1, int y1, int x2, int y2)
- * Removes a rectangular region from the specified microtile array. Due to the
- * way microtile arrays represent regions, the tiles at the edge of the
- * rectangle may not be clipped exactly.
-- **/
-+ */
- void
- uta_remove_rect (EomUta *uta, int x1, int y1, int x2, int y2)
- {
-@@ -1047,7 +1045,7 @@ copy_tile (EomUta *uta, int x, int y, int xofs, int yofs)
- * expanded if the destination area does not fit within it; rather only the area
- * that fits will be copied. The source rectangle must be completely contained
- * within the microtile array.
-- **/
-+ */
- void
- uta_copy_area (EomUta *uta, int src_x, int src_y, int dest_x, int dest_y, int width, int height)
- {
diff --git a/media-gfx/eom/files/eom-cve-2013-7447.patch b/media-gfx/eom/files/eom-cve-2013-7447.patch
deleted file mode 100644
index 410b433eb34a..000000000000
--- a/media-gfx/eom/files/eom-cve-2013-7447.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From b7849cc5b6e7fd741ef04e334f586266a444ef8a Mon Sep 17 00:00:00 2001
-From: monsta <monsta@inbox.ru>
-Date: Wed, 10 Feb 2016 14:52:54 +0300
-Subject: [PATCH] avoid integer overflow when allocating a large block of
- memory
-
-it's the same issue as in gdk_cairo_set_source_pixbuf since the code
-is apparently copied from there.
-
-fix is taken from
-https://git.gnome.org/browse/gtk+/commit?id=894b1ae76a32720f4bb3d39cf460402e3ce331d6
----
- src/eom-print-preview.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/eom-print-preview.c b/src/eom-print-preview.c
-index f9f005f..7dc2a8a 100644
---- a/src/eom-print-preview.c
-+++ b/src/eom-print-preview.c
-@@ -732,7 +732,7 @@ create_surface_from_pixbuf (GdkPixbuf *pixbuf)
- format = CAIRO_FORMAT_ARGB32;
-
- cairo_stride = cairo_format_stride_for_width (format, width);
-- cairo_pixels = g_malloc (height * cairo_stride);
-+ cairo_pixels = g_malloc_n (height, cairo_stride);
- surface = cairo_image_surface_create_for_data ((unsigned char *)cairo_pixels,
- format,
- width, height, cairo_stride);