summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2020-10-06 08:34:59 +0200
committerAlfredo Tupone <tupone@gentoo.org>2020-10-06 08:34:59 +0200
commit649287aaab870763cf8a436e4212b57a6fcf0c02 (patch)
tree57197ef402635ba6eaad878bd1d778b9ee457f6a /media-gfx/exact-image
parentapp-admin/ansible-base: remove possible dep loop (diff)
downloadgentoo-649287aaab870763cf8a436e4212b57a6fcf0c02.tar.gz
gentoo-649287aaab870763cf8a436e4212b57a6fcf0c02.tar.bz2
gentoo-649287aaab870763cf8a436e4212b57a6fcf0c02.zip
media-gfx/exact-image: fix to work with php7
Closes: https://bugs.gentoo.org/651072 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'media-gfx/exact-image')
-rw-r--r--media-gfx/exact-image/exact-image-1.0.2.ebuild1
-rw-r--r--media-gfx/exact-image/files/exact-image-1.0.2-php.patch11
2 files changed, 12 insertions, 0 deletions
diff --git a/media-gfx/exact-image/exact-image-1.0.2.ebuild b/media-gfx/exact-image/exact-image-1.0.2.ebuild
index 2c2e93b4fffd..62b39e9d7e4d 100644
--- a/media-gfx/exact-image/exact-image-1.0.2.ebuild
+++ b/media-gfx/exact-image/exact-image-1.0.2.ebuild
@@ -40,6 +40,7 @@ PATCHES=(
"${FILESDIR}"/${P}-gcc6.patch
"${FILESDIR}"/${P}-g++.patch
"${FILESDIR}"/${P}-dcraw.patch
+ "${FILESDIR}"/${P}-php.patch
)
src_prepare() {
diff --git a/media-gfx/exact-image/files/exact-image-1.0.2-php.patch b/media-gfx/exact-image/files/exact-image-1.0.2-php.patch
new file mode 100644
index 000000000000..787d71335f38
--- /dev/null
+++ b/media-gfx/exact-image/files/exact-image-1.0.2-php.patch
@@ -0,0 +1,11 @@
+--- a/api/php/Makefile 2020-10-06 08:28:04.511865454 +0200
++++ b/api/php/Makefile 2020-10-06 08:28:18.109638538 +0200
+@@ -8,7 +8,7 @@
+
+ $($(X_MODULE)_OUTPUT)/api-php-wrap.cc: $(X_MODULE)/../api.hh $(X_MODULE)/../api-swig.hh
+ $(Q)echo " SWIG $(dir $@)"
+- $(Q)swig -php5 -c++ -outdir $(dir $@) -o '$@' $(X_MODULE)/../api-swig.hh
++ $(Q)swig -php7 -c++ -outdir $(dir $@) -o '$@' $(X_MODULE)/../api-swig.hh
+
+ # we have an own install
+ _X_BUILD_IMPLICIT := $(_X_BUILD_IMPLICIT)