summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/fontforge/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/fontforge/files')
-rw-r--r--media-gfx/fontforge/files/fontforge-20110222-libz.so-linkage.patch66
-rw-r--r--media-gfx/fontforge/files/fontforge-20110222-lxkbui.patch13
-rw-r--r--media-gfx/fontforge/files/fontforge-20110222-remove-useless-extern.patch11
-rw-r--r--media-gfx/fontforge/files/fontforge-desktop.patch16
-rw-r--r--media-gfx/fontforge/files/fontforge-py27.diff11
5 files changed, 117 insertions, 0 deletions
diff --git a/media-gfx/fontforge/files/fontforge-20110222-libz.so-linkage.patch b/media-gfx/fontforge/files/fontforge-20110222-libz.so-linkage.patch
new file mode 100644
index 000000000000..7e01e8a3a76f
--- /dev/null
+++ b/media-gfx/fontforge/files/fontforge-20110222-libz.so-linkage.patch
@@ -0,0 +1,66 @@
+https://bugs.gentoo.org/show_bug.cgi?id=367425
+
+diff -ruN fontforge-20110222~/fontforge/parsepdf.c fontforge-20110222/fontforge/parsepdf.c
+--- fontforge-20110222~/fontforge/parsepdf.c 2011-02-15 05:37:39.000000000 +0200
++++ fontforge-20110222/fontforge/parsepdf.c 2011-05-17 22:19:56.000000000 +0300
+@@ -759,7 +759,11 @@
+ if ( zlib!=NULL )
+ return( true );
+
+- if ( (zlib = dlopen("libz" SO_EXT,RTLD_GLOBAL|RTLD_LAZY))==NULL ) {
++ if ( (zlib = dlopen("libz" SO_EXT,RTLD_GLOBAL|RTLD_LAZY))==NULL
++#ifdef SO_1_EXT
++ && (zlib = dlopen("libz" SO_1_EXT,RTLD_LAZY))==NULL
++#endif
++ ) {
+ LogError( "%s", dlerror());
+ return( false );
+ }
+diff -ruN fontforge-20110222~/fontforge/svg.c fontforge-20110222/fontforge/svg.c
+--- fontforge-20110222~/fontforge/svg.c 2011-02-18 23:33:27.000000000 +0200
++++ fontforge-20110222/fontforge/svg.c 2011-05-17 22:19:56.000000000 +0300
+@@ -1153,7 +1153,11 @@
+ if ( xmltested )
+ return( libxml!=NULL );
+
+- dlopen("libz" SO_EXT,RTLD_GLOBAL|RTLD_LAZY);
++ dlopen("libz" SO_EXT,RTLD_GLOBAL|RTLD_LAZY)
++#ifdef SO_1_EXT
++ || dlopen("libz" SO_1_EXT,RTLD_LAZY)
++#endif
++ ;
+
+ libxml = dlopen( "libxml2" SO_EXT,RTLD_LAZY);
+ # ifdef SO_2_EXT
+diff -ruN fontforge-20110222~/fontforge/ufo.c fontforge-20110222/fontforge/ufo.c
+--- fontforge-20110222~/fontforge/ufo.c 2011-02-17 02:20:37.000000000 +0200
++++ fontforge-20110222/fontforge/ufo.c 2011-05-17 22:19:56.000000000 +0300
+@@ -929,7 +929,11 @@
+ if ( xmltested )
+ return( libxml!=NULL );
+
+- dlopen("libz" SO_EXT,RTLD_GLOBAL|RTLD_LAZY);
++ dlopen("libz" SO_EXT,RTLD_GLOBAL|RTLD_LAZY)
++#ifdef SO_1_EXT
++ || dlopen("libz" SO_1_EXT,RTLD_LAZY)
++#endif
++ ;
+
+ libxml = dlopen( "libxml2" SO_EXT,RTLD_LAZY);
+ # ifdef SO_2_EXT
+diff -ruN fontforge-20110222~/fontforge/woff.c fontforge-20110222/fontforge/woff.c
+--- fontforge-20110222~/fontforge/woff.c 2011-02-15 05:37:40.000000000 +0200
++++ fontforge-20110222/fontforge/woff.c 2011-05-17 22:19:56.000000000 +0300
+@@ -76,7 +76,11 @@
+ if ( zlib!=NULL )
+ return( true );
+
+- if ( (zlib = dlopen("libz" SO_EXT,RTLD_GLOBAL|RTLD_LAZY))==NULL ) {
++ if ( (zlib = dlopen("libz" SO_EXT,RTLD_GLOBAL|RTLD_LAZY))==NULL
++#ifdef SO_1_EXT
++ && (zlib = dlopen("libz" SO_1_EXT,RTLD_LAZY))==NULL
++#endif
++ ) {
+ LogError( "%s", dlerror());
+ return( false );
+ }
diff --git a/media-gfx/fontforge/files/fontforge-20110222-lxkbui.patch b/media-gfx/fontforge/files/fontforge-20110222-lxkbui.patch
new file mode 100644
index 000000000000..b344bc9dc838
--- /dev/null
+++ b/media-gfx/fontforge/files/fontforge-20110222-lxkbui.patch
@@ -0,0 +1,13 @@
+=== modified file 'configure.in'
+--- a/configure.in
++++ b/configure.in
+@@ -36,7 +36,7 @@
+ dnl /usr/share/doc/XFree86-doc-4.2.0/Xi/lib.PS
+
+ AC_CHECK_LIB(Xi, XOpenDevice, X_11LIB="-lXi -lX11" ,AC_DEFINE(_NO_XINPUT), $X_LIBS $X_PRE_LIBS $X_EXTRA_LIBS -lX11 )
+- AC_CHECK_LIB(xkbui, XkbQueryExtension, X_11LIB="$X_11LIB -lxkbui" ,AC_DEFINE(_NO_XKB), $X_LIBS $X_PRE_LIBS $X_EXTRA_LIBS -lX11 -lm )
++ AC_CHECK_LIB(X11, XkbQueryExtension, ,AC_DEFINE(_NO_XKB), $X_LIBS $X_PRE_LIBS $X_EXTRA_LIBS -lX11 -lm )
+ fi
+
+ gww_define_caps_for_alt="dontknow"
+
diff --git a/media-gfx/fontforge/files/fontforge-20110222-remove-useless-extern.patch b/media-gfx/fontforge/files/fontforge-20110222-remove-useless-extern.patch
new file mode 100644
index 000000000000..f7e7152f2eaf
--- /dev/null
+++ b/media-gfx/fontforge/files/fontforge-20110222-remove-useless-extern.patch
@@ -0,0 +1,11 @@
+diff -Naur fontforge-20110222.orig/gutils/gimagereadrgb.c fontforge-20110222/gutils/gimagereadrgb.c
+--- fontforge-20110222.orig/gutils/gimagereadrgb.c 2013-05-05 18:03:18.884623199 +0000
++++ fontforge-20110222/gutils/gimagereadrgb.c 2013-05-05 18:03:35.452624126 +0000
+@@ -86,7 +86,6 @@
+
+ static void find_scanline(FILE *fp,struct sgiheader *header,int cur,
+ unsigned long *starttab,unsigned char **ptrtab) {
+- extern int fgetc(FILE *);
+ int (*getthingamy)(FILE *) = header->bpc==1?fgetc:getshort;
+ int ch,i,cnt,val;
+ unsigned char *pt;
diff --git a/media-gfx/fontforge/files/fontforge-desktop.patch b/media-gfx/fontforge/files/fontforge-desktop.patch
new file mode 100644
index 000000000000..ba8ac1078152
--- /dev/null
+++ b/media-gfx/fontforge/files/fontforge-desktop.patch
@@ -0,0 +1,16 @@
+diff --git a/Packaging/fontforge.desktop b/Packaging/fontforge.desktop
+index a66b28b..18e049c 100644
+--- a/Packaging/fontforge.desktop
++++ b/Packaging/fontforge.desktop
+@@ -8,9 +8,8 @@ Comment[ru]=Редактор шрифтов
+ Comment[fr]=Un constructeur des polices
+ Comment[zh_TW]=FontForge 描邊字型編輯器
+ Exec=fontforge
+-Icon=fontforge.png
++Icon=fontforge
+ Terminal=false
+ Type=Application
+-Categories=Application;Graphics;
+-Encoding=UTF-8
++Categories=Graphics;
+ MimeType=application/vnd.font-fontforge-sfd;application/x-font-ttf;application/x-font-otf;application/x-font-type1;application/x-font-bdf;application/x-font-pcf;application/x-font-tex;
diff --git a/media-gfx/fontforge/files/fontforge-py27.diff b/media-gfx/fontforge/files/fontforge-py27.diff
new file mode 100644
index 000000000000..24f98e13cb30
--- /dev/null
+++ b/media-gfx/fontforge/files/fontforge-py27.diff
@@ -0,0 +1,11 @@
+--- fontforge/ffpython.h 2010/02/04 17:42:36 1.8
++++ fontforge/ffpython.h 2010/09/12 08:30:00 1.9
+@@ -62,7 +62,7 @@
+ #define PyMODINIT_FUNC void
+ #endif
+
+-#if PY_MAJOR_VERSION < 2 || (PY_MAJOR_VERSION == 2 && PY_MINOR_VERSION <= 5)
++#if PY_MAJOR_VERSION < 2 || (PY_MAJOR_VERSION == 2 && PY_MINOR_VERSION <= 7)
+ #define PyBytesObject PyStringObject
+ #define PyBytes_Type PyString_Type
+