summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2021-06-21 02:39:35 +0200
committerSam James <sam@gentoo.org>2021-06-21 23:25:59 +0100
commit6628a9ab320db0de0a112215db0d3d586f282838 (patch)
tree18a3f21facebca9edf96457a3db0a45836673471 /media-gfx/freecad
parentmedia-gfx/freecad: improve display of optional packages (diff)
downloadgentoo-6628a9ab320db0de0a112215db0d3d586f282838.tar.gz
gentoo-6628a9ab320db0de0a112215db0d3d586f282838.tar.bz2
gentoo-6628a9ab320db0de0a112215db0d3d586f282838.zip
media-gfx/freecad: sync changes from 0.19.2
- support sci-libs/opencascade-7.5.2 - support sci-libs/vtk-9 - add more optfeature's Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/21350 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/freecad')
-rw-r--r--media-gfx/freecad/freecad-9999.ebuild33
1 files changed, 26 insertions, 7 deletions
diff --git a/media-gfx/freecad/freecad-9999.ebuild b/media-gfx/freecad/freecad-9999.ebuild
index b96f2771615e..3d41d5d0ca12 100644
--- a/media-gfx/freecad/freecad-9999.ebuild
+++ b/media-gfx/freecad/freecad-9999.ebuild
@@ -19,7 +19,8 @@ if [[ ${PV} = *9999 ]]; then
else
MY_PV=$(ver_cut 1-2)
MY_PV=$(ver_rs 1 '_' ${MY_PV})
- SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz
+ https://raw.githubusercontent.com/waebbl/waebbl-gentoo/master/patches/${P}-0005-Make-smesh-compile-with-vtk9.patch.xz"
KEYWORDS="~amd64"
S="${WORKDIR}/FreeCAD-${PV}"
fi
@@ -68,7 +69,7 @@ RDEPEND="
sci-libs/flann[openmp]
sci-libs/hdf5:=[fortran,zlib]
>=sci-libs/med-4.0.0-r1[python,${PYTHON_SINGLE_USEDEP}]
- <sci-libs/opencascade-7.5.2:=[vtk(+)]
+ sci-libs/opencascade:=[vtk(+)]
sci-libs/orocos_kdl:=
sys-libs/zlib
virtual/glu
@@ -78,9 +79,9 @@ RDEPEND="
dev-libs/openssl:=
net-misc/curl
)
- fem? ( <sci-libs/vtk-9[boost,python,qt5,rendering,${PYTHON_SINGLE_USEDEP}] )
+ fem? ( sci-libs/vtk[boost,python,qt5,rendering,${PYTHON_SINGLE_USEDEP}] )
openscad? ( media-gfx/openscad )
- pcl? ( >=sci-libs/pcl-1.8.1:=[opengl,openni2(+),qt5(+),vtk(+)] )
+ pcl? ( ~sci-libs/pcl-${PV}:=[opengl,openni2(+),qt5(+),vtk(+)] )
$(python_gen_cond_dep '
dev-libs/boost:=[python,threads(+),${PYTHON_MULTI_USEDEP}]
dev-python/matplotlib[${PYTHON_MULTI_USEDEP}]
@@ -319,15 +320,33 @@ pkg_postinst() {
einfo "You can load a lot of additional workbenches using the integrated"
einfo "AddonManager."
+ # ToDo: check opencv, pysolar (::science), elmerfem (::science)
+ # ifc++, ifcopenshell, netgen, z88 (no pkgs), calculix-ccx (::waebbl)
einfo "There are a lot of additional tools, for which FreeCAD has builtin"
einfo "support. Some of them are available in Gentoo. Take a look at"
einfo "https://wiki.freecadweb.org/Installing#External_software_supported_by_FreeCAD"
- optfeature "interact with git repositories" dev-python/GitPython
- optfeature "work with COLLADA documents" dev-python/pycollada
+ optfeature_header "Computational utilities"
+ optfeature "numerical computations with Python" dev-python/numpy
+ optfeature "BLAS library" sci-libs/openblas
+ optfeature "statistical computation with Python" dev-python/pandas
+ optfeature "usage of Point Clouds" sci-libs/pcl
+ optfeature "scientific computation with Python" dev-python/scipy
+ optfeature "symbolic math with Python" dev-python/sympy
+ optfeature_header "Imaging, Plotting and Rendering utilities"
+ optfeature "function plotting with Python" dev-python/matplotlib
optfeature "dependency graphs" media-gfx/graphviz
optfeature "PBR Rendering" media-gfx/povray
- optfeature "FEM mesh generator" sci-libs/gmsh
+ optfeature_header "Import / Export"
+ optfeature "interacting with git repositories" dev-python/GitPython
+ optfeature "working with COLLADA documents" dev-python/pycollada
+ optfeature "YAML importer and emitter" dev-python/pyyaml
optfeature "importing and exporting 2D AutoCAD DWG files" media-gfx/libredwg
+ optfeature "importing and exporting geospatial data formats" sci-libs/gdal
+ optfeature "working with projection data" sci-libs/proj
+ optfeature_header "Meshing and FEM"
+ optfeature "FEM mesh generator" sci-libs/gmsh
+ optfeature "triangulating meshes" sci-libs/gts
+ optfeature "visualization" sci-visualization/paraview
}
pkg_postrm() {