summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-07-17 20:16:06 +0200
committerDavid Seifert <soap@gentoo.org>2021-07-17 20:16:06 +0200
commit9b414b59d10e3c2f535b9aea289e0f7702a4fd7b (patch)
tree5d07c73987ea0b952eca3533b6c9a65832314690 /media-gfx/freecad
parentmedia-gfx/eog-plugins: PYTHON_MULTI_USEDEP -> PYTHON_USEDEP (diff)
downloadgentoo-9b414b59d10e3c2f535b9aea289e0f7702a4fd7b.tar.gz
gentoo-9b414b59d10e3c2f535b9aea289e0f7702a4fd7b.tar.bz2
gentoo-9b414b59d10e3c2f535b9aea289e0f7702a4fd7b.zip
media-gfx/freecad: PYTHON_MULTI_USEDEP -> PYTHON_USEDEP
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-gfx/freecad')
-rw-r--r--media-gfx/freecad/freecad-0.19.2-r3.ebuild20
-rw-r--r--media-gfx/freecad/freecad-9999.ebuild20
2 files changed, 20 insertions, 20 deletions
diff --git a/media-gfx/freecad/freecad-0.19.2-r3.ebuild b/media-gfx/freecad/freecad-0.19.2-r3.ebuild
index 954e1f8b1fed..70fb0270fb59 100644
--- a/media-gfx/freecad/freecad-0.19.2-r3.ebuild
+++ b/media-gfx/freecad/freecad-0.19.2-r3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8,9} )
inherit check-reqs cmake desktop eapi8-dosym optfeature python-single-r1 xdg
@@ -83,15 +83,15 @@ RDEPEND="
openscad? ( media-gfx/openscad )
pcl? ( >=sci-libs/pcl-1.8.1:=[opengl,openni2(+),qt5(+),vtk(+)] )
$(python_gen_cond_dep '
- dev-libs/boost:=[python,threads(+),${PYTHON_MULTI_USEDEP}]
- dev-python/matplotlib[${PYTHON_MULTI_USEDEP}]
- dev-python/numpy[${PYTHON_MULTI_USEDEP}]
- >=dev-python/pivy-0.6.5[${PYTHON_MULTI_USEDEP}]
- dev-python/pybind11[${PYTHON_MULTI_USEDEP}]
- dev-python/pyside2[gui,svg,${PYTHON_MULTI_USEDEP}]
- dev-python/shiboken2[${PYTHON_MULTI_USEDEP}]
- addonmgr? ( dev-python/GitPython[${PYTHON_MULTI_USEDEP}] )
- fem? ( dev-python/ply[${PYTHON_MULTI_USEDEP}] )
+ dev-libs/boost:=[python,threads(+),${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pivy-0.6.5[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ dev-python/pyside2[gui,svg,${PYTHON_USEDEP}]
+ dev-python/shiboken2[${PYTHON_USEDEP}]
+ addonmgr? ( dev-python/GitPython[${PYTHON_USEDEP}] )
+ fem? ( dev-python/ply[${PYTHON_USEDEP}] )
')
"
DEPEND="${RDEPEND}"
diff --git a/media-gfx/freecad/freecad-9999.ebuild b/media-gfx/freecad/freecad-9999.ebuild
index cb6c6efe011b..8c0caca6adc6 100644
--- a/media-gfx/freecad/freecad-9999.ebuild
+++ b/media-gfx/freecad/freecad-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8,9} )
inherit check-reqs cmake desktop eapi8-dosym optfeature python-single-r1 xdg
@@ -83,15 +83,15 @@ RDEPEND="
openscad? ( media-gfx/openscad )
pcl? ( ~sci-libs/pcl-${PV}:=[opengl,openni2(+),qt5(+),vtk(+)] )
$(python_gen_cond_dep '
- dev-libs/boost:=[python,threads(+),${PYTHON_MULTI_USEDEP}]
- dev-python/matplotlib[${PYTHON_MULTI_USEDEP}]
- dev-python/numpy[${PYTHON_MULTI_USEDEP}]
- >=dev-python/pivy-0.6.5[${PYTHON_MULTI_USEDEP}]
- dev-python/pybind11[${PYTHON_MULTI_USEDEP}]
- dev-python/pyside2[gui,svg,${PYTHON_MULTI_USEDEP}]
- dev-python/shiboken2[${PYTHON_MULTI_USEDEP}]
- addonmgr? ( dev-python/GitPython[${PYTHON_MULTI_USEDEP}] )
- fem? ( dev-python/ply[${PYTHON_MULTI_USEDEP}] )
+ dev-libs/boost:=[python,threads(+),${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pivy-0.6.5[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ dev-python/pyside2[gui,svg,${PYTHON_USEDEP}]
+ dev-python/shiboken2[${PYTHON_USEDEP}]
+ addonmgr? ( dev-python/GitPython[${PYTHON_USEDEP}] )
+ fem? ( dev-python/ply[${PYTHON_USEDEP}] )
')
"
DEPEND="${RDEPEND}"