summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2021-10-21 21:32:47 +0300
committerSam James <sam@gentoo.org>2021-10-22 02:47:02 +0000
commit4630ec6a49c982c3515b457393c3c2d5a04720de (patch)
tree9aa141585906d0ccb6ed1b71c53c75f8ff1c7884 /media-gfx/gimp
parentmedia-gfx/gimp: dev preview 2.99.8 version bump (diff)
downloadgentoo-4630ec6a49c982c3515b457393c3c2d5a04720de.tar.gz
gentoo-4630ec6a49c982c3515b457393c3c2d5a04720de.tar.bz2
gentoo-4630ec6a49c982c3515b457393c3c2d5a04720de.zip
media-gfx/gimp: update live ebuild
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/22661 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/gimp')
-rw-r--r--media-gfx/gimp/gimp-9999.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/media-gfx/gimp/gimp-9999.ebuild b/media-gfx/gimp/gimp-9999.ebuild
index 1519df009bc8..89e884dd1969 100644
--- a/media-gfx/gimp/gimp-9999.ebuild
+++ b/media-gfx/gimp/gimp-9999.ebuild
@@ -4,9 +4,9 @@
EAPI=7
LUA_COMPAT=( luajit )
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
GNOME2_EAUTORECONF=yes
-VALA_MIN_API_VERSION="0.40"
+VALA_MIN_API_VERSION="0.44"
VALA_USE_DEPEND=vapigen
inherit git-r3 gnome2 lua-single python-single-r1 toolchain-funcs vala virtualx
@@ -17,11 +17,12 @@ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/gimp.git"
SRC_URI=""
LICENSE="GPL-3 LGPL-3"
SLOT="0/3"
-KEYWORDS=""
-IUSE="aalib alsa aqua debug doc gnome heif javascript jpeg2k lua mng openexr postscript python udev unwind vala vector-icons webp wmf xpm cpu_flags_ppc_altivec cpu_flags_x86_mmx cpu_flags_x86_sse"
-REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
- python? ( ${PYTHON_REQUIRED_USE} )"
+IUSE="aalib alsa aqua doc gnome heif javascript jpeg2k lua mng openexr postscript python udev unwind vala vector-icons webp wmf xpm cpu_flags_ppc_altivec cpu_flags_x86_mmx cpu_flags_x86_sse"
+REQUIRED_USE="
+ lua? ( ${LUA_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
RESTRICT="!test? ( test )"
@@ -31,7 +32,7 @@ COMMON_DEPEND="
>=app-text/poppler-0.90.1[cairo]
>=app-text/poppler-data-0.4.9
>=dev-libs/atk-2.34.1
- >=dev-libs/glib-2.62.6:2
+ >=dev-libs/glib-2.68.0:2
>=dev-libs/json-glib-1.4.4
dev-libs/libxml2:2
dev-libs/libxslt
@@ -40,7 +41,7 @@ COMMON_DEPEND="
>=media-libs/babl-0.1.86[introspection,lcms,vala?]
>=media-libs/fontconfig-2.12.6
>=media-libs/freetype-2.10.2
- >=media-libs/gegl-0.4.30:0.4[cairo,introspection,lcms,vala?]
+ >=media-libs/gegl-0.4.32:0.4[cairo,introspection,lcms,vala?]
>=media-libs/gexiv2-0.10.10
>=media-libs/harfbuzz-2.6.5:=
>=media-libs/lcms-2.9:2
@@ -185,7 +186,6 @@ src_configure() {
$(use_enable cpu_flags_x86_mmx mmx)
$(use_enable cpu_flags_x86_sse sse)
$(use_enable doc gtk_doc)
- $(use_enable debug)
$(use_enable vector-icons)
$(use_with aalib aa)
$(use_with alsa)