summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/gliv/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/gliv/files')
-rw-r--r--media-gfx/gliv/files/gliv-1.9.6-as-needed.patch99
-rw-r--r--media-gfx/gliv/files/gliv-1.9.7-as-needed.patch87
-rw-r--r--media-gfx/gliv/files/gliv-1.9.7-destdir.patch15
3 files changed, 201 insertions, 0 deletions
diff --git a/media-gfx/gliv/files/gliv-1.9.6-as-needed.patch b/media-gfx/gliv/files/gliv-1.9.6-as-needed.patch
new file mode 100644
index 000000000000..3128b99e4435
--- /dev/null
+++ b/media-gfx/gliv/files/gliv-1.9.6-as-needed.patch
@@ -0,0 +1,99 @@
+--- gliv-1.9.6.orig/configure.ac 2005-09-21 23:05:57.000000000 +0200
++++ gliv-1.9.6/configure.ac 2010-01-03 15:51:41.464539460 +0100
+@@ -16,18 +16,17 @@
+ # Checks for programs.
+ AC_PROG_CC
+ AC_PROG_RANLIB
+-
++AC_USE_SYSTEM_EXTENSIONS
+
+ # Default CFLAGS.
+-if test "x$GCC" = "xyes" && test "$DEFAULT_CFLAGS" = "yes"; then
+- CFLAGS="-Wall -O2 -fomit-frame-pointer -ffast-math"
+-fi
+-CFLAGS="$CFLAGS -I${srcdir}/../lib"
++#if test "x$GCC" = "xyes" && test "$DEFAULT_CFLAGS" = "yes"; then
++# CFLAGS="-Wall -O2 -fomit-frame-pointer -ffast-math"
++#fi
++#CFLAGS="$CFLAGS -I${srcdir}/../lib"
+
+ # Checks for LFS flags, we may not handle big files, but it doesn't hurt.
+ AC_SYS_LARGEFILE
+
+-
+ AC_DEFUN([CHECK_MATH],
+ [OLD_CFLAGS="$CFLAGS"]
+ [CFLAGS="$CFLAGS -w"]
+@@ -127,35 +126,22 @@
+
+ # Checks for X.
+ AC_PATH_XTRA
+-CFLAGS="$X_CFLAGS $CFLAGS"
+-LDFLAGS="$X_PRE_LIBS $X_LIBS -lX11 $X_EXTRA_LIBS $LDFLAGS"
+
+ # Checks for GtkGLExt.
+ PKG_CHECK_MODULES(GTKGLEXT, [gtkglext-1.0 >= 0.7.0])
+-CFLAGS="$GTKGLEXT_CFLAGS $CFLAGS"
+-LDFLAGS="$GTKGLEXT_LIBS $LDFLAGS"
+ GTKGL_VERSION="$($PKG_CONFIG --modversion gtkglext-1.0)"
+
+ # Checks for OpenGL.
+-AC_TRY_LINK([#include "GL/gl.h"],
+- [glBegin(GL_QUADS);],
+- [ogl="yes"],
+- [ogl="no"])
+-
++AC_SEARCH_LIBS([glBegin],[GL],[ogl="yes"],[ogl="no"],)
+ if test "x$ogl" = "xno"; then
+ AC_MSG_NOTICE([maybe libGL requires libpthread...])
+- OLD_LDFLAGS="$LDFLAGS"
+- LDFLAGS="$LDFLAGS -lpthread"
+- AC_TRY_LINK([#include "GL/gl.h"],
+- [glBegin(GL_QUADS);],
+- [],
+- AC_MSG_ERROR([cannot use -lGL]))
++ AC_SEARCH_LIBS([glBegin],[GL],[ogl="yes"],[ogl="no"],[-lpthread])
+ fi
+
+ # Checks for gtk.
+ AM_PATH_GTK_2_0([2.6.0], [
+ CFLAGS="$GTK_CFLAGS $CFLAGS"
+- LDFLAGS="$GTK_LIBS $LDFLAGS"
++ LIBS="$LIBS $GTK_LIBS"
+ GTK_VERSION="$($PKG_CONFIG --modversion gtk+-2.0)"
+ ], [exit 1], [gthread])
+
+@@ -163,9 +149,6 @@
+ ALL_LINGUAS=$(echo po/*.po | sed -e 's|\.po||g' -e 's|po/||g')
+ AM_GNU_GETTEXT_VERSION
+ AM_GNU_GETTEXT
+-CFLAGS="$CFLAGS -I../${srcdir}/intl"
+-LIBS="$LIBS $LIBINTL"
+-
+
+ AC_CONFIG_FILES([
+ Makefile
+--- gliv-1.9.6.orig/src/Makefile.am 2006-11-18 15:21:13.000000000 +0100
++++ gliv-1.9.6/src/Makefile.am 2010-01-03 15:48:45.765539472 +0100
+@@ -64,6 +64,9 @@
+ gliv_LDADD = -L../lib -lreplacements
+ endif
+
++gliv_CFLAGS = @GTKGLEXT_CFLAGS@
++gliv_LDADD = @GTKGLEXT_LIBS@
++
+ AM_CPPFLAGS = -I$(srcdir)/include -D_REENTRANT -D_THREAD_SAFE \
+ -DSYSCONFDIR=\"$(sysconfdir)\"
+
+--- gliv-1.9.6.orig/po/Makefile.in.in 2006-11-18 15:21:13.000000000 +0100
++++ gliv-1.9.6/po/Makefile.in.in 2010-01-03 16:05:43.860539403 +0100
+@@ -29,7 +29,7 @@
+
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+-MKINSTALLDIRS = @MKINSTALLDIRS@
++MKINSTALLDIRS = $(top_srcdir)/mkinstalldirs
+ mkinstalldirs = $(SHELL) $(MKINSTALLDIRS)
+
+ GMSGFMT = @GMSGFMT@
+
diff --git a/media-gfx/gliv/files/gliv-1.9.7-as-needed.patch b/media-gfx/gliv/files/gliv-1.9.7-as-needed.patch
new file mode 100644
index 000000000000..6998e5fd988d
--- /dev/null
+++ b/media-gfx/gliv/files/gliv-1.9.7-as-needed.patch
@@ -0,0 +1,87 @@
+--- gliv-1.9.7.orig/configure.ac
++++ gliv-1.9.7/configure.ac
+@@ -17,18 +17,17 @@
+ # Checks for programs.
+ AC_PROG_CC
+ AC_PROG_RANLIB
+-
++AC_USE_SYSTEM_EXTENSIONS
+
+ # Default CFLAGS.
+-if test "x$GCC" = "xyes" && test "$DEFAULT_CFLAGS" = "yes"; then
+- CFLAGS="-Wall -O2 -fomit-frame-pointer -ffast-math"
+-fi
+-CFLAGS="$CFLAGS -I${srcdir}/../lib"
++#if test "x$GCC" = "xyes" && test "$DEFAULT_CFLAGS" = "yes"; then
++# CFLAGS="-Wall -O2 -fomit-frame-pointer -ffast-math"
++#fi
++#CFLAGS="$CFLAGS -I${srcdir}/../lib"
+
+ # Checks for LFS flags, we may not handle big files, but it doesn't hurt.
+ AC_SYS_LARGEFILE
+
+-
+ AC_DEFUN([CHECK_MATH],
+ [OLD_CFLAGS="$CFLAGS"]
+ [CFLAGS="$CFLAGS -w"]
+@@ -128,35 +127,22 @@
+
+ # Checks for X.
+ AC_PATH_XTRA
+-CFLAGS="$X_CFLAGS $CFLAGS"
+-LDFLAGS="$X_PRE_LIBS $X_LIBS -lX11 $X_EXTRA_LIBS $LDFLAGS"
+
+ # Checks for GtkGLExt.
+ PKG_CHECK_MODULES(GTKGLEXT, [gtkglext-1.0 >= 0.7.0])
+-CFLAGS="$GTKGLEXT_CFLAGS $CFLAGS"
+-LDFLAGS="$GTKGLEXT_LIBS $LDFLAGS"
+ GTKGL_VERSION="$($PKG_CONFIG --modversion gtkglext-1.0)"
+
+ # Checks for OpenGL.
+-AC_TRY_LINK([#include "GL/gl.h"],
+- [glBegin(GL_QUADS);],
+- [ogl="yes"],
+- [ogl="no"])
+-
++AC_SEARCH_LIBS([glBegin],[GL],[ogl="yes"],[ogl="no"],)
+ if test "x$ogl" = "xno"; then
+ AC_MSG_NOTICE([maybe libGL requires libpthread...])
+- OLD_LDFLAGS="$LDFLAGS"
+- LDFLAGS="$LDFLAGS -lpthread"
+- AC_TRY_LINK([#include "GL/gl.h"],
+- [glBegin(GL_QUADS);],
+- [],
+- AC_MSG_ERROR([cannot use -lGL]))
++ AC_SEARCH_LIBS([glBegin],[GL],[ogl="yes"],[ogl="no"],[-lpthread])
+ fi
+
+ # Checks for gtk.
+ AM_PATH_GTK_2_0([2.6.0], [
+ CFLAGS="$GTK_CFLAGS $CFLAGS"
+- LDFLAGS="$GTK_LIBS $LDFLAGS"
++ LIBS="$LIBS $GTK_LIBS"
+ GTK_VERSION="$($PKG_CONFIG --modversion gtk+-2.0)"
+ ], [exit 1], [gthread])
+
+@@ -164,9 +150,6 @@
+ ALL_LINGUAS=$(echo po/*.po | sed -e 's|\.po||g' -e 's|po/||g')
+ AM_GNU_GETTEXT_VERSION
+ AM_GNU_GETTEXT
+-CFLAGS="$CFLAGS -I../${srcdir}/intl"
+-LIBS="$LIBS $LIBINTL"
+-
+
+ AC_CONFIG_FILES([ intl/Makefile
+ Makefile
+--- gliv-1.9.7.orig/src/Makefile.am
++++ gliv-1.9.7/src/Makefile.am
+@@ -64,6 +64,9 @@
+ gliv_LDADD = -L../lib -lreplacements
+ endif
+
++gliv_CFLAGS = @GTKGLEXT_CFLAGS@
++gliv_LDADD = @GTKGLEXT_LIBS@
++
+ AM_CPPFLAGS = -I$(srcdir)/include -D_REENTRANT -D_THREAD_SAFE \
+ -DSYSCONFDIR=\"$(sysconfdir)\"
+
diff --git a/media-gfx/gliv/files/gliv-1.9.7-destdir.patch b/media-gfx/gliv/files/gliv-1.9.7-destdir.patch
new file mode 100644
index 000000000000..827c6adb10d8
--- /dev/null
+++ b/media-gfx/gliv/files/gliv-1.9.7-destdir.patch
@@ -0,0 +1,15 @@
+--- gliv-1.9.7/Makefile.am.orig
++++ gliv-1.9.7/Makefile.am
+@@ -31,9 +31,9 @@
+ @echo
+ @if desktop-file-install --help > /dev/null 2>&1; then \
+ echo "Installing the GLiv desktop file with desktop-file-install"; \
+- mkdir -p $(datadir)/{pixmaps,applications} || true; \
+- cp gliv.png $(datadir)/pixmaps/gliv.png || true; \
+- desktop-file-install --vendor=gnome --dir=$(datadir)/applications \
++ mkdir -p $(DESTDIR)$(datadir)/{pixmaps,applications} || true; \
++ cp gliv.png $(DESTDIR)$(datadir)/pixmaps/gliv.png || true; \
++ desktop-file-install --vendor=gnome --dir=$(DESTDIR)$(datadir)/applications \
+ gliv.desktop || true; \
+ else \
+ echo "No desktop-file-install(1), skipping gliv.desktop"; \