summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-11-10 23:25:14 +0000
committerMarek Szuba <marecki@gentoo.org>2022-11-10 23:26:42 +0000
commita16ca95eda19f52557b440b134dbc50e9fc7fcfd (patch)
tree3ff5df1bf256b583da30df378b1f76576ee7f995 /media-gfx/gmic
parentapp-metrics/collectd: fix compilation with python3_11 (diff)
downloadgentoo-a16ca95eda19f52557b440b134dbc50e9fc7fcfd.tar.gz
gentoo-a16ca95eda19f52557b440b134dbc50e9fc7fcfd.tar.bz2
gentoo-a16ca95eda19f52557b440b134dbc50e9fc7fcfd.zip
media-gfx/gmic: strip stray backslashes from grep calls
Since grep-3.8 the string '\ ' no longer matches a space. Closes: https://bugs.gentoo.org/880339 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'media-gfx/gmic')
-rw-r--r--media-gfx/gmic/files/gmic-3.1.6-grep38.patch27
-rw-r--r--media-gfx/gmic/gmic-3.1.6.ebuild1
2 files changed, 28 insertions, 0 deletions
diff --git a/media-gfx/gmic/files/gmic-3.1.6-grep38.patch b/media-gfx/gmic/files/gmic-3.1.6-grep38.patch
new file mode 100644
index 000000000000..ec1df70002c3
--- /dev/null
+++ b/media-gfx/gmic/files/gmic-3.1.6-grep38.patch
@@ -0,0 +1,27 @@
+Starting with version 3.8, grep no longer quietly ignores backslashes
+preceding a white-space character.
+
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -88,16 +88,16 @@
+ EXE =
+ WGET = wget --no-check-certificate --quiet -O
+ PLUGINDIR = $(shell gimptool-2.0 --gimpplugindir)/plug-ins
+-VERSION = $(shell grep 'gmic_version\ ' gmic.h | tail -c4 | head -c3)
+-VERSION1 = $(shell grep 'gmic_version\ ' gmic.h | tail -c4 | head -c1)
+-VERSION2 = $(shell grep 'gmic_version\ ' gmic.h | tail -c3 | head -c1)
+-VERSION3 = $(shell grep 'gmic_version\ ' gmic.h | tail -c2 | head -c1)
++VERSION = $(shell grep 'gmic_version ' gmic.h | tail -c4 | head -c3)
++VERSION1 = $(shell grep 'gmic_version ' gmic.h | tail -c4 | head -c1)
++VERSION2 = $(shell grep 'gmic_version ' gmic.h | tail -c3 | head -c1)
++VERSION3 = $(shell grep 'gmic_version ' gmic.h | tail -c2 | head -c1)
+ SVERSION=$(VERSION1).$(VERSION2).$(VERSION3)
+ SRC_PATH=$(shell pwd)
+
+ # Check that versions of files 'CImg.h' and 'gmic.h' match.
+ ifneq (,$(wildcard CImg.h))
+-CIMG_VERSION = $(shell grep 'cimg_version\ ' CImg.h | tail -c4 | head -c3)
++CIMG_VERSION = $(shell grep 'cimg_version ' CImg.h | tail -c4 | head -c3)
+ else
+ CIMG_VERSION = $(VERSION)
+ endif
diff --git a/media-gfx/gmic/gmic-3.1.6.ebuild b/media-gfx/gmic/gmic-3.1.6.ebuild
index da836f3b546c..85bb406d8cc0 100644
--- a/media-gfx/gmic/gmic-3.1.6.ebuild
+++ b/media-gfx/gmic/gmic-3.1.6.ebuild
@@ -67,6 +67,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-3.1.6-ar_so.patch
+ "${FILESDIR}"/${PN}-3.1.6-grep38.patch
"${FILESDIR}"/${PN}-3.1.6-makefile_automagic.patch
"${FILESDIR}"/${PN}-3.1.6-relative_rpath.patch
)