summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/gnome-raw-thumbnailer/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/gnome-raw-thumbnailer/files')
-rw-r--r--media-gfx/gnome-raw-thumbnailer/files/gnome-raw-thumbnailer-0.99.1-drop-libgsf.patch32
-rw-r--r--media-gfx/gnome-raw-thumbnailer/files/gnome-raw-thumbnailer-0.99.1-make-382.patch34
2 files changed, 66 insertions, 0 deletions
diff --git a/media-gfx/gnome-raw-thumbnailer/files/gnome-raw-thumbnailer-0.99.1-drop-libgsf.patch b/media-gfx/gnome-raw-thumbnailer/files/gnome-raw-thumbnailer-0.99.1-drop-libgsf.patch
new file mode 100644
index 000000000000..33cf2c65898d
--- /dev/null
+++ b/media-gfx/gnome-raw-thumbnailer/files/gnome-raw-thumbnailer-0.99.1-drop-libgsf.patch
@@ -0,0 +1,32 @@
+--- configure.ac
++++ configure.ac
+@@ -17,9 +17,9 @@
+
+ SCROLLKEEPER_REQUIRED=0.1.4
+
+-PKG_CHECK_MODULES(GSF, gnome-vfs-2.0 libgsf-gnome-1 gdk-pixbuf-2.0)
+-AC_SUBST(GSF_CFLAGS)
+-AC_SUBST(GSF_LIBS)
++PKG_CHECK_MODULES(GNOME, gnome-vfs-2.0 gdk-pixbuf-2.0)
++AC_SUBST(GNOME_CFLAGS)
++AC_SUBST(GNOME_LIBS)
+
+ PKG_CHECK_MODULES(OPENRAW, libopenraw-gnome-1.0 >= 0.0.4)
+ AC_SUBST(OPENRAW_CFLAGS)
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -2,7 +2,7 @@
+
+
+ INCLUDES = -I$(top_srcdir) \
+- $(GSF_CFLAGS) \
++ $(GNOME_CFLAGS) \
+ $(OPENRAW_CFLAGS) \
+ -DG_LOG_DOMAIN=\"raw-thumbnailer\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/$(DATADIRNAME)/locale"\" \
+@@ -15,4 +15,4 @@
+
+ raw_thumbnailer_SOURCES = raw-thumbnailer.c
+
+-raw_thumbnailer_LDADD = $(GSF_LIBS) $(OPENRAW_LIBS) $(INTLLIBS)
++raw_thumbnailer_LDADD = $(GNOME_LIBS) $(OPENRAW_LIBS) $(INTLLIBS)
diff --git a/media-gfx/gnome-raw-thumbnailer/files/gnome-raw-thumbnailer-0.99.1-make-382.patch b/media-gfx/gnome-raw-thumbnailer/files/gnome-raw-thumbnailer-0.99.1-make-382.patch
new file mode 100644
index 000000000000..411198977261
--- /dev/null
+++ b/media-gfx/gnome-raw-thumbnailer/files/gnome-raw-thumbnailer-0.99.1-make-382.patch
@@ -0,0 +1,34 @@
+http://bugs.gentoo.org/333715
+
+--- data/Makefile.am
++++ data/Makefile.am
+@@ -20,11 +20,11 @@
+
+ install-data-local: $(schema_DATA)
+ if GCONF_SCHEMAS_INSTALL
+- if test -z "$(DESTDIR)" ; then \
+- for p in $^ ; do \
+- GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $$p 2>&1 > /dev/null; \
+- done \
+- fi
++ if test -z "$(DESTDIR)" ; then \
++ for p in $^ ; do \
++ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $$p 2>&1 > /dev/null; \
++ done \
++ fi
+ endif
+
+ EXTRA_DIST = \
+@@ -34,8 +34,8 @@
+ raw-thumbnailer.xml
+
+ CLEANFILES = \
+- $(generated_schema_in_files) \
+- $(schema_DATA) \
+- raw-thumbnailer.schemas.in \
+- update-gconf.sh
++ $(generated_schema_in_files) \
++ $(schema_DATA) \
++ raw-thumbnailer.schemas.in \
++ update-gconf.sh
+