summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-01-07 11:42:55 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-01-07 14:42:40 +0100
commit466764e2d192316be446ceb1a2b760c223fab7fc (patch)
tree77f31b69351c8481ad49b61f3323a7b08f2315bf /media-gfx/graphviz
parentxfce-base/libxfce4ui: stable 4.13.4 for ppc64, bug #643074 (diff)
downloadgentoo-466764e2d192316be446ceb1a2b760c223fab7fc.tar.gz
gentoo-466764e2d192316be446ceb1a2b760c223fab7fc.tar.bz2
gentoo-466764e2d192316be446ceb1a2b760c223fab7fc.zip
media-gfx/graphviz: Switch USE qt4 to qt5
Bug: https://bugs.gentoo.org/638026 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'media-gfx/graphviz')
-rw-r--r--media-gfx/graphviz/files/graphviz-2.40.1-qt5.patch127
-rw-r--r--media-gfx/graphviz/graphviz-2.40.1-r1.ebuild278
2 files changed, 405 insertions, 0 deletions
diff --git a/media-gfx/graphviz/files/graphviz-2.40.1-qt5.patch b/media-gfx/graphviz/files/graphviz-2.40.1-qt5.patch
new file mode 100644
index 000000000000..02e81fac1d25
--- /dev/null
+++ b/media-gfx/graphviz/files/graphviz-2.40.1-qt5.patch
@@ -0,0 +1,127 @@
+Submitted By: Pierre Labastie <pierre dot labastie at neuf dot fr>
+Date: 2017-08-27
+Initial Package Version: 2.40.1
+Upstream Status: Unknown
+Origin: https://github.com/elkrejzi/pacman/blob/master/pkgbuild/graphviz/graphviz-qt5.patch
+ Addition of patch for cmd/gvedit/Makefile.am by P. Labastie
+Description: Fixes use of Qt5
+
+diff -Naur a/cmd/gvedit/csettings.cpp b/cmd/gvedit/csettings.cpp
+--- a/cmd/gvedit/csettings.cpp 2016-09-08 06:45:03.000000000 +0200
++++ b/cmd/gvedit/csettings.cpp 2017-08-28 17:05:32.226578375 +0200
+@@ -16,7 +16,7 @@
+ #include "csettings.h"
+ #include "qmessagebox.h"
+ #include "qfiledialog.h"
+-#include <QtGui>
++#include <QtWidgets>
+ #include <qfile.h>
+ #include "mdichild.h"
+ #include "string.h"
+diff -Naur a/cmd/gvedit/imageviewer.h b/cmd/gvedit/imageviewer.h
+--- a/cmd/gvedit/imageviewer.h 2016-08-09 23:02:09.000000000 +0200
++++ b/cmd/gvedit/imageviewer.h 2017-08-28 17:05:32.226578375 +0200
+@@ -15,7 +15,7 @@
+
+ #ifndef IMAGEVIEWER_H
+ #define IMAGEVIEWER_H
+-#include <QtGui>
++#include <QtWidgets>
+ #include <QMainWindow>
+ #include <QPrinter>
+
+diff -Naur a/cmd/gvedit/mainwindow.cpp b/cmd/gvedit/mainwindow.cpp
+--- a/cmd/gvedit/mainwindow.cpp 2016-09-20 06:45:02.000000000 +0200
++++ b/cmd/gvedit/mainwindow.cpp 2017-08-28 17:05:32.226578375 +0200
+@@ -11,7 +11,7 @@
+ * Contributors: See CVS logs. Details at http://www.graphviz.org/
+ *************************************************************************/
+
+-#include <QtGui>
++#include <QtWidgets>
+ #include <qframe.h>
+ #include "mainwindow.h"
+ #include "mdichild.h"
+diff -Naur a/cmd/gvedit/Makefile.am b/cmd/gvedit/Makefile.am
+--- a/cmd/gvedit/Makefile.am 2016-09-20 06:45:02.000000000 +0200
++++ b/cmd/gvedit/Makefile.am 2017-08-28 17:06:21.012476088 +0200
+@@ -30,6 +30,8 @@
+ -DDEMAND_LOADING=1 \
+ -DGVEDIT_DATADIR=\""$(pkgdatadir)/gvedit"\"
+
++gvedit_CXXFLAGS = -fPIC
++
+ gvedit_LDADD = \
+ $(top_builddir)/lib/gvc/libgvc.la \
+ $(top_builddir)/lib/cgraph/libcgraph.la \
+diff -Naur a/cmd/gvedit/mdichild.cpp b/cmd/gvedit/mdichild.cpp
+--- a/cmd/gvedit/mdichild.cpp 2016-08-09 23:02:09.000000000 +0200
++++ b/cmd/gvedit/mdichild.cpp 2017-08-28 17:05:32.226578375 +0200
+@@ -12,7 +12,7 @@
+ *************************************************************************/
+
+
+-#include <QtGui>
++#include <QtWidgets>
+
+ #include "mdichild.h"
+ #include "mainwindow.h"
+diff -Naur a/cmd/gvedit/ui_settings.h b/cmd/gvedit/ui_settings.h
+--- a/cmd/gvedit/ui_settings.h 2016-09-08 06:45:03.000000000 +0200
++++ b/cmd/gvedit/ui_settings.h 2017-08-28 17:05:32.226578375 +0200
+@@ -10,22 +10,22 @@
+ #ifndef UI_SETTINGS_H
+ #define UI_SETTINGS_H
+
+-#include <QtCore/QVariant>
+-#include <QtGui/QAction>
+-#include <QtGui/QApplication>
+-#include <QtGui/QButtonGroup>
+-#include <QtGui/QComboBox>
+-#include <QtGui/QDialog>
+-#include <QtGui/QFrame>
+-#include <QtGui/QHBoxLayout>
+-#include <QtGui/QHeaderView>
+-#include <QtGui/QLabel>
+-#include <QtGui/QLineEdit>
+-#include <QtGui/QPushButton>
+-#include <QtGui/QSpacerItem>
+-#include <QtGui/QTextEdit>
+-#include <QtGui/QVBoxLayout>
+-#include <QtGui/QWidget>
++#include <QVariant>
++#include <QAction>
++#include <QApplication>
++#include <QButtonGroup>
++#include <QComboBox>
++#include <QDialog>
++#include <QFrame>
++#include <QHBoxLayout>
++#include <QHeaderView>
++#include <QLabel>
++#include <QLineEdit>
++#include <QPushButton>
++#include <QSpacerItem>
++#include <QTextEdit>
++#include <QVBoxLayout>
++#include <QWidget>
+
+ QT_BEGIN_NAMESPACE
+
+diff -Naur a/configure.ac b/configure.ac
+--- a/configure.ac 2016-12-22 06:44:41.000000000 +0100
++++ b/configure.ac 2017-08-28 17:05:32.227578435 +0200
+@@ -2561,10 +2561,10 @@
+ use_qt="No (disabled)"
+ else
+
+- AC_CHECK_PROGS(QMAKE,qmake-qt4 qmake-qt3 qmake,false)
++ AC_CHECK_PROGS(QMAKE,qmake-qt5 qmake,false)
+ if test "$QMAKE" != "false"; then
+- PKG_CHECK_MODULES(QTCORE, [QtCore],[
+- PKG_CHECK_MODULES(QTGUI, [QtGui],[
++ PKG_CHECK_MODULES(QTCORE, [Qt5Core],[
++ PKG_CHECK_MODULES(QTGUI, [Qt5Widgets Qt5PrintSupport],[
+ use_qt="Yes"
+ ],[
+ use_qt="No (QtGui not available)"
diff --git a/media-gfx/graphviz/graphviz-2.40.1-r1.ebuild b/media-gfx/graphviz/graphviz-2.40.1-r1.ebuild
new file mode 100644
index 000000000000..2c248dad22ea
--- /dev/null
+++ b/media-gfx/graphviz/graphviz-2.40.1-r1.ebuild
@@ -0,0 +1,278 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils flag-o-matic java-pkg-opt-2 multilib python-single-r1 qmake-utils
+
+DESCRIPTION="Open Source Graph Visualization Software"
+HOMEPAGE="http://www.graphviz.org/ https://gitlab.com/graphviz/graphviz/"
+SRC_URI="http://www.graphviz.org/pub/graphviz/stable/SOURCES/${P}.tar.gz"
+
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="+cairo devil doc examples gdk-pixbuf gtk gts guile java lasi nls pdf perl postscript python qt5 ruby svg static-libs tcl X elibc_FreeBSD"
+
+# Requires ksh
+RESTRICT="test"
+
+RDEPEND="
+ sys-libs/zlib
+ >=dev-libs/expat-2
+ >=dev-libs/glib-2.11.1:2
+ dev-libs/libltdl:0
+ >=media-libs/fontconfig-2.3.95
+ >=media-libs/freetype-2.1.10
+ >=media-libs/gd-2.0.34:=[fontconfig,jpeg,png,truetype,zlib]
+ >=media-libs/libpng-1.2:0
+ !<=sci-chemistry/cluster-1.3.081231
+ virtual/jpeg:0
+ virtual/libiconv
+ X? (
+ x11-libs/libXaw
+ x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXt
+ )
+ cairo? (
+ >=x11-libs/pango-1.12
+ >=x11-libs/cairo-1.1.10[svg]
+ )
+ devil? ( media-libs/devil[png,jpeg] )
+ postscript? ( app-text/ghostscript-gpl )
+ gtk? ( x11-libs/gtk+:2 )
+ gts? ( sci-libs/gts )
+ lasi? ( media-libs/lasi )
+ pdf? ( app-text/poppler )
+ perl? ( dev-lang/perl:= )
+ python? ( ${PYTHON_DEPS} )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ )
+ ruby? ( dev-lang/ruby:* )
+ svg? ( gnome-base/librsvg )
+ tcl? ( >=dev-lang/tcl-8.3:0= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/flex
+ sys-devel/libtool
+ guile? ( dev-scheme/guile dev-lang/swig )
+ java? ( >=virtual/jdk-1.5 dev-lang/swig )
+ nls? ( >=sys-devel/gettext-0.14.5 )
+ perl? ( dev-lang/swig )
+ python? ( dev-lang/swig )
+ ruby? ( dev-lang/swig )
+ tcl? ( dev-lang/swig )"
+REQUIRED_USE="
+ !cairo? ( !X !gtk !postscript !lasi )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+# Dependency description / Maintainer-Info:
+
+# Rendering is done via the following plugins (/plugins):
+# - core, dot_layout, neato_layout, gd , dot
+# the ones which are always compiled in, depend on zlib, gd
+# - gtk
+# Directly depends on gtk-2.
+# needs 'pangocairo' enabled in graphviz configuration
+# gtk-2 depends on pango, cairo and libX11 directly.
+# - gdk-pixbuf
+# Disabled, GTK-1 junk.
+# - glitz
+# Disabled, no particular reason
+# needs 'pangocairo' enabled in graphviz configuration
+# - ming
+# flash plugin via -Tswf requires media-libs/ming-0.4. Disabled as it's
+# incomplete.
+# - cairo/pango:
+# Needs pango for text layout, uses cairo methods to draw stuff
+# - xlib:
+# needs cairo+pango,
+# can make use of gnomeui and inotify support (??? unsure),
+# needs libXaw for UI
+# UI also links directly against libX11, libXmu, and libXt
+# and uses libXpm if available so we make sure it always is
+
+# There can be swig-generated bindings for the following languages (/tclpkg/gv):
+# - c-sharp (disabled)
+# - scheme (enabled via guile) ... no longer broken on ~x86
+# - io (disabled)
+# - java (enabled via java) *2
+# - lua (enabled via lua)
+# - ocaml (enabled via ocaml)
+# - perl (enabled via perl) *1
+# - php (enabled via php) *2
+# - python (enabled via python) *1
+# - ruby (enabled via ruby) *1
+# - tcl (enabled via tcl)
+# *1 = The ${P}-bindings.patch takes care that those bindings are installed to the right location
+# *2 = Those bindings don't build because the paths for the headers/libs aren't
+# detected correctly and/or the options passed to swig are wrong (-php instead of -php4/5)
+
+# There are several other tools in /tclpkg:
+# gdtclft, tcldot, tclhandle, tclpathplan, tclstubs ; enabled with: --with-tcl
+# tkspline, tkstubs ; enabled with: --with-tk
+
+# And the commands (/cmd):
+# - dot, dotty, gvedit, gvpr, lefty, lneato, smyrna, tools/* :)
+# sci-libs/gts can be used for some of these
+# - lefty:
+# needs Xaw and X to build
+# - gvedit (via 'qt5'):
+# based on ./configure it needs qt-core and qt-gui only
+# - smyrna : experimental opengl front-end (via 'smyrna')
+# currently disabled -- it segfaults a lot
+# needs x11-libs/gtkglext, gnome-base/libglade, media-libs/freeglut
+# sci-libs/gts, x11-libs/gtk. Also needs 'gtk','glade','glut','gts' and 'png'
+# with flags enabled at configure time
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.34.0-Xaw-configure.patch
+ "${FILESDIR}"/${P}-qt5.patch
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+
+ java-pkg-opt-2_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # ToDo: Do the same thing for examples and/or
+ # write a patch for a configuration-option
+ # and send it to upstream
+ # note - the longer sed expression removes multi-line assignments that are extended via '\'
+ if ! use doc ; then
+ find . -iname Makefile.am \
+ | xargs sed -i -e '/^\(html\|pdf\)_DATA.*\\[[:space:]]*$/{:m;N;s/\\\n//;tm;d}' \
+ -e '/^\(html\|pdf\)_DATA/d' || die
+ fi
+
+ # This is an old version of libtool
+ # use the ./configure option to exclude its use, and
+ # delete the dir since we don't need to eautoreconf it
+ rm -r libltdl || die
+
+ # no nls, no gettext, no iconv macro, so disable it
+ if ! use nls ; then
+ sed -i -e '/^AM_ICONV/d' configure.ac || die
+ fi
+
+ # Nuke the dead symlinks for the bindings
+ sed -i -e '/$(pkgluadir)/d' tclpkg/gv/Makefile.am || die
+
+ # replace the whitespace with tabs
+ sed -i -e 's: :\t:g' doc/info/Makefile.am || die
+
+ # use correct version of qmake. bug #567236
+ sed -i -e "/AC_CHECK_PROGS(QMAKE/a AC_SUBST(QMAKE,$(qt5_get_bindir)/qmake)" configure.ac || die
+
+ # workaround for http://www.graphviz.org/mantisbt/view.php?id=1895
+ use elibc_FreeBSD && append-flags $(test-flags -fno-builtin-sincos)
+
+ use java && append-cppflags $(java-pkg_get-jni-cflags)
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --enable-ltdl
+ --disable-silent-rules
+ $(use_enable static-libs static)
+ )
+
+ # libtool file collision, bug 276609
+ myconf+=( --without-included-ltdl --disable-ltdl-install )
+
+ myconf+=(
+ $(use_with cairo pangocairo)
+ $(use_with devil)
+ $(use_with gtk)
+ $(use_with gts)
+ $(use_with qt5 qt)
+ $(use_with lasi)
+ $(use_with pdf poppler)
+ $(use_with postscript ghostscript)
+ $(use_with svg rsvg)
+ $(use_with X x)
+ $(use_with X xaw)
+ $(use_with X lefty)
+ --with-digcola
+ --with-fontconfig
+ --with-freetype2
+ --with-ipsepcola
+ --with-libgd
+ --with-sfdp
+ $(use_enable gdk-pixbuf)
+ --without-ming
+ )
+
+ # new/experimental features, to be tested, disable for now
+ myconf+=(
+ --with-cgraph
+ --without-glitz
+ --without-ipsepcola
+ --without-smyrna
+ --without-visio
+ )
+
+ # Bindings:
+ myconf+=(
+ $(use_enable guile)
+ --disable-io
+ $(use_enable java)
+ --disable-lua
+ --disable-ocaml
+ $(use_enable perl)
+ --disable-php
+ $(use_enable python)
+ --disable-r
+ $(use_enable ruby)
+ --disable-sharp
+ $(use_enable tcl)
+ )
+
+ econf ${myconf[@]}
+}
+
+src_install() {
+ sed -i -e "s:htmldir:htmlinfodir:g" doc/info/Makefile || die
+
+ emake DESTDIR="${D}" \
+ txtdir="${EPREFIX}"/usr/share/doc/${PF} \
+ htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ htmlinfodir="${EPREFIX}"/usr/share/doc/${PF}/html/info \
+ pdfdir="${EPREFIX}"/usr/share/doc/${PF}/pdf \
+ pkgconfigdir="${EPREFIX}"/usr/$(get_libdir)/pkgconfig \
+ install
+
+ use examples || rm -rf "${ED}"/usr/share/graphviz/demo
+
+ use static-libs || find "${ED}" -name '*.la' -exec rm -f {} +
+
+ dodoc AUTHORS ChangeLog NEWS README
+
+ use python && python_optimize \
+ "${D}$(python_get_sitedir)" \
+ "${D}/usr/$(get_libdir)/graphviz/python"
+}
+
+pkg_postinst() {
+ # This actually works if --enable-ltdl is passed
+ # to configure
+ dot -c
+}
+
+pkg_postrm() {
+ # Remove cruft, bug #547344
+ rm -f "${EROOT}usr/lib/graphviz/config{,6}"
+}