summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-07-02 17:28:57 +0200
committerPacho Ramos <pacho@gentoo.org>2016-07-02 19:10:36 +0200
commit41f0daa157d894cd712ad613acd18f3f0b3a0cac (patch)
tree76879059afd2a9720ff732e4d36865650f6de513 /media-gfx/gtkam/gtkam-1.0.ebuild
parentmedia-gfx/gnome-screenshot: Version bump (diff)
downloadgentoo-41f0daa157d894cd712ad613acd18f3f0b3a0cac.tar.gz
gentoo-41f0daa157d894cd712ad613acd18f3f0b3a0cac.tar.bz2
gentoo-41f0daa157d894cd712ad613acd18f3f0b3a0cac.zip
media-gfx/gtkam: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'media-gfx/gtkam/gtkam-1.0.ebuild')
-rw-r--r--media-gfx/gtkam/gtkam-1.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-gfx/gtkam/gtkam-1.0.ebuild b/media-gfx/gtkam/gtkam-1.0.ebuild
new file mode 100644
index 000000000000..01a8d42ec394
--- /dev/null
+++ b/media-gfx/gtkam/gtkam-1.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils gnome2
+
+DESCRIPTION="A frontend for gPhoto 2"
+HOMEPAGE="http://gphoto.org/proj/gtkam"
+SRC_URI="mirror://sourceforge/gphoto/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="gimp nls"
+
+RDEPEND="
+ x11-libs/gtk+:2
+ >=media-libs/libgphoto2-2.5.0
+ >=media-libs/libexif-0.3.2
+ media-libs/libexif-gtk
+ gimp? ( >=media-gfx/gimp-2 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.14.1 )
+"
+
+PATCHES=(
+ # Fix .desktop validity, bug #271569
+ "${FILESDIR}/${PN}-0.1.18-desktop-validation.patch"
+)
+
+src_configure() {
+ gnome2_src_configure \
+ --without-bonobo \
+ --without-gnome \
+ $(use_with gimp) \
+ $(use_enable nls) \
+ --with-rpmbuild=/bin/false
+}
+
+src_install() {
+ gnome2_src_install
+ rm -rf "${ED}"/usr/share/doc/gtkam || die "rm failed"
+}