summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/iscan-data/iscan-data-1.36.0.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/iscan-data/iscan-data-1.36.0.1.ebuild')
-rw-r--r--media-gfx/iscan-data/iscan-data-1.36.0.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-gfx/iscan-data/iscan-data-1.36.0.1.ebuild b/media-gfx/iscan-data/iscan-data-1.36.0.1.ebuild
new file mode 100644
index 000000000000..5653548c69d3
--- /dev/null
+++ b/media-gfx/iscan-data/iscan-data-1.36.0.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils versionator udev multilib
+
+MY_PV="$(get_version_component_range 1-3)"
+MY_PVR="$(replace_version_separator 3 -)"
+
+DESCRIPTION="Image Scan! for Linux data files"
+HOMEPAGE="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
+# Use a gentoo hosted url since upstream uses a session based url that causes the
+# files to no longer be available after the session expires.
+SRC_URI="http://dev.gentoo.org/~idella4/tarballs//${PN}_${MY_PVR}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="amd64 x86"
+IUSE="udev"
+
+DEPEND="udev? (
+ dev-libs/libxslt
+ media-gfx/sane-backends
+ )"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DOCS=( NEWS SUPPORTED-DEVICES KNOWN-PROBLEMS )
+
+src_install() {
+ ewarn ""; ewarn "Some profiles automatically enable udev which will cause install to fail"
+ ewarn "if media-gfx/sane-backends is not already installed."; ewarn ""
+ default
+
+ if use udev; then
+ # create udev rules
+ local rulesdir=$(get_udevdir)/rules.d
+ dodir ${rulesdir}
+ "${D}usr/$(get_libdir)/iscan-data/make-policy-file" \
+ --force --mode udev \
+ -d "${D}usr/share/iscan-data/epkowa.desc" \
+ -o "${D}${rulesdir}/99-iscan.rules" || die
+ fi
+}