summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/iscan/files/iscan-2.30.1-fix-g++-test.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/iscan/files/iscan-2.30.1-fix-g++-test.patch')
-rw-r--r--media-gfx/iscan/files/iscan-2.30.1-fix-g++-test.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-gfx/iscan/files/iscan-2.30.1-fix-g++-test.patch b/media-gfx/iscan/files/iscan-2.30.1-fix-g++-test.patch
new file mode 100644
index 000000000000..5a7f26eb4ca5
--- /dev/null
+++ b/media-gfx/iscan/files/iscan-2.30.1-fix-g++-test.patch
@@ -0,0 +1,45 @@
+Drop obsolete C++ ABI transistion code.
+https://bugs.gentoo.org/549866
+
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -62,27 +62,6 @@ dnl checks for programs
+
+ AC_PROG_CXX
+
+-# Transitionary check for the C++ ABI while we are switching provided
+-# binaries from gcc-3.[23] to gcc-3.4 or later. Currently gcc-3.[23]
+-# is still the official compiler version to use, but experimental bi-
+-# naries are released with a ".c2" suffix.
+-# The CXX_ABI for gcc-3.[23] is 102, btw.
+-# Note that the PACKAGE_RELEASE for the gcc-3.4 or later packages has
+-# to be larger than that for the gcc-3.[23] packages (as long as both
+-# are distributed) for smooth upgrade paths.
+-
+-if test x"$CXX" = xg++; then
+- AC_MSG_CHECKING([C++ ABI version])
+- CXX_ABI="`$CXX -E -dM - < /dev/null | $AWK '/GXX_ABI/ { print $3 }'`"
+- AC_MSG_RESULT([$CXX_ABI])
+- if test x"$CXX_ABI" = x1002; then
+- PACKAGE_CXX_ABI=".c2"
+- else
+- PACKAGE_CXX_ABI=""
+- fi
+- AC_SUBST(PACKAGE_CXX_ABI)
+-fi
+-
+ AC_PROG_CC
+ AC_PROG_CPP
+ AC_PROG_INSTALL
+--- a/non-free/Makefile.am
++++ b/non-free/Makefile.am
+@@ -65,7 +65,7 @@ $(NON_FREE_SOLIBS):
+ *) echo "unsupported architecture" 1>&2; \
+ exit 1;; \
+ esac; \
+- $(LN_S) $(srcdir)/libesmod-$${arch}$(PACKAGE_CXX_ABI).so $@
++ $(LN_S) $(srcdir)/libesmod-$${arch}.c2.so $@
+
+ install-exec-local: $(NON_FREE_SOLIBS)
+ $(mkinstalldirs) $(DESTDIR)$(libdir)