summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2020-05-10 13:52:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-10 14:05:52 +0200
commitc35585303c48d0746234352cca0df3e1b9ff8fd3 (patch)
treea7cfbf6a89a85e0fe494d8c0175eccabd8a440d4 /media-gfx/iscan
parentapp-forensics/foremost: Fixes issue 706886 (diff)
downloadgentoo-c35585303c48d0746234352cca0df3e1b9ff8fd3.tar.gz
gentoo-c35585303c48d0746234352cca0df3e1b9ff8fd3.tar.bz2
gentoo-c35585303c48d0746234352cca0df3e1b9ff8fd3.zip
media-gfx/iscan: fix building with boost 1.73
Closes: https://bugs.gentoo.org/721696 Signed-off-by: Marcin Deranek <marcin.deranek@slonko.net> Closes: https://github.com/gentoo/gentoo/pull/15737 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/iscan')
-rw-r--r--media-gfx/iscan/files/iscan-3.62.0-boost-1.73.patch33
-rw-r--r--media-gfx/iscan/iscan-3.62.0.ebuild1
2 files changed, 34 insertions, 0 deletions
diff --git a/media-gfx/iscan/files/iscan-3.62.0-boost-1.73.patch b/media-gfx/iscan/files/iscan-3.62.0-boost-1.73.patch
new file mode 100644
index 000000000000..d55a464823b8
--- /dev/null
+++ b/media-gfx/iscan/files/iscan-3.62.0-boost-1.73.patch
@@ -0,0 +1,33 @@
+diff -urN a/drivers/esci/verify.cpp b/drivers/esci/verify.cpp
+--- a/drivers/esci/verify.cpp 2019-11-18 04:08:45.000000000 +0200
++++ b/drivers/esci/verify.cpp 2020-05-09 20:22:00.899968638 +0300
+@@ -58,6 +58,7 @@
+
+ using namespace utsushi;
+ using namespace _drv_::esci;
++using namespace boost::placeholders;
+
+ using std::basic_string;
+ using std::ios_base;
+diff -urN a/lib/monitor.cpp b/lib/monitor.cpp
+--- a/lib/monitor.cpp 2019-11-18 04:08:08.000000000 +0200
++++ b/lib/monitor.cpp 2020-05-09 20:22:26.392174029 +0300
+@@ -49,6 +49,7 @@
+ namespace utsushi {
+
+ using boost::filesystem::exists;
++using namespace boost::placeholders;
+
+ class monitor::impl
+ {
+diff -urN a/sane/handle.cpp b/sane/handle.cpp
+--- a/sane/handle.cpp 2019-11-18 04:08:08.000000000 +0200
++++ b/sane/handle.cpp 2020-05-09 20:21:49.559223712 +0300
+@@ -65,6 +65,7 @@
+ using utsushi::_flt_::deskew;
+ using utsushi::_flt_::autocrop;
+ using utsushi::_flt_::pnm;
++using namespace boost::placeholders;
+
+ namespace sane {
+
diff --git a/media-gfx/iscan/iscan-3.62.0.ebuild b/media-gfx/iscan/iscan-3.62.0.ebuild
index f5957958df9a..f01a67d24171 100644
--- a/media-gfx/iscan/iscan-3.62.0.ebuild
+++ b/media-gfx/iscan/iscan-3.62.0.ebuild
@@ -33,6 +33,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-3.61.0-ijg-libjpeg.patch
"${FILESDIR}"/${PN}-3.61.0-imagemagick-7.patch
"${FILESDIR}"/${PN}-3.62.0-gcc-10.patch
+ "${FILESDIR}"/${PN}-3.62.0-boost-1.73.patch
)
src_prepare() {