summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2020-07-28 15:29:01 +0200
committerAaron Bauman <bman@gentoo.org>2020-07-28 14:19:29 -0400
commitfa3833ddd2a83c8bc49f4d3409288b0186c37173 (patch)
treeacb00b9070dea26edd67b4d1216ec08d55c4bf34 /media-gfx/jhead
parentdev-libs/libressl: remove unused patch (diff)
downloadgentoo-fa3833ddd2a83c8bc49f4d3409288b0186c37173.tar.gz
gentoo-fa3833ddd2a83c8bc49f4d3409288b0186c37173.tar.bz2
gentoo-fa3833ddd2a83c8bc49f4d3409288b0186c37173.zip
media-gfx/jhead: remove unused patch
Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16873 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'media-gfx/jhead')
-rw-r--r--media-gfx/jhead/files/Makefile44
1 files changed, 0 insertions, 44 deletions
diff --git a/media-gfx/jhead/files/Makefile b/media-gfx/jhead/files/Makefile
deleted file mode 100644
index 5f1d9799a42b..000000000000
--- a/media-gfx/jhead/files/Makefile
+++ /dev/null
@@ -1,44 +0,0 @@
-#--------------------------------
-# jhead makefile for Unix
-# this make file also creates libjhead for meshlab
-#--------------------------------
-OBJ=.
-SRC=.
-AR = ar cqs
-LFLAGS = -shared -Wl,-soname,libjhead.so.1
-
-objs = $(OBJ)/jhead.o $(OBJ)/jpgfile.o $(OBJ)/jpgqguess.o $(OBJ)/paths.o \
- $(OBJ)/exif.o $(OBJ)/iptc.o $(OBJ)/gpsinfo.o $(OBJ)/makernote.o
-
-TARGET = libjhead.so.1.0.0
-TARGET0 = libjhead.so
-TARGET1 = libjhead.so.1
-TARGET2 = libjhead.so.1.0
-
-all: jhead $(TARGET)
-
-$(OBJ)/%.o:$(SRC)/%.c
- ${CC} -fPIC $(CFLAGS) -c $< -o $@
-
-jhead: $(objs) jhead.h
- ${CC} ${LDFLAGS} -o jhead $(objs) -lm
-
-clean:
- rm -f $(objs) jhead ${TARGET} ${TARGETA} ${TARGET0} ${TARGETD} \
- ${TARGET1} ${TARGET2}
-
-install:
- cp jhead ${DESTDIR}/usr/bin/
- cp ${TARGET} ${DESTDIR}/usr/lib/
- cp jhead ${DESTDIR}/usr/bin/
- cp ${TARGET0} ${DESTDIR}/usr/lib/
- cp ${TARGET1} ${DESTDIR}/usr/lib/
- cp ${TARGET2} ${DESTDIR}/usr/lib/
-
-$(TARGET): $(objs) jhead
- ${CC} $(LDFLAGS) $(LFLAGS) -o $(TARGET) $(objs)
- ln -s ${TARGET} ${TARGET0}
- ln -s ${TARGET} ${TARGET1}
- ln -s ${TARGET} ${TARGET2}
-
-