summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2019-02-08 16:31:24 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-09 17:06:47 +0100
commitf20b8ec6da83060e38426e322d3d8c3493a67fe9 (patch)
tree126687c4c046c96136760f416e55aada2e98fcbe /media-gfx/jpeginfo
parentmedia-gfx/jpeginfo: use HTTPS (diff)
downloadgentoo-f20b8ec6da83060e38426e322d3d8c3493a67fe9.tar.gz
gentoo-f20b8ec6da83060e38426e322d3d8c3493a67fe9.tar.bz2
gentoo-f20b8ec6da83060e38426e322d3d8c3493a67fe9.zip
media-gfx/jpeginfo: use HTTPs, EAPI7 bump
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/jpeginfo')
-rw-r--r--media-gfx/jpeginfo/files/jpeginfo-1.6.0-parallel_install.patch4
-rw-r--r--media-gfx/jpeginfo/jpeginfo-1.6.1-r1.ebuild29
2 files changed, 31 insertions, 2 deletions
diff --git a/media-gfx/jpeginfo/files/jpeginfo-1.6.0-parallel_install.patch b/media-gfx/jpeginfo/files/jpeginfo-1.6.0-parallel_install.patch
index 379e200fd90f..84de25bafca6 100644
--- a/media-gfx/jpeginfo/files/jpeginfo-1.6.0-parallel_install.patch
+++ b/media-gfx/jpeginfo/files/jpeginfo-1.6.0-parallel_install.patch
@@ -1,5 +1,5 @@
---- Makefile.in
-+++ Makefile.in
+--- a/Makefile.in
++++ b/Makefile.in
@@ -79,7 +79,7 @@
groff -Tps -mandoc ./$(PKGNAME).1 >$(PKGNAME).ps
groff -Tascii -mandoc ./$(PKGNAME).1 | tee $(PKGNAME).prn | sed 's/.//g' >$(PKGNAME).txt
diff --git a/media-gfx/jpeginfo/jpeginfo-1.6.1-r1.ebuild b/media-gfx/jpeginfo/jpeginfo-1.6.1-r1.ebuild
new file mode 100644
index 000000000000..fb764fd99d88
--- /dev/null
+++ b/media-gfx/jpeginfo/jpeginfo-1.6.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Prints information and tests integrity of JPEG/JFIF files"
+HOMEPAGE="https://www.kokkonen.net/tjko/projects.html"
+SRC_URI="https://www.kokkonen.net/tjko/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="virtual/jpeg:0"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.6.0-parallel_install.patch )
+
+src_configure() {
+ tc-export CC
+ econf
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ dodoc README
+}