summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2020-04-27 21:08:57 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-21 01:28:32 +0200
commitc594609b401cc5bed57c1548d8ebab703a9f49b7 (patch)
tree39c7b257fbf30b2828bb09728dfaf9eae9347d07 /media-gfx/lximage-qt/lximage-qt-0.15.0.ebuild
parentlxqt-base/lxqt-runner: add version 0.15.0 (diff)
downloadgentoo-c594609b401cc5bed57c1548d8ebab703a9f49b7.tar.gz
gentoo-c594609b401cc5bed57c1548d8ebab703a9f49b7.tar.bz2
gentoo-c594609b401cc5bed57c1548d8ebab703a9f49b7.zip
media-gfx/lximage-qt: add version 0.15.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/lximage-qt/lximage-qt-0.15.0.ebuild')
-rw-r--r--media-gfx/lximage-qt/lximage-qt-0.15.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-gfx/lximage-qt/lximage-qt-0.15.0.ebuild b/media-gfx/lximage-qt/lximage-qt-0.15.0.ebuild
new file mode 100644
index 000000000000..a0ad4a567157
--- /dev/null
+++ b/media-gfx/lximage-qt/lximage-qt-0.15.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Qt Image Viewer"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.7.0
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-libs/libexif
+ >=x11-libs/libfm-qt-0.15.0:=
+ x11-libs/libX11
+ x11-libs/libXfixes
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"