summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-01-01 13:42:41 +0100
committerDavid Seifert <soap@gentoo.org>2018-01-01 13:42:41 +0100
commitb02dedbf2c669105c7d72ace5fbe4473e434c858 (patch)
tree380ef1523c2cda04fb78500900ba27ef3e1b29be /media-gfx/maim/maim-9999.ebuild
parentx11-misc/slop: Add live ebuild (diff)
downloadgentoo-b02dedbf2c669105c7d72ace5fbe4473e434c858.tar.gz
gentoo-b02dedbf2c669105c7d72ace5fbe4473e434c858.tar.bz2
gentoo-b02dedbf2c669105c7d72ace5fbe4473e434c858.zip
media-gfx/maim: Add live ebuild
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'media-gfx/maim/maim-9999.ebuild')
-rw-r--r--media-gfx/maim/maim-9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-gfx/maim/maim-9999.ebuild b/media-gfx/maim/maim-9999.ebuild
new file mode 100644
index 000000000000..254e10aa2376
--- /dev/null
+++ b/media-gfx/maim/maim-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Commandline tool to take screenshots of the desktop"
+HOMEPAGE="https://github.com/naelstrof/maim"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/naelstrof/maim.git"
+else
+ SRC_URI="https://github.com/naelstrof/maim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="unicode"
+
+RDEPEND="
+ media-libs/libpng:0=
+ virtual/jpeg:0
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-misc/slop:=
+ unicode? ( dev-libs/icu:= )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DMAIM_UNICODE=$(usex unicode)
+ )
+ cmake-utils_src_configure
+}