summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/mandelbulber
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/mandelbulber')
-rw-r--r--media-gfx/mandelbulber/Manifest3
-rw-r--r--media-gfx/mandelbulber/files/mandelbulber-1.11-qa.patch37
-rw-r--r--media-gfx/mandelbulber/files/mandelbulber-1.12.1-memcpy_and_memset.patch22
-rw-r--r--media-gfx/mandelbulber/files/mandelbulber-1.21.1-qa.patch30
-rw-r--r--media-gfx/mandelbulber/mandelbulber-1.11.ebuild46
-rw-r--r--media-gfx/mandelbulber/mandelbulber-1.12.1.ebuild47
-rw-r--r--media-gfx/mandelbulber/mandelbulber-1.21.1.ebuild48
-rw-r--r--media-gfx/mandelbulber/metadata.xml14
8 files changed, 247 insertions, 0 deletions
diff --git a/media-gfx/mandelbulber/Manifest b/media-gfx/mandelbulber/Manifest
new file mode 100644
index 000000000000..252acc328fa4
--- /dev/null
+++ b/media-gfx/mandelbulber/Manifest
@@ -0,0 +1,3 @@
+DIST mandelbulber1.11.tar.gz 1176248 SHA256 3f57a23f91c3d88f1e28cba29e4f076e03c9bcb97ce7ecdd0cd713687cab714e
+DIST mandelbulber1.12-1.tar.gz 1179684 SHA256 75376616b52cb8dac7c7f358f4eb26f9d2fb171b9b0a54dbb25eeb57e494d382 SHA512 c198c71648ad4d674dac980c77fe2573617e122bdddb7775fccf74e1a929900691a421561f8717e4df741db65421cbdb8e464fd031ff5c38a56f63f5259b5512 WHIRLPOOL 7b5113bc81913607a544d19e9d16f53ec8888f97584110d0b8ad545b4603582f88fdfab4260d9fc74feaaae815739ac14f4b42e045fa1d6ae86d0e72e52f77fa
+DIST mandelbulber1.21-1.orig.tar.gz 1076836 SHA256 d9d95be4e21311fa2b2b7883a659d2c173940499a7c5f8436aa62cdf543b6eca SHA512 caaa27a4aa67e83045e9cfc84593770d26d0b12d44e6f37f1f37e04eb62f7d2038c07d82541eca2ef8c64c787bae2fac9c487f69c98936310946f27c07760ce3 WHIRLPOOL 204ebc870e9d6a80dbbff210424bcef333dafc24b8b6010d10f7eda833b3e6342154182d171e0960d02531ebc812b727197f8dfe2aa4aa641e5160b0256993c8
diff --git a/media-gfx/mandelbulber/files/mandelbulber-1.11-qa.patch b/media-gfx/mandelbulber/files/mandelbulber-1.11-qa.patch
new file mode 100644
index 000000000000..f457c1902c8f
--- /dev/null
+++ b/media-gfx/mandelbulber/files/mandelbulber-1.11-qa.patch
@@ -0,0 +1,37 @@
+--- a/makefiles/makefile
++++ b/makefiles/makefile
+@@ -5,6 +5,7 @@
+ -include ../makefile.init
+
+ RM := rm -rf
++CXX ?= g++
+
+ # All of the sources participating in the build are defined here
+ -include sources.mk
+@@ -44,7 +45,7 @@
+ mandelbulber: $(OBJS) $(USER_OBJS)
+ @echo 'Building target: $@'
+ @echo 'Invoking: GCC C++ Linker'
+- g++ -o"mandelbulber" -L/usr/lib/x86_64-linux-gnu/ $(OBJS) $(USER_OBJS) $(LIBS) `pkg-config --libs gtk+-2.0 gthread-2.0`
++ $(CXX) $(LDFLAGS) -o"mandelbulber" -L/usr/lib/x86_64-linux-gnu/ $(OBJS) $(USER_OBJS) $(LIBS) `pkg-config --libs gtk+-2.0 gthread-2.0`
+ @echo 'Finished building target: $@'
+ @echo ' '
+
+--- a/makefiles/src/subdir.mk
++++ b/makefiles/src/subdir.mk
+@@ -63,12 +63,14 @@
+ ./src/undo.d \
+ ./src/cl_support.d
+
++CXX ?= g++
++CXXFLAGS ?= -O2 -fast-math
+
+ # Each subdirectory must supply rules for building sources it contributes
+ src/%.o: ../src/%.cpp
+ @echo 'Building file: $<'
+ @echo 'Invoking: GCC C++ Compiler'
+- g++ -O2 -ffast-math -Wall -c -fmessage-length=0 `pkg-config --cflags gtk+-2.0 gthread-2.0;` -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o"$@" "$<"
++ $(CXX) $(CXXFLAGS) -Wall -c -fmessage-length=0 `pkg-config --cflags gtk+-2.0 gthread-2.0;` -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o"$@" "$<"
+ @echo 'Finished building: $<'
+ @echo ' '
+
diff --git a/media-gfx/mandelbulber/files/mandelbulber-1.12.1-memcpy_and_memset.patch b/media-gfx/mandelbulber/files/mandelbulber-1.12.1-memcpy_and_memset.patch
new file mode 100644
index 000000000000..43fb0b982dbd
--- /dev/null
+++ b/media-gfx/mandelbulber/files/mandelbulber-1.12.1-memcpy_and_memset.patch
@@ -0,0 +1,22 @@
+http://bugs.gentoo.org/464972
+
+--- src/texture.cpp
++++ src/texture.cpp
+@@ -5,6 +5,7 @@
+ * Author: krzysztof
+ */
+ #include <stdio.h>
++#include <string.h>
+ #include "texture.hpp"
+ #include "files.h"
+
+--- src/timeline.cpp
++++ src/timeline.cpp
+@@ -6,6 +6,7 @@
+ */
+
+ #include <cstdlib>
++#include <cstring>
+
+ #include "timeline.hpp"
+ #include "files.h"
diff --git a/media-gfx/mandelbulber/files/mandelbulber-1.21.1-qa.patch b/media-gfx/mandelbulber/files/mandelbulber-1.21.1-qa.patch
new file mode 100644
index 000000000000..6fea9525cfe1
--- /dev/null
+++ b/media-gfx/mandelbulber/files/mandelbulber-1.21.1-qa.patch
@@ -0,0 +1,30 @@
+--- mandelbulber1.21-1.orig/makefiles/makefile
++++ mandelbulber1.21-1.orig/makefiles/makefile
+@@ -5,6 +5,7 @@
+ -include ../makefile.init
+
+ RM := rm -rf
++CXX ?= g++
+
+ # All of the sources participating in the build are defined here
+ -include sources.mk
+@@ -44,7 +45,7 @@
+ mandelbulber: $(OBJS) $(USER_OBJS)
+ @echo 'Building target: $@'
+ @echo 'Invoking: GCC C++ Linker'
+- g++ -o"mandelbulber" -L/usr/lib/x86_64-linux-gnu/ $(CXXFLAGS) $(CPPFLAGS) $(LDFLAGS) $(OBJS) $(USER_OBJS) $(LIBS)
++ $(CXX) -o"mandelbulber" -L/usr/lib/x86_64-linux-gnu/ $(CXXFLAGS) $(CPPFLAGS) $(LDFLAGS) $(OBJS) $(USER_OBJS) $(LIBS)
+ @echo 'Finished building target: $@'
+ @echo ' '
+
+--- mandelbulber1.21-1.orig/makefiles/src/subdir.mk
++++ mandelbulber1.21-1.orig/makefiles/src/subdir.mk
+@@ -71,7 +71,7 @@
+ src/%.o: ../src/%.cpp
+ @echo 'Building file: $<'
+ @echo 'Invoking: GCC C++ Compiler'
+- g++ -O3 -ffast-math -Wall -c -fmessage-length=0 `pkg-config --cflags gtk+-2.0 gthread-2.0;` -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" $(CXXFLAGS) $(CPPFLAGS) -o"$@" "$<"
++ $(CXX) -Wall -c -fmessage-length=0 `pkg-config --cflags gtk+-2.0 gthread-2.0;` -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" $(CXXFLAGS) $(CPPFLAGS) -o"$@" "$<"
+ @echo 'Finished building: $<'
+ @echo ' '
+
diff --git a/media-gfx/mandelbulber/mandelbulber-1.11.ebuild b/media-gfx/mandelbulber/mandelbulber-1.11.ebuild
new file mode 100644
index 000000000000..7bae8d3e6163
--- /dev/null
+++ b/media-gfx/mandelbulber/mandelbulber-1.11.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+MY_P=${PN}${PV}
+
+DESCRIPTION="Tool to render 3D fractals"
+HOMEPAGE="http://sites.google.com/site/mandelbulber/home"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ >=media-libs/libsndfile-1
+ >=media-libs/libpng-1.4
+ virtual/jpeg"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-qa.patch
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" -C makefiles all
+}
+
+src_install() {
+ dobin makefiles/${PN}
+ dodoc README NEWS
+ insinto /usr/share/${PN}
+ doins -r usr/share/*
+}
+
+pkg_postinst() {
+ elog "Before you run ${PN} please copy /usr/share/${PN}/* to \${HOME}/.${PN}"
+}
diff --git a/media-gfx/mandelbulber/mandelbulber-1.12.1.ebuild b/media-gfx/mandelbulber/mandelbulber-1.12.1.ebuild
new file mode 100644
index 000000000000..68a78d357101
--- /dev/null
+++ b/media-gfx/mandelbulber/mandelbulber-1.12.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs versionator
+
+MY_P=${PN}$(replace_version_separator 2 '-' )
+
+DESCRIPTION="Tool to render 3D fractals"
+HOMEPAGE="http://sites.google.com/site/mandelbulber/home"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ >=media-libs/libsndfile-1
+ >=media-libs/libpng-1.4:0=
+ virtual/jpeg"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.11-qa.patch \
+ "${FILESDIR}"/${P}-memcpy_and_memset.patch
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" -C makefiles all
+}
+
+src_install() {
+ dobin makefiles/${PN}
+ dodoc README NEWS
+ insinto /usr/share/${PN}
+ doins -r usr/share/*
+}
+
+pkg_postinst() {
+ elog "Before you run ${PN} please copy /usr/share/${PN}/* to \${HOME}/.${PN}"
+}
diff --git a/media-gfx/mandelbulber/mandelbulber-1.21.1.ebuild b/media-gfx/mandelbulber/mandelbulber-1.21.1.ebuild
new file mode 100644
index 000000000000..a9dd01cf53e8
--- /dev/null
+++ b/media-gfx/mandelbulber/mandelbulber-1.21.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs versionator
+
+MY_P=${PN}$(replace_version_separator 2 '-' ).orig
+
+DESCRIPTION="Tool to render 3D fractals"
+HOMEPAGE="http://sites.google.com/site/mandelbulber/home"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ dev-libs/glib:2
+ >=media-libs/libpng-1.4:0=
+ virtual/jpeg"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-qa.patch
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" -C makefiles all
+}
+
+src_install() {
+ dobin makefiles/${PN}
+ dodoc README NEWS
+ insinto /usr/share/${PN}
+ doins -r usr/share/*
+ domenu ${PN}.desktop
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Before you run ${PN} please copy /usr/share/${PN}/* to \${HOME}/.${PN}"
+ fi
+}
diff --git a/media-gfx/mandelbulber/metadata.xml b/media-gfx/mandelbulber/metadata.xml
new file mode 100644
index 000000000000..f34f1d95dc92
--- /dev/null
+++ b/media-gfx/mandelbulber/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+ <longdescription>
+ Mandelbulber is an easy to use, handy but experimental application
+ designed to help you render 3D Mandelbrot fractals called Mandelbulb
+ and some other kind of 3D fractals like Mandelbox, Bulbbox, Juliabulb,
+ Menger Sponge.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">mandelbulber</remote-id>
+ </upstream>
+</pkgmetadata>