summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/monica/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/monica/files')
-rw-r--r--media-gfx/monica/files/monica-3.6-makefile-cleanup.patch33
-rw-r--r--media-gfx/monica/files/monica-3.7-gcc44.patch11
2 files changed, 44 insertions, 0 deletions
diff --git a/media-gfx/monica/files/monica-3.6-makefile-cleanup.patch b/media-gfx/monica/files/monica-3.6-makefile-cleanup.patch
new file mode 100644
index 000000000000..21881db24971
--- /dev/null
+++ b/media-gfx/monica/files/monica-3.6-makefile-cleanup.patch
@@ -0,0 +1,33 @@
+diff -Nuar monica-3.6.orig/Makefile monica-3.6/Makefile
+--- monica-3.6.orig/Makefile 2005-03-14 22:00:18.000000000 -0800
++++ monica-3.6/Makefile 2007-11-15 00:48:39.000000000 -0800
+@@ -2,22 +2,24 @@
+ CXX = g++
+ LINK = g++
+ CFLAGS = -Wall -O2
+-CXXFLAGS = `fltk-config --cxxflags` -Wall -O2
+-LDFLAGS = `fltk-config --ldflags`
++CXXFLAGS = -Wall -O2
++FLTK_CXXFLAGS = `fltk-config --cxxflags`
++LDFLAGS =
++FLTK_LDFLAGS = `fltk-config --ldflags`
+ TARGET = monica
+-DESTINATION = /usr/bin
++DESTINATION = $(DESTDIR)/usr/bin
+ OBJECTS = monica.o
+
+ all: $(TARGET)
+
+ $(TARGET): $(OBJECTS)
+- $(LINK) -o $(TARGET) $(OBJECTS) $(LDFLAGS)
++ $(LINK) -o $(TARGET) $(OBJECTS) $(FLTK_LDFLAGS) $(LDFLAGS)
+
+
+ monica.o: monica.cpp
+- $(CXX) -c $(CXXFLAGS) $(INCPATH) -o monica.o monica.cpp
++ $(CXX) -c $(FLTK_CXXFLAGS) $(CXXFLAGS) $(INCPATH) -o monica.o monica.cpp
+
+ clean:
+ rm -f $(OBJECTS)
+ rm -f monica
+
diff --git a/media-gfx/monica/files/monica-3.7-gcc44.patch b/media-gfx/monica/files/monica-3.7-gcc44.patch
new file mode 100644
index 000000000000..6fad87c6f86b
--- /dev/null
+++ b/media-gfx/monica/files/monica-3.7-gcc44.patch
@@ -0,0 +1,11 @@
+diff -ur monica-3.7.orig/monica.cpp monica-3.7/monica.cpp
+--- monica-3.7.orig/monica.cpp 2008-06-02 06:45:50.000000000 +0300
++++ monica-3.7/monica.cpp 2009-07-24 20:42:12.000000000 +0300
+@@ -14,6 +14,7 @@
+ #include <FL/Fl_Tooltip.H>
+ #include <FL/Fl_Pixmap.H>
+
++#include <cstdio>
+ #include <cstdlib>
+ #include <string>
+ #include <iostream>