summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Grigo <agrigo2001@yahoo.com.au>2020-08-18 10:24:09 +1000
committerSam James <sam@gentoo.org>2020-08-24 14:41:49 +0100
commit3c56c123b69155630847109905b2aa249a5856f9 (patch)
tree1fd9a9ee18c4ee175bef8af151de56e49aa64fcd /media-gfx/openvdb
parentpackage.mask: unmask s3cmd after fix (diff)
downloadgentoo-3c56c123b69155630847109905b2aa249a5856f9.tar.gz
gentoo-3c56c123b69155630847109905b2aa249a5856f9.tar.bz2
gentoo-3c56c123b69155630847109905b2aa249a5856f9.zip
media-gfx/openvdb: Update to EAPI 7 and switch to cmake eclass
The minimum set of changes to pass repoman checks is to update to EAPI 7 and switch the cmake-utils eclass to cmake Signed-off-by: Adrian Grigo <agrigo2001@yahoo.com.au> Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/openvdb')
-rw-r--r--media-gfx/openvdb/openvdb-4.0.2-r3.ebuild6
-rw-r--r--media-gfx/openvdb/openvdb-5.2.0-r1.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/media-gfx/openvdb/openvdb-4.0.2-r3.ebuild b/media-gfx/openvdb/openvdb-4.0.2-r3.ebuild
index 221e31086115..1996c6be2df2 100644
--- a/media-gfx/openvdb/openvdb-4.0.2-r3.ebuild
+++ b/media-gfx/openvdb/openvdb-4.0.2-r3.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_6 )
-inherit cmake-utils flag-o-matic python-single-r1
+inherit cmake flag-o-matic python-single-r1
DESCRIPTION="Libs for the efficient manipulation of volumetric data"
HOMEPAGE="https://www.openvdb.org"
@@ -85,5 +85,5 @@ src_configure() {
use python && mycmakeargs+=( -DPYOPENVDB_INSTALL_DIRECTORY="$(python_get_sitedir)" )
use test && mycmakeargs+=( -DCPPUNIT_LOCATION="${myprefix}" )
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/media-gfx/openvdb/openvdb-5.2.0-r1.ebuild b/media-gfx/openvdb/openvdb-5.2.0-r1.ebuild
index 2f2eb78d9fcb..3955290220ba 100644
--- a/media-gfx/openvdb/openvdb-5.2.0-r1.ebuild
+++ b/media-gfx/openvdb/openvdb-5.2.0-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_6 )
-inherit cmake-utils flag-o-matic python-single-r1
+inherit cmake flag-o-matic python-single-r1
DESCRIPTION="Libs for the efficient manipulation of volumetric data"
HOMEPAGE="https://www.openvdb.org"
@@ -78,5 +78,5 @@ src_configure() {
use python && mycmakeargs+=( -DPYOPENVDB_INSTALL_DIRECTORY="$(python_get_sitedir)" )
use test && mycmakeargs+=( -DCPPUNIT_LOCATION="${myprefix}" )
- cmake-utils_src_configure
+ cmake_src_configure
}