summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Grigo <agrigo2001@yahoo.com.au>2020-08-18 14:49:14 +1000
committerSam James <sam@gentoo.org>2020-08-24 14:41:51 +0100
commit4a186793a1a0fdb0336bcb41432c1c5f51a8df5f (patch)
tree529e89379ed33c35f2bda3018bb8daeaa74b372a /media-gfx/openvdb
parentmedia-gfx/openvdb: Port for python 3.7 and 3.8 (diff)
downloadgentoo-4a186793a1a0fdb0336bcb41432c1c5f51a8df5f.tar.gz
gentoo-4a186793a1a0fdb0336bcb41432c1c5f51a8df5f.tar.bz2
gentoo-4a186793a1a0fdb0336bcb41432c1c5f51a8df5f.zip
media-gfx/openvdb: Ensure user chooses appropriate abi version
The initial ebuilds for openvdb assumed that they would build the same abi as the major version, unless abiX-compat was given to force building against a legacy version. This makes it difficult for other ebuilds to determine which ABI openvdb supports as they can not rely on a USE flag being set to ensure that openvdb uses the same version they are building against. Starting with openvdb 5, openvdb also requires OPENVDB_ABI_VERSION_NUMBER to be set with the version to build against. This is also hard to determine if the user does not have a USE flag to determine which version is being built against. To fix these problems, I am using abiX-compat where x is 3,4,5... to determine the appropriate number for OPENVDB_ABI_VERSION_NUMBER and other ebuilds can use these flags to determine which openvdb abi to build against. It is required that openvdb and all programs linking with it build against the same openvdb version. These use flags are no longer set by default in the ebuild, so the user must ensure they set abiX-compat in package.use for openvdb and any other package using openvdb (which will be the new versions of blender and openimageio). These use flags must be set even if the user wants to build againt the latest supported abi version (eg abi5-compat for openvdb-5.2.0), which is a change from the old behaviour. I personally think this would be better hidden away inside an eclass and a USE_EXPAND variable. I have submitted a proposal and would be happy to prepare a PR if desired. This can be found at https:// archives.gentoo.org/gentoo-dev/message/1df75c608c83530b43c6ea67e1db8930 Signed-off-by: Adrian Grigo <agrigo2001@yahoo.com.au> Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/openvdb')
-rw-r--r--media-gfx/openvdb/metadata.xml11
-rw-r--r--media-gfx/openvdb/openvdb-4.0.2-r3.ebuild17
-rw-r--r--media-gfx/openvdb/openvdb-5.2.0-r1.ebuild20
3 files changed, 39 insertions, 9 deletions
diff --git a/media-gfx/openvdb/metadata.xml b/media-gfx/openvdb/metadata.xml
index 747061595948..43363d09c1a0 100644
--- a/media-gfx/openvdb/metadata.xml
+++ b/media-gfx/openvdb/metadata.xml
@@ -15,11 +15,14 @@
Chance of Meatballs2' and 'How to Train Your Dragon 2'.
</longdescription>
<use>
- <flag restrict="&lt;media-gfx/openvdb-5.0.0" name="abi3-compat">
- Disables newer features to maintain compatibility with ABI3. Enabled by default.
+ <flag name="abi3-compat">
+ Disables newer features to maintain compatibility with ABI3.
</flag>
- <flag restrict="&gt;=media-gfx/openvdb-5.0.0" name="abi4-compat">
- Disables newer features to maintain compatibility with ABI4. Enabled by default.
+ <flag restrict="&gt;=media-gfx/openvdb-4.0.0" name="abi4-compat">
+ Disables newer features to maintain compatibility with ABI4.
+ </flag>
+ <flag restrict="&gt;=media-gfx/openvdb-5.0.0" name="abi5-compat">
+ Disables newer features to maintain compatibility with ABI5.
</flag>
</use>
<upstream>
diff --git a/media-gfx/openvdb/openvdb-4.0.2-r3.ebuild b/media-gfx/openvdb/openvdb-4.0.2-r3.ebuild
index 7a9db2c7125d..a34fc012d959 100644
--- a/media-gfx/openvdb/openvdb-4.0.2-r3.ebuild
+++ b/media-gfx/openvdb/openvdb-4.0.2-r3.ebuild
@@ -15,9 +15,13 @@ SRC_URI="https://github.com/AcademySoftwareFoundation/${PN}/archive/v${PV}.tar.g
LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="amd64 ~x86"
-IUSE="+abi3-compat doc python test"
+IUSE="abi3-compat abi4-compat doc python test"
RESTRICT="!test? ( test )"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ ^^ ( abi3-compat abi4-compat )
+"
RDEPEND="
dev-libs/boost:=
@@ -71,6 +75,15 @@ src_configure() {
# To stay in sync with Boost
append-cxxflags -std=c++14
+ local version
+ if use abi3-compat; then
+ version=3
+ elif use abi4-compat; then
+ version=4
+ else
+ die "Openvdb abi version is not compatible"
+ fi
+
local mycmakeargs=(
-DBLOSC_LOCATION="${myprefix}"
-DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
diff --git a/media-gfx/openvdb/openvdb-5.2.0-r1.ebuild b/media-gfx/openvdb/openvdb-5.2.0-r1.ebuild
index 383beb063428..4a84ca540d1c 100644
--- a/media-gfx/openvdb/openvdb-5.2.0-r1.ebuild
+++ b/media-gfx/openvdb/openvdb-5.2.0-r1.ebuild
@@ -14,9 +14,12 @@ SRC_URI="https://github.com/AcademySoftwareFoundation/${PN}/archive/v${PV}.tar.g
LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+abi4-compat doc python test"
+IUSE="abi3-compat abi4-compat abi5-compat doc python test"
RESTRICT="!test? ( test )"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ ^^ ( abi3-compat abi4-compat abi5-compat )
+"
RDEPEND="
dev-libs/boost:=
@@ -64,11 +67,22 @@ pkg_setup() {
src_configure() {
local myprefix="${EPREFIX}/usr/"
+ local version
+ if use abi3-compat; then
+ version=3
+ elif use abi4-compat; then
+ version=4
+ elif use abi5-compat; then
+ version=5
+ else
+ die "Openvdb ABI version not specified"
+ fi
+
local mycmakeargs=(
-DBLOSC_LOCATION="${myprefix}"
-DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
-DGLFW3_LOCATION="${myprefix}"
- -DOPENVDB_ABI_VERSION_NUMBER=$(usex abi4-compat 4 5)
+ -DOPENVDB_ABI_VERSION_NUMBER="${version}"
-DOPENVDB_BUILD_DOCS=$(usex doc)
-DOPENVDB_BUILD_PYTHON_MODULE=$(usex python)
-DOPENVDB_BUILD_UNITTESTS=$(usex test)