summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2020-06-14 18:15:19 -0500
committerBen Kohler <bkohler@gentoo.org>2020-06-14 18:19:22 -0500
commit02b8b29f059386fe67063003b214032824b42722 (patch)
tree59ab8a4aeeb5ff4a607cfb753859ef50baba6c87 /media-gfx/pencil
parentsys-kernel/gentoo-sources: Clean-up of 4.9.X series (diff)
downloadgentoo-02b8b29f059386fe67063003b214032824b42722.tar.gz
gentoo-02b8b29f059386fe67063003b214032824b42722.tar.bz2
gentoo-02b8b29f059386fe67063003b214032824b42722.zip
media-gfx/pencil: revbump for qt-5.15.0 fix
Closes: https://bugs.gentoo.org/726954 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'media-gfx/pencil')
-rw-r--r--media-gfx/pencil/files/pencil-0.6.4-fixes-for-qt-5.15.0.patch30
-rw-r--r--media-gfx/pencil/pencil-0.6.4-r1.ebuild65
2 files changed, 95 insertions, 0 deletions
diff --git a/media-gfx/pencil/files/pencil-0.6.4-fixes-for-qt-5.15.0.patch b/media-gfx/pencil/files/pencil-0.6.4-fixes-for-qt-5.15.0.patch
new file mode 100644
index 000000000000..cbbaf2b20658
--- /dev/null
+++ b/media-gfx/pencil/files/pencil-0.6.4-fixes-for-qt-5.15.0.patch
@@ -0,0 +1,30 @@
+--- a/core_lib/src/graphics/bitmap/bitmapimage.cpp
++++ b/core_lib/src/graphics/bitmap/bitmapimage.cpp
+@@ -20,6 +20,7 @@ GNU General Public License for more details.
+ #include <QDebug>
+ #include <QtMath>
+ #include <QFile>
++#include <QPainterPath>
+ #include "util.h"
+
+ BitmapImage::BitmapImage()
+--- a/core_lib/src/graphics/vector/beziercurve.cpp
++++ b/core_lib/src/graphics/vector/beziercurve.cpp
+@@ -22,6 +22,7 @@ GNU General Public License for more details.
+
+ #include <cmath>
+ #include <QList>
++#include <QPainterPath>
+ #include "object.h"
+ #include "pencilerror.h"
+
+--- a/core_lib/src/managers/viewmanager.cpp
++++ b/core_lib/src/managers/viewmanager.cpp
+@@ -15,6 +15,7 @@ GNU General Public License for more details.
+
+ */
+
++#include <QPainterPath>
+ #include "viewmanager.h"
+ #include "editor.h"
+ #include "object.h"
diff --git a/media-gfx/pencil/pencil-0.6.4-r1.ebuild b/media-gfx/pencil/pencil-0.6.4-r1.ebuild
new file mode 100644
index 000000000000..e5623d010010
--- /dev/null
+++ b/media-gfx/pencil/pencil-0.6.4-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop qmake-utils xdg-utils
+
+DESCRIPTION="2D animation and drawing program based on Qt5"
+HOMEPAGE="https://www.pencil2d.org/"
+SRC_URI="https://github.com/pencil2d/${PN}/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+
+S="${WORKDIR}/${P/_/-}"
+
+PATCHES=( "${FILESDIR}"/pencil-0.6.4-fixes-for-qt-5.15.0.patch )
+
+src_prepare() {
+ default
+ sed -e "/^QT/s/xmlpatterns //" \
+ -i core_lib/core_lib.pro tests/tests.pro || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ einstalldocs
+
+ # install target not yet provided
+ # emake INSTALL_ROOT="${D}" install
+ newbin bin/pencil2d ${PN}
+
+ newicon app/data/icons/icon.png ${PN}.png
+ make_desktop_entry ${PN} pencil2d ${PN} Graphics
+
+ insinto /usr/share/mime/packages/
+ doins app/data/pencil2d.xml
+
+ # TODO: Install l10n files
+}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}