summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2018-02-22 20:14:01 +1100
committerMichael Palimaka <kensington@gentoo.org>2018-02-22 20:14:13 +1100
commit263c11e4ce917b7cd59a051575c47964e6038ab0 (patch)
tree12ccc932a51f56cd43d043fad8bb176b62664712 /media-gfx/peps
parentdev-libs/mapm: remove 4.9.5-r0 (diff)
downloadgentoo-263c11e4ce917b7cd59a051575c47964e6038ab0.tar.gz
gentoo-263c11e4ce917b7cd59a051575c47964e6038ab0.tar.bz2
gentoo-263c11e4ce917b7cd59a051575c47964e6038ab0.zip
media-gfx/peps: remove 2.0-r0
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'media-gfx/peps')
-rw-r--r--media-gfx/peps/peps-2.0.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/media-gfx/peps/peps-2.0.ebuild b/media-gfx/peps/peps-2.0.ebuild
deleted file mode 100644
index e232d298ea69..000000000000
--- a/media-gfx/peps/peps-2.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="2"
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Preprocess and convert EPS files to bitmap with Ghostscript"
-HOMEPAGE="http://peps.redprince.net/peps/"
-SRC_URI="http://www.peps.redprince.net/peps/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="X"
-
-DEPEND="app-text/ghostscript-gpl
- app-arch/gzip"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- if use X && ! grep -q x11gray4 <(gs -h 2>/dev/null); then
- die "you need a ghostscript version with 'x11' and 'x11gray4' devices!"
- fi
-}
-
-src_prepare() {
- # adding <string.h> include
- sed -i -e "s:^\(#include.*<unistd.h>.*\):\1\n#include <string.h>:" peps.c
- # adding LDFLAGS to Makefile
- sed -i -e "s:\( -o \): \${LDFLAGS}\1:g" Makefile
-}
-
-src_compile() {
- local myopts="peps"
- use X && myopts="${myopts} xpeps"
- emake CC="$(tc-getCC)" ${myopts} || die "emake failed"
-}
-
-src_install() {
- # manual install, because fixing dumb Makefile is more compilcated
- dobin peps || die "install failed"
- use X && dobin xpeps
-
- doman peps.1
- dodoc README
-
- insinto /etc
- doins peps.mime
-
- # copy PDF so it won't be compressed
- cp peps.pdf "${D}usr/share/doc/${PF}"
-}