summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/peps
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/peps')
-rw-r--r--media-gfx/peps/Manifest1
-rw-r--r--media-gfx/peps/metadata.xml14
-rw-r--r--media-gfx/peps/peps-2.0.ebuild54
3 files changed, 69 insertions, 0 deletions
diff --git a/media-gfx/peps/Manifest b/media-gfx/peps/Manifest
new file mode 100644
index 000000000000..b05b7545e711
--- /dev/null
+++ b/media-gfx/peps/Manifest
@@ -0,0 +1 @@
+DIST peps-2.0.tar.gz 55421 SHA256 b514fed9412548cdcf43a95b6dcf01b2038f314bc9ef363498ebd2779c897a91
diff --git a/media-gfx/peps/metadata.xml b/media-gfx/peps/metadata.xml
new file mode 100644
index 000000000000..3442601e4dfd
--- /dev/null
+++ b/media-gfx/peps/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ peps will preprocess encapsulated Postscript files and allow you to
+ convert them into bitmaps. Note the word allow: peps does not do the
+ conversion for you. Rather, it prepares the Postscript input for a
+ bitmap conversion by Ghostscript, which must already be installed on
+ your system.
+ </longdescription>
+</pkgmetadata>
diff --git a/media-gfx/peps/peps-2.0.ebuild b/media-gfx/peps/peps-2.0.ebuild
new file mode 100644
index 000000000000..9148d36d8a5c
--- /dev/null
+++ b/media-gfx/peps/peps-2.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Peps preprocesses EPS files and passes it to Ghostscript for conversion into a bitmap"
+HOMEPAGE="http://peps.redprince.net/peps/"
+SRC_URI="http://www.peps.redprince.net/peps/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="X"
+
+DEPEND="app-text/ghostscript-gpl
+ app-arch/gzip"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if use X && ! grep -q x11gray4 <(gs -h 2>/dev/null); then
+ die "you need a ghostscript version with 'x11' and 'x11gray4' devices!"
+ fi
+}
+
+src_prepare() {
+ # adding <string.h> include
+ sed -i -e "s:^\(#include.*<unistd.h>.*\):\1\n#include <string.h>:" peps.c
+ # adding LDFLAGS to Makefile
+ sed -i -e "s:\( -o \): \${LDFLAGS}\1:g" Makefile
+}
+
+src_compile() {
+ local myopts="peps"
+ use X && myopts="${myopts} xpeps"
+ emake CC="$(tc-getCC)" ${myopts} || die "emake failed"
+}
+
+src_install() {
+ # manual install, because fixing dumb Makefile is more compilcated
+ dobin peps || die "install failed"
+ use X && dobin xpeps
+
+ doman peps.1
+ dodoc README
+
+ insinto /etc
+ doins peps.mime
+
+ # copy PDF so it won't be compressed
+ cp peps.pdf "${D}usr/share/doc/${PF}"
+}