summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-05-30 21:14:38 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-05-30 21:14:50 +0200
commit97dde1a3a5aa88d0f340c346a6996ed56b6a637e (patch)
tree18fbf42510d4171ff385812d9c74b17d34613163 /media-gfx/pngquant
parentmedia-gfx/libimagequant: bump to v2.12.3 (diff)
downloadgentoo-97dde1a3a5aa88d0f340c346a6996ed56b6a637e.tar.gz
gentoo-97dde1a3a5aa88d0f340c346a6996ed56b6a637e.tar.bz2
gentoo-97dde1a3a5aa88d0f340c346a6996ed56b6a637e.zip
media-gfx/pngquant: bump to v2.12.3
Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'media-gfx/pngquant')
-rw-r--r--media-gfx/pngquant/Manifest1
-rw-r--r--media-gfx/pngquant/pngquant-2.12.3.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/media-gfx/pngquant/Manifest b/media-gfx/pngquant/Manifest
index 95ec88186ab1..0f66b208bd9f 100644
--- a/media-gfx/pngquant/Manifest
+++ b/media-gfx/pngquant/Manifest
@@ -1 +1,2 @@
DIST pngquant-2.12.2-src.tar.gz 143404 BLAKE2B b06b1185fdeb1990e6b6f0cb77e33051729731fc2c2f4b1f618bd9077057354eabc21405872c938dbdf5395040860b4a884e9780bbd439da36f2af61d53e82a9 SHA512 ed82e0a57d9f4f3ee40258c4cbbf7ed086177dee1e2afdcb7d308f779c83fb2be9c7226c0713b9c72e6b6c22161dbaca3d14f2bdc2f0468daa608be80e9ef1c9
+DIST pngquant-2.12.3-src.tar.gz 143572 BLAKE2B 6f4cc9f36c9148f36734d9afa3765e206c09e833064cff5d98494d0d71610e857d7c605bc5673eb9fd5b38029ade60c9c1ffc18e745a3dfe5dbde6d39a81d0c7 SHA512 cf39f56750a49b2818fb86b168845e54f3797b664c3f49535ee93a3dc899299192a692039396ffcddc5988d040a778006c5f701f8bcd9f5c73583a47b711b01c
diff --git a/media-gfx/pngquant/pngquant-2.12.3.ebuild b/media-gfx/pngquant/pngquant-2.12.3.ebuild
new file mode 100644
index 000000000000..822e8fbf648f
--- /dev/null
+++ b/media-gfx/pngquant/pngquant-2.12.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="command-line utility and library for lossy compression of PNG images"
+HOMEPAGE="https://pngquant.org/"
+SRC_URI="https://pngquant.org/${P}-src.tar.gz"
+
+LICENSE="GPL-3 HPND rwpng"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug lcms openmp cpu_flags_x86_sse2"
+
+RDEPEND="media-libs/libpng:0=
+ media-gfx/libimagequant:=
+ sys-libs/zlib:=
+ lcms? ( media-libs/lcms:2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.12.2-respect-CFLAGS.patch )
+
+src_prepare() {
+ default
+
+ # avoid silent fallback to bundled lib
+ rm -rv lib || die
+}
+
+src_configure() {
+ tc-export AR CC
+ # Hand rolled configure script, so not all flags are supported.
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ --with-libimagequant \
+ $(use debug && echo --enable-debug) \
+ $(use_enable cpu_flags_x86_sse2 sse) \
+ $(use openmp && tc-has-openmp && echo --with-openmp) \
+ $(use_with lcms lcms2) \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc CHANGELOG README.md
+}