summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJiayi Zhao <jeff.no.zhao@gmail.com>2018-01-14 10:48:48 -0500
committerMichał Górny <mgorny@gentoo.org>2018-03-13 08:41:43 +0100
commit1ea23f10d0bc7b27c925ac9a5375ea9ea126331c (patch)
tree6b8f50eccf330387856f904880dae12c58149375 /media-gfx/qimgv
parenttoolchain.eclass: Use :0= for dependency on >=dev-libs/isl-0.14. (diff)
downloadgentoo-1ea23f10d0bc7b27c925ac9a5375ea9ea126331c.tar.gz
gentoo-1ea23f10d0bc7b27c925ac9a5375ea9ea126331c.tar.bz2
gentoo-1ea23f10d0bc7b27c925ac9a5375ea9ea126331c.zip
media-gfx/qimgv: new package
Closes: https://github.com/gentoo/gentoo/pull/6858
Diffstat (limited to 'media-gfx/qimgv')
-rw-r--r--media-gfx/qimgv/Manifest1
-rw-r--r--media-gfx/qimgv/metadata.xml12
-rw-r--r--media-gfx/qimgv/qimgv-0.6.ebuild44
-rw-r--r--media-gfx/qimgv/qimgv-9999.ebuild38
4 files changed, 95 insertions, 0 deletions
diff --git a/media-gfx/qimgv/Manifest b/media-gfx/qimgv/Manifest
new file mode 100644
index 000000000000..307592128283
--- /dev/null
+++ b/media-gfx/qimgv/Manifest
@@ -0,0 +1 @@
+DIST qimgv-0.6.tar.gz 232586 BLAKE2B 077210c16906dbc746f18295f80ac8ea5f948b4abba366659826ebd0ebad1876da53be26a3855c58a2f25e2cfc02fb2ef030a74e17e89f92b2aef572e58a8e0c SHA512 50156a6bdf08e8cc82d30ad23d1deef7f0c119c970c8e577d8b0de65f6b11827e0cf57593834ae7e8887dce5d83215cbd98e9c5b8905d6a3580943e432bdb6cb
diff --git a/media-gfx/qimgv/metadata.xml b/media-gfx/qimgv/metadata.xml
new file mode 100644
index 000000000000..ccef191fae16
--- /dev/null
+++ b/media-gfx/qimgv/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>jeff.no.zhao@gmail.com</email>
+ <name>Jiayi Zhao</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/media-gfx/qimgv/qimgv-0.6.ebuild b/media-gfx/qimgv/qimgv-0.6.ebuild
new file mode 100644
index 000000000000..1d1623a2470c
--- /dev/null
+++ b/media-gfx/qimgv/qimgv-0.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils xdg-utils
+
+DESCRIPTION="A cross-platform image viewer with webm support. Written in qt5"
+HOMEPAGE="https://github.com/easymodo/qimgv"
+SRC_URI="https://github.com/easymodo/qimgv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ media-video/mpv[libmpv]
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # so cmake can find binaries
+ sed -i 's/build\/qimgv/${CMAKE_BINARY_DIR}\/qimgv/' CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
diff --git a/media-gfx/qimgv/qimgv-9999.ebuild b/media-gfx/qimgv/qimgv-9999.ebuild
new file mode 100644
index 000000000000..a5955797418a
--- /dev/null
+++ b/media-gfx/qimgv/qimgv-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit git-r3 cmake-utils gnome2-utils xdg-utils
+
+DESCRIPTION="A cross-platform image viewer with webm support. Written in qt5."
+HOMEPAGE="https://github.com/easymodo/qimgv"
+
+EGIT_REPO_URI="https://github.com/easymodo/qimgv.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ media-video/mpv[libmpv]
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}