summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-08-24 22:02:26 +0200
committerMichał Górny <mgorny@gentoo.org>2017-08-24 22:08:16 +0200
commit9ea8af00b8f5d1cb6598614c6f9d3d2ef5864355 (patch)
tree9b9f19a195b7afe1cd56cd26750333fe9790a16d /media-gfx/ristretto/ristretto-0.8.2_p20170821.ebuild
parentdev-libs/libmspack: CVE-2017-6419, bug 628684. (diff)
downloadgentoo-9ea8af00b8f5d1cb6598614c6f9d3d2ef5864355.tar.gz
gentoo-9ea8af00b8f5d1cb6598614c6f9d3d2ef5864355.tar.bz2
gentoo-9ea8af00b8f5d1cb6598614c6f9d3d2ef5864355.zip
media-gfx/ristretto: Add a snapshot using gdbus, #628426
Diffstat (limited to 'media-gfx/ristretto/ristretto-0.8.2_p20170821.ebuild')
-rw-r--r--media-gfx/ristretto/ristretto-0.8.2_p20170821.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-gfx/ristretto/ristretto-0.8.2_p20170821.ebuild b/media-gfx/ristretto/ristretto-0.8.2_p20170821.ebuild
new file mode 100644
index 000000000000..bce668dc9152
--- /dev/null
+++ b/media-gfx/ristretto/ristretto-0.8.2_p20170821.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils xdg-utils
+
+MY_P=${P%_p*}git-rd21ed3c
+DESCRIPTION="A fast and lightweight picture viewer for Xfce"
+HOMEPAGE="https://docs.xfce.org/apps/ristretto/start"
+SRC_URI="https://dev.gentoo.org/~mgorny/dist/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/dbus-glib-0.98:0=
+ >=dev-libs/glib-2.24:2=
+ media-libs/libexif:0=
+ x11-libs/cairo:0=
+ >=x11-libs/gtk+-2.20:2=
+ x11-libs/libX11:0=
+ >=xfce-base/libxfce4ui-4.10:0=
+ >=xfce-base/libxfce4util-4.10:0=
+ >=xfce-base/xfconf-4.10:0="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}