summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Mayo <aklhfex@gmail.com>2017-05-18 19:44:17 +0100
committerMichał Górny <mgorny@gentoo.org>2017-05-18 21:40:39 +0200
commit693e8708e2d51fd691fe899d724fa75722a22b91 (patch)
treed5120e7c6084bfe21fecdada36e651a53efaadd5 /media-gfx/scour
parentsys-apps/hdparm: arm64 stable (bug 617238). (diff)
downloadgentoo-693e8708e2d51fd691fe899d724fa75722a22b91.tar.gz
gentoo-693e8708e2d51fd691fe899d724fa75722a22b91.tar.bz2
gentoo-693e8708e2d51fd691fe899d724fa75722a22b91.zip
media-gfx/scour: Fix Python dependencies and support tests
Closes: https://github.com/gentoo/gentoo/pull/4659 Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'media-gfx/scour')
-rw-r--r--media-gfx/scour/scour-0.35-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/media-gfx/scour/scour-0.35-r1.ebuild b/media-gfx/scour/scour-0.35-r1.ebuild
new file mode 100644
index 000000000000..6d884d56e170
--- /dev/null
+++ b/media-gfx/scour/scour-0.35-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Take an SVG file and produce a cleaner and more concise file"
+HOMEPAGE="http://www.codedread.com/scour/"
+SRC_URI="https://github.com/codedread/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE=""
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ "${EPYTHON}" testscour.py -v || die "Tests fail with ${EPYTHON}"
+}