summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-15 16:53:22 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-15 17:23:54 +0200
commite6773c101e6b7c8922923a11c6f488af9b402341 (patch)
tree2c5c805a30dbd54bafe35f9b48e161ab20c937e0 /media-gfx/scour
parentnet-libs/quiche: drop 0.20.1 (diff)
downloadgentoo-e6773c101e6b7c8922923a11c6f488af9b402341.tar.gz
gentoo-e6773c101e6b7c8922923a11c6f488af9b402341.tar.bz2
gentoo-e6773c101e6b7c8922923a11c6f488af9b402341.zip
media-gfx/scour: Enable py3.12
Closes: https://bugs.gentoo.org/929625 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-gfx/scour')
-rw-r--r--media-gfx/scour/metadata.xml1
-rw-r--r--media-gfx/scour/scour-0.38.2-r1.ebuild14
2 files changed, 11 insertions, 4 deletions
diff --git a/media-gfx/scour/metadata.xml b/media-gfx/scour/metadata.xml
index b229b50ca604..85d1478227ea 100644
--- a/media-gfx/scour/metadata.xml
+++ b/media-gfx/scour/metadata.xml
@@ -5,5 +5,6 @@
<stabilize-allarches/>
<upstream>
<remote-id type="github">scour-project/scour</remote-id>
+ <remote-id type="pypi">scour</remote-id>
</upstream>
</pkgmetadata>
diff --git a/media-gfx/scour/scour-0.38.2-r1.ebuild b/media-gfx/scour/scour-0.38.2-r1.ebuild
index 30d85af79f5f..7749f9b9fa22 100644
--- a/media-gfx/scour/scour-0.38.2-r1.ebuild
+++ b/media-gfx/scour/scour-0.38.2-r1.ebuild
@@ -1,21 +1,27 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
+
inherit distutils-r1
DESCRIPTION="Take an SVG file and produce a cleaner and more concise file"
-HOMEPAGE="https://github.com/scour-project/scour"
+HOMEPAGE="
+ https://github.com/scour-project/scour/
+ https://pypi.org/project/scour/
+"
SRC_URI="https://github.com/scour-project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 ~sparc x86"
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
python_test() {
"${EPYTHON}" test_scour.py -v || die "Tests fail with ${EPYTHON}"