summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-12-12 11:27:50 +0100
committerPacho Ramos <pacho@gentoo.org>2015-12-12 11:28:17 +0100
commitbcf4dfafacc4bf41d870da6584264d2b9366698c (patch)
tree79f71470025766aa7014994caf3afc4113e5bc3f /media-gfx/simple-scan/simple-scan-3.18.2.ebuild
parentsys-auth/skey: Unpack patches in WORKDIR instead of S. (diff)
downloadgentoo-bcf4dfafacc4bf41d870da6584264d2b9366698c.tar.gz
gentoo-bcf4dfafacc4bf41d870da6584264d2b9366698c.tar.bz2
gentoo-bcf4dfafacc4bf41d870da6584264d2b9366698c.zip
media-gfx/simple-scan: Version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'media-gfx/simple-scan/simple-scan-3.18.2.ebuild')
-rw-r--r--media-gfx/simple-scan/simple-scan-3.18.2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/media-gfx/simple-scan/simple-scan-3.18.2.ebuild b/media-gfx/simple-scan/simple-scan-3.18.2.ebuild
new file mode 100644
index 000000000000..113fe00a9bcc
--- /dev/null
+++ b/media-gfx/simple-scan/simple-scan-3.18.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.22"
+
+inherit gnome2 vala versionator
+
+DESCRIPTION="Simple document scanning utility"
+HOMEPAGE="https://launchpad.net/simple-scan"
+
+MY_PV=$(get_version_component_range 1-2)
+SRC_URI="https://launchpad.net/${PN}/${MY_PV}/${PV}/+download/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="colord"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.32:2
+ dev-libs/libgusb
+ >=media-gfx/sane-backends-1.0.20:=
+ >=sys-libs/zlib-1.2.3.1:=
+ virtual/jpeg:0=
+ x11-libs/cairo:=
+ >=x11-libs/gtk+-3:3
+ colord? ( >=x11-misc/colord-0.1.24:=[udev] )
+"
+RDEPEND="${COMMON_DEPEND}
+ x11-misc/xdg-utils
+ x11-themes/adwaita-icon-theme
+"
+DEPEND="${COMMON_DEPEND}
+ $(vala_depend)
+ app-text/yelp-tools
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # https://bugs.launchpad.net/simple-scan/+bug/1462769
+ rm -f src/simple_scan_vala.stamp || die
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="NEWS README.md"
+ gnome2_src_configure \
+ --disable-packagekit \
+ $(use_enable colord)
+}