summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-24 11:45:06 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-24 13:11:19 +0100
commit809d3d6fce454e80a52438fe5cee0f25e89b9ab4 (patch)
tree3114fca85ed85caf5b4145811fd39a5dfe1e8fb6 /media-gfx/symboleditor
parentmedia-fonts/oxygen-fonts: Fix d and t w/ accents in regular and bold fonts (diff)
downloadgentoo-809d3d6fce454e80a52438fe5cee0f25e89b9ab4.tar.gz
gentoo-809d3d6fce454e80a52438fe5cee0f25e89b9ab4.tar.bz2
gentoo-809d3d6fce454e80a52438fe5cee0f25e89b9ab4.zip
media-gfx/symboleditor: EAPI-7 bump, cmake fix, fix typo, drop blocker
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/symboleditor')
-rw-r--r--media-gfx/symboleditor/files/symboleditor-2.0.0-cmake.patch41
-rw-r--r--media-gfx/symboleditor/files/symboleditor-2.0.0-doc-optional.patch28
-rw-r--r--media-gfx/symboleditor/symboleditor-2.0.0-r1.ebuild48
3 files changed, 117 insertions, 0 deletions
diff --git a/media-gfx/symboleditor/files/symboleditor-2.0.0-cmake.patch b/media-gfx/symboleditor/files/symboleditor-2.0.0-cmake.patch
new file mode 100644
index 000000000000..ab0bd049bef3
--- /dev/null
+++ b/media-gfx/symboleditor/files/symboleditor-2.0.0-cmake.patch
@@ -0,0 +1,41 @@
+From 8739cd6f5fe0f2ed0cf9913170573c62ee246c63 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Burkhard=20L=C3=BCck?= <lueck@hube-lueck.de>
+Date: Thu, 22 Sep 2016 21:17:07 +0200
+Subject: cleanup CMakeLists.txt
+
+remove qt5_wrap_ui wrong because the app uses xgettext and line 60 already has ki18n_wrap_ui
+remove add_definitions (-DTRANSLATION_DOMAIN=SymbolEditor), that is only for libraries
+and
+src/Main.cpp:84: KLocalizedString::setApplicationDomain(SymbolEditor);
+is used to load the translation catalog
+REVIEW:128126
+---
+ CMakeLists.txt | 6 ------
+ 1 file changed, 6 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index d1016cb..d88174a 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -64,10 +64,6 @@ add_subdirectory (doc)
+
+ kconfig_add_kcfg_files (SymbolEditor_SRCS SymbolEditor.kcfgc)
+
+-qt5_wrap_ui (SymbolEditor_SRCS
+- ui/EditorConfigPage.ui
+-)
+-
+ ecm_install_icons (ICONS sc-apps-SymbolEditor.svgz DESTINATION ${ICON_INSTALL_DIR})
+
+ add_executable (SymbolEditor ${SymbolEditor_SRCS})
+@@ -89,8 +85,6 @@ add_definitions (
+ -DKDE_NO_COMPAT
+ )
+
+-add_definitions (-DTRANSLATION_DOMAIN="SymbolEditor")
+-
+ if (SILENCE_DEPRECATED)
+ add_definitions( -Wno-deprecated-declarations )
+ endif (SILENCE_DEPRECATED)
+--
+cgit v1.1
diff --git a/media-gfx/symboleditor/files/symboleditor-2.0.0-doc-optional.patch b/media-gfx/symboleditor/files/symboleditor-2.0.0-doc-optional.patch
new file mode 100644
index 000000000000..3434e90c6122
--- /dev/null
+++ b/media-gfx/symboleditor/files/symboleditor-2.0.0-doc-optional.patch
@@ -0,0 +1,28 @@
+From 2b809c68d40a3d0af2da668bad3f4d9ced86f56e Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Thu, 10 Mar 2016 20:26:57 +0100
+Subject: KF5DocTools is optional, so add doc subdir conditionally
+
+REVIEW: 127336
+---
+ CMakeLists.txt | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index d88174a..da7458f 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -60,7 +60,10 @@ file (GLOB SymbolEditor_UI ${CMAKE_CURRENT_SOURCE_DIR}/ui/*.ui)
+ ki18n_wrap_ui (SymbolEditor_SRCS ${SymbolEditor_UI})
+
+ add_subdirectory (icons)
+-add_subdirectory (doc)
++
++if (KF5DocTools_FOUND)
++ add_subdirectory (doc)
++endif (KF5DocTools_FOUND)
+
+ kconfig_add_kcfg_files (SymbolEditor_SRCS SymbolEditor.kcfgc)
+
+--
+cgit v1.1
diff --git a/media-gfx/symboleditor/symboleditor-2.0.0-r1.ebuild b/media-gfx/symboleditor/symboleditor-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..3661330a67f4
--- /dev/null
+++ b/media-gfx/symboleditor/symboleditor-2.0.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="optional"
+inherit kde5
+
+DESCRIPTION="Application to create libraries of QPainterPath objects with rendering hints"
+HOMEPAGE="https://userbase.kde.org/SymbolEditor"
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ MY_P=SymbolEditor-${PV}
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${MY_P}.tar.bz2"
+ S="${WORKDIR}"/${MY_P}
+fi
+
+LICENSE="GPL-2"
+KEYWORDS="amd64"
+IUSE=""
+
+BDEPEND="
+ sys-devel/gettext
+"
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-cmake.patch"
+ "${FILESDIR}/${P}-doc-optional.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON
+ )
+
+ kde5_src_configure
+}