summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-05-02 09:46:22 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-05-02 09:51:46 +0200
commit91f36308f8226f775c5fb4258a9600e45a0779c4 (patch)
tree8e9e8f9296c31d8fcd0905043a90a4cbf2b8f6d6 /media-gfx/uniconvertor
parentmedia-video/dvdauthor: Added slotdep for imagemagick. Bumped to EAPI-6. (diff)
downloadgentoo-91f36308f8226f775c5fb4258a9600e45a0779c4.tar.gz
gentoo-91f36308f8226f775c5fb4258a9600e45a0779c4.tar.bz2
gentoo-91f36308f8226f775c5fb4258a9600e45a0779c4.zip
media-gfx/uniconvertor: Added slotdep for imagemagick. Bumped to EAPI-6.
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-gfx/uniconvertor')
-rw-r--r--media-gfx/uniconvertor/uniconvertor-2.0_pre379-r1.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/media-gfx/uniconvertor/uniconvertor-2.0_pre379-r1.ebuild b/media-gfx/uniconvertor/uniconvertor-2.0_pre379-r1.ebuild
index c41c97664191..505e9e503302 100644
--- a/media-gfx/uniconvertor/uniconvertor-2.0_pre379-r1.ebuild
+++ b/media-gfx/uniconvertor/uniconvertor-2.0_pre379-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 )
@@ -19,7 +19,7 @@ IUSE=""
RDEPEND="
dev-python/pycairo[${PYTHON_USEDEP}]
- media-gfx/imagemagick
+ media-gfx/imagemagick:=
media-libs/lcms:2
dev-python/pillow[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
@@ -33,8 +33,10 @@ PATCHES=(
)
python_prepare_all() {
+ default
+
local wand
- wand=$(pkg-config --libs Wand | sed -e "s:^ *::g" -e "s: *$::g" -e "s:-l:\':g" -e "s: :',:g" -e "s:$:':g" -e "s:,'$::g")
+ wand=$(pkg-config --libs MagickWand | sed -e "s:^ *::g" -e "s: *$::g" -e "s:-l:\':g" -e "s: :',:g" -e "s:$:':g" -e "s:,'$::g")
distutils-r1_python_prepare_all