summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-10-01 17:36:35 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-10-01 18:15:46 +0200
commit7562815cf329f4f3dea152e55bdad21ad6bd37ce (patch)
tree477cae64da7480e20d8d54b16f754ab71f0713bd /media-gfx/wally
parentnet-firewall/shorewall: Bump to v5.1.7.2 (diff)
downloadgentoo-7562815cf329f4f3dea152e55bdad21ad6bd37ce.tar.gz
gentoo-7562815cf329f4f3dea152e55bdad21ad6bd37ce.tar.bz2
gentoo-7562815cf329f4f3dea152e55bdad21ad6bd37ce.zip
media-gfx/wally: Drop USE=kde, ebuild makeover, bug #629032
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'media-gfx/wally')
-rw-r--r--media-gfx/wally/files/wally-2.2.0-disable-kde4.patch14
-rw-r--r--media-gfx/wally/wally-2.4.5.ebuild40
2 files changed, 16 insertions, 38 deletions
diff --git a/media-gfx/wally/files/wally-2.2.0-disable-kde4.patch b/media-gfx/wally/files/wally-2.2.0-disable-kde4.patch
deleted file mode 100644
index 95f471ce1cd5..000000000000
--- a/media-gfx/wally/files/wally-2.2.0-disable-kde4.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -238,11 +238,6 @@ else( APPLE )
- add_custom_command( TARGET ${PROGNAME} POST_BUILD COMMAND strip ARGS ${WALLY_PATH} WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} )
- endif( CMAKE_BUILD_TYPE STREQUAL Release )
-
-- find_package( KDE4 )
-- if ( KDE4_FOUND )
-- add_subdirectory( ${CMAKE_SOURCE_DIR}/wallyplugin )
-- endif( KDE4_FOUND )
--
- endif( APPLE )
-
- file( GLOB TS_FILES ${CMAKE_SOURCE_DIR}/res/lang/*.ts )
diff --git a/media-gfx/wally/wally-2.4.5.ebuild b/media-gfx/wally/wally-2.4.5.ebuild
index 26ef94ccc9d0..e22dcfe2f182 100644
--- a/media-gfx/wally/wally-2.4.5.ebuild
+++ b/media-gfx/wally/wally-2.4.5.ebuild
@@ -1,20 +1,18 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-KDE_REQUIRED="optional"
-SQL_REQUIRED="always"
-inherit eutils kde4-base readme.gentoo
+inherit cmake-utils eutils xdg-utils
-DESCRIPTION="A Qt4/KDE4 wallpaper changer"
+DESCRIPTION="Qt4 wallpaper changer"
HOMEPAGE="http://www.becrux.com/index.php?page=projects&name=wally"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="4"
KEYWORDS="amd64 x86"
-IUSE="debug kde"
+IUSE="debug"
DEPEND="
dev-qt/qtcore:4
@@ -24,28 +22,17 @@ DEPEND="
dev-qt/qtsvg:4
media-libs/libexif
x11-libs/libX11
- kde? ( kde-frameworks/kdelibs:4[plasma(+)] )
"
RDEPEND="${DEPEND}"
-DOCS=(
- "AUTHORS" "ChangeLog" "README" "README.XFCE4"
- "README.shortcuts" "TODO"
-)
-PATCHES=(
- "${FILESDIR}"/${PN}-2.2.0-disable_popup.patch
-)
-
-src_prepare() {
- DOC_CONTENTS="In order to use wallyplugin you need to
- restart plasma in your KDE4 enviroment."
- kde4-base_src_prepare
- use kde || epatch "${FILESDIR}"/${PN}-2.2.0-disable-kde4.patch
-}
+DOCS=( AUTHORS ChangeLog README README.XFCE4 README.shortcuts TODO )
+
+PATCHES=( "${FILESDIR}"/${PN}-2.2.0-disable_popup.patch )
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DSTATIC=FALSE
+ -DCMAKE_DISABLE_FIND_PACKAGE_KDE4=ON
)
cmake-utils_src_configure
}
@@ -54,9 +41,14 @@ src_install() {
cmake-utils_src_install
newicon "${S}"/res/images/idle.png wally.png
make_desktop_entry wally Wally wally "Graphics;Qt"
- use kde && readme.gentoo_create_doc
}
pkg_postinst() {
- use kde && readme.gentoo_print_elog
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
}