summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-02-17 14:28:13 +0100
committerUlrich Müller <ulm@gentoo.org>2020-02-17 16:53:58 +0100
commit9f359924f7b78bf0bd15a69380ff41a7c005fa5e (patch)
tree080e5541fef732e956c9d6204bd60b537cd3a1f5 /media-gfx/word_cloud
parentdev-db/mysql: ppc64 stable wrt bug #709624 (diff)
downloadgentoo-9f359924f7b78bf0bd15a69380ff41a7c005fa5e.tar.gz
gentoo-9f359924f7b78bf0bd15a69380ff41a7c005fa5e.tar.bz2
gentoo-9f359924f7b78bf0bd15a69380ff41a7c005fa5e.zip
media-gfx/word_cloud: Initial import.
Ebuild contributed by me. Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'media-gfx/word_cloud')
-rw-r--r--media-gfx/word_cloud/Manifest1
-rw-r--r--media-gfx/word_cloud/files/word_cloud-1.6.0-bundled-font.patch9
-rw-r--r--media-gfx/word_cloud/metadata.xml7
-rw-r--r--media-gfx/word_cloud/word_cloud-1.6.0.ebuild24
4 files changed, 41 insertions, 0 deletions
diff --git a/media-gfx/word_cloud/Manifest b/media-gfx/word_cloud/Manifest
new file mode 100644
index 000000000000..8eac0255ce86
--- /dev/null
+++ b/media-gfx/word_cloud/Manifest
@@ -0,0 +1 @@
+DIST word_cloud-1.6.0.tar.gz 27524706 BLAKE2B 751b78fca97ec6e93c6a766c5b960dbb5fd91c012637e9c905ef96eea0dc60882ef1604a9868cfb3ca91a2c9ac6f50132ad5d820e6dd52114e68112bbe6decb0 SHA512 cb67570e2f6206c92316ef398382703b4ff0f1740688cd4a9ec66a093a663e903da66daaef666d634a7fddc5ec19da859d706693940a963a3bf58c52e9054056
diff --git a/media-gfx/word_cloud/files/word_cloud-1.6.0-bundled-font.patch b/media-gfx/word_cloud/files/word_cloud-1.6.0-bundled-font.patch
new file mode 100644
index 000000000000..3c43b30ce42b
--- /dev/null
+++ b/media-gfx/word_cloud/files/word_cloud-1.6.0-bundled-font.patch
@@ -0,0 +1,9 @@
+Don't install bundled DroidSansMono font.
+
+--- a/setup.py
++++ b/setup.py
+@@ -24,3 +24,3 @@
+ packages=['wordcloud'],
+- package_data={'wordcloud': ['stopwords', 'DroidSansMono.ttf']}
++ package_data={'wordcloud': ['stopwords']}
+ )
diff --git a/media-gfx/word_cloud/metadata.xml b/media-gfx/word_cloud/metadata.xml
new file mode 100644
index 000000000000..c665e48637be
--- /dev/null
+++ b/media-gfx/word_cloud/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>ulm@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/media-gfx/word_cloud/word_cloud-1.6.0.ebuild b/media-gfx/word_cloud/word_cloud-1.6.0.ebuild
new file mode 100644
index 000000000000..a8a60e0fb337
--- /dev/null
+++ b/media-gfx/word_cloud/word_cloud-1.6.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="A little word cloud generator in Python"
+HOMEPAGE="https://amueller.github.io/word_cloud/"
+SRC_URI="https://github.com/amueller/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ media-fonts/droid"
+
+PATCHES=( "${FILESDIR}"/${P}-bundled-font.patch )