summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-11 04:23:56 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-11 04:56:00 -0400
commitd0c72584cae39d84e8fc5c8ce03baa3874efcc38 (patch)
tree6923cad7db77183f4897004e7dc24080d341809d /media-gfx/xli
parentmail-filter/dcc: fix for -std=c2x early (diff)
downloadgentoo-d0c72584cae39d84e8fc5c8ce03baa3874efcc38.tar.gz
gentoo-d0c72584cae39d84e8fc5c8ce03baa3874efcc38.tar.bz2
gentoo-d0c72584cae39d84e8fc5c8ce03baa3874efcc38.zip
media-gfx/xli: pass -std=gnu89
Does not build with `clang -std=c2x`, early workaround for when this will become a default. (not actively hunting for these, merely revisiting packages previously looked at for clang16 even if not an issue "yet"). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-gfx/xli')
-rw-r--r--media-gfx/xli/xli-1.17.0-r6.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/media-gfx/xli/xli-1.17.0-r6.ebuild b/media-gfx/xli/xli-1.17.0-r6.ebuild
index a33109d2bef3..573868770552 100644
--- a/media-gfx/xli/xli-1.17.0-r6.ebuild
+++ b/media-gfx/xli/xli-1.17.0-r6.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
SNAPSHOT="2005-02-27"
DESCRIPTION="X Load Image: view images or load them to root window"
@@ -61,6 +61,8 @@ src_prepare() {
}
src_configure() {
+ append-cflags -std=gnu89 # old codebase, incompatible with c2x
+
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf || die
}