summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/xpaint/files/xpaint-2.9.9.4-QA1.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/xpaint/files/xpaint-2.9.9.4-QA1.patch')
-rw-r--r--media-gfx/xpaint/files/xpaint-2.9.9.4-QA1.patch91
1 files changed, 91 insertions, 0 deletions
diff --git a/media-gfx/xpaint/files/xpaint-2.9.9.4-QA1.patch b/media-gfx/xpaint/files/xpaint-2.9.9.4-QA1.patch
new file mode 100644
index 000000000000..31e3a38ba005
--- /dev/null
+++ b/media-gfx/xpaint/files/xpaint-2.9.9.4-QA1.patch
@@ -0,0 +1,91 @@
+From 2987bfa203a8467a697efffa211b90b12858b40b Mon Sep 17 00:00:00 2001
+From: hasufell <hasufell@gentoo.org>
+Date: Sun, 6 Oct 2013 20:37:28 +0200
+Subject: [PATCH] respect flags, add WITH_PGF option, fix echo
+
+---
+ util/Makefile | 56 +++++++++++++++++++++++++++++++++++---------------------
+ 1 file changed, 35 insertions(+), 21 deletions(-)
+
+diff --git a/util/Makefile b/util/Makefile
+index e6af415..21a0d17 100644
+--- a/util/Makefile
++++ b/util/Makefile
+@@ -1,39 +1,53 @@
+-GCC = gcc
+-CPP = g++ -fpermissive
++# set to anything but "no" to enable
++WITH_PGF=no
+
++ifneq ($(WITH_PGF),no)
+ all: pdfconcat ppmtops pgf2pnm
++else
++all: pdfconcat ppmtops
++endif
+
+ pdfconcat:
+- $(GCC) -O3 -s -DNDEBUG=1 -DNO_CONFIG=1 -ansi -pedantic -Wunused -Wall -W -Wstrict-prototypes -Wtraditional -Wnested-externs -Winline -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wmissing-prototypes -Wmissing-declarations pdfconcat.c -o pdfconcat
++ $(CC) $(CFLAGS) -DNDEBUG=1 -DNO_CONFIG=1 -ansi -pedantic -Wunused -Wall -W -Wstrict-prototypes -Wtraditional -Wnested-externs -Winline -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wmissing-prototypes -Wmissing-declarations pdfconcat.c -o pdfconcat $(LDFLAGS)
+
+ ppmtops:
+- $(GCC) ppmtops.c -o ppmtops
++ $(CC) $(CFLAGS) ppmtops.c -o ppmtops $(LDFLAGS)
+
++ifneq ($(WITH_PGF),no)
+ pgf2pnm: main.cpp pnm.cpp
+ @if [ -x /usr/include/libpgf ] ; then \
+- $(CPP) -c main.cpp -o main.o -I/usr/include/libpgf ; \
+- $(CPP) -c pnm.cpp -o pnm.o -I/usr/include/libpgf ; \
+- $(CPP) -o pgf2pnm main.o pnm.o -lpgf ; \
++ $(CXX) $(CXXFLAGS) -fpermissive -c main.cpp -o main.o -I/usr/include/libpgf ; \
++ $(CXX) $(CXXFLAGS) -fpermissive -c pnm.cpp -o pnm.o -I/usr/include/libpgf ; \
++ $(CXX) $(CXXFLAGS) -fpermissive -o pgf2pnm main.o pnm.o $(LDFLAGS) -lpgf ; \
+ else \
+- @echo "libpgf not installed !!" ; \
++ echo "libpgf not installed !!" ; \
+ fi
++endif
+
+-install:
++install-common:
+ @if [ -x pdfconcat ] ; then \
+- mkdir -p $(DESTDIR)/usr/bin ; \
+- install -c pdfconcat $(DESTDIR)/usr/bin ; \
+- echo "install -c pdfconcat $(DESTDIR)/usr/bin" ; \
+- mkdir -p $(DESTDIR)/usr/share/man/man1 ; \
+- install -c -m 644 pdfconcat.1 $(DESTDIR)/usr/share/man/man1 ; \
+- echo "install -c pdfconcat.1 $(DESTDIR)/usr/share/man/man1" ; fi
++ mkdir -p "$(DESTDIR)"/usr/bin ; \
++ install -c pdfconcat "$(DESTDIR)"/usr/bin ; \
++ echo "install -c pdfconcat "$(DESTDIR)"/usr/bin" ; \
++ mkdir -p "$(DESTDIR)"/usr/share/man/man1 ; \
++ install -c -m 644 pdfconcat.1 "$(DESTDIR)"/usr/share/man/man1 ; \
++ echo "install -c pdfconcat.1 "$(DESTDIR)"/usr/share/man/man1" ; fi
+ @if [ -x ppmtops ] ; then \
+- mkdir -p $(DESTDIR)/usr/bin ; \
+- install -c ppmtops $(DESTDIR)/usr/bin ; \
+- echo "install -c ppmtops $(DESTDIR)/usr/bin" ; fi
++ mkdir -p "$(DESTDIR)"/usr/bin ; \
++ install -c ppmtops "$(DESTDIR)"/usr/bin ; \
++ echo "install -c ppmtops "$(DESTDIR)"/usr/bin" ; fi
++
++install-pgf:
+ @if [ -x pgf2pnm ] ; then \
+- mkdir -p $(DESTDIR)/usr/bin ; \
+- install -c pgf2pnm $(DESTDIR)/usr/bin ; \
+- echo "install -c pgf2pnm $(DESTDIR)/usr/bin" ; fi
++ mkdir -p "$(DESTDIR)"/usr/bin ; \
++ install -c pgf2pnm "$(DESTDIR)"/usr/bin ; \
++ echo "install -c pgf2pnm "$(DESTDIR)"/usr/bin" ; fi
++
++ifneq ($(WITH_PGF),no)
++install: install-common install-pgf
++else
++install: install-common
++endif
+
+ clean:
+ rm -f core *~ *.o pdfconcat ppmtops pgf2pnm
+--
+1.8.3.2
+