summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/zbar/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/zbar/files')
-rw-r--r--media-gfx/zbar/files/zbar-0.10-errors.patch10
-rw-r--r--media-gfx/zbar/files/zbar-0.10-no-v4l1-check.patch74
-rw-r--r--media-gfx/zbar/files/zbar-0.10-python-crash.patch19
3 files changed, 103 insertions, 0 deletions
diff --git a/media-gfx/zbar/files/zbar-0.10-errors.patch b/media-gfx/zbar/files/zbar-0.10-errors.patch
new file mode 100644
index 000000000000..63328ce664bb
--- /dev/null
+++ b/media-gfx/zbar/files/zbar-0.10-errors.patch
@@ -0,0 +1,10 @@
+--- zbar-0.10/include/zbar/Exception.h
++++ zbar-0.10/include/zbar/Exception.h
+@@ -32,6 +32,7 @@
+
+ #include <exception>
+ #include <new>
++#include <cstddef>
+
+ namespace zbar {
+
diff --git a/media-gfx/zbar/files/zbar-0.10-no-v4l1-check.patch b/media-gfx/zbar/files/zbar-0.10-no-v4l1-check.patch
new file mode 100644
index 000000000000..b25827a0b998
--- /dev/null
+++ b/media-gfx/zbar/files/zbar-0.10-no-v4l1-check.patch
@@ -0,0 +1,74 @@
+--- zbar-0.10/configure.ac
++++ zbar-0.10/configure.ac
+@@ -147,19 +147,13 @@
+ with_video="no"
+ AS_IF([test "x$enable_video" != "xno"],
+ [AS_IF([test "x$win32" = "xno"],
+- [AC_CHECK_HEADERS([linux/videodev.h], [with_video="v4l1"],
+- [AC_MSG_FAILURE([test for video support failed!
+-rebuild your kernel to include video4linux support or
+-configure --disable-video to skip building video support.])])
+- AC_CHECK_HEADERS([linux/videodev2.h], [with_video="v4l2"],
++ [AC_CHECK_HEADERS([linux/videodev2.h], [with_video="v4l2"],
+ [AC_MSG_WARN([v4l2 API not detected, upgrade your kernel!])])],
+ [AC_CHECK_HEADERS([vfw.h], [with_video="vfw"],
+ [AC_MSG_FAILURE([test for VfW video support failed!
+ configure --disable-video to skip building vidoe support.])])])
+ ])
+ AM_CONDITIONAL([HAVE_VIDEO], [test "x$enable_video" != "xno"])
+-AM_CONDITIONAL([HAVE_V4L1],
+- [test "x$with_video" = "xv4l1" || test "x$with_video" = "xv4l2"])
+ AM_CONDITIONAL([HAVE_V4L2], [test "x$with_video" = "xv4l2"])
+
+ dnl X
+--- zbar-0.10/zbar/Makefile.am.inc
++++ zbar-0.10/zbar/Makefile.am.inc
+@@ -53,12 +53,9 @@
+ zbar_libzbar_la_SOURCES += zbar/processor/posix.h zbar/processor/posix.c
+ endif
+
+-if HAVE_V4L1
+-zbar_libzbar_la_SOURCES += zbar/video/v4l1.c
+ if HAVE_V4L2
+ zbar_libzbar_la_SOURCES += zbar/video/v4l2.c
+ endif
+-endif
+ if WIN32
+ if HAVE_VIDEO
+ zbar_libzbar_la_SOURCES += zbar/video/vfw.c
+--- zbar-0.10/zbar/video/v4l2.c
++++ zbar-0.10/zbar/video/v4l2.c
+@@ -39,6 +39,9 @@
+ # include <sys/mman.h>
+ #endif
+ #include <linux/videodev2.h>
++#include <sys/stat.h>
++#include <unistd.h>
++#include <fcntl.h>
+
+ #include "video.h"
+ #include "image.h"
+@@ -507,3 +507,23 @@
+ vdo->dq = v4l2_dq;
+ return(0);
+ }
++
++int _zbar_video_open (zbar_video_t *vdo,
++ const char *dev)
++{
++ vdo->fd = open(dev, O_RDWR);
++ if(vdo->fd < 0)
++ return(err_capture_str(vdo, SEV_ERROR, ZBAR_ERR_SYSTEM, __func__,
++ "opening video device '%s'", dev));
++ zprintf(1, "opened camera device %s (fd=%d)\n", dev, vdo->fd);
++
++ int rc = -1;
++ if(vdo->intf != VIDEO_V4L1)
++ rc = _zbar_v4l2_probe(vdo);
++
++ if(rc && vdo->fd >= 0) {
++ close(vdo->fd);
++ vdo->fd = -1;
++ }
++ return(rc);
++}
diff --git a/media-gfx/zbar/files/zbar-0.10-python-crash.patch b/media-gfx/zbar/files/zbar-0.10-python-crash.patch
new file mode 100644
index 000000000000..a6f7a96e34db
--- /dev/null
+++ b/media-gfx/zbar/files/zbar-0.10-python-crash.patch
@@ -0,0 +1,19 @@
+https://sourceforge.net/p/zbar/patches/37/
+
+fix from Debian for crashes when importing the python module.
+http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=702499
+
+this doesn't happen on some arches as the data naturally ends up with zero
+data after the structure, but on some (like arm), it isn't so we crash when
+python walks the list.
+
+--- a/python/imagescanner.c
++++ b/python/imagescanner.c
+@@ -68,6 +68,7 @@ imagescanner_get_results (zbarImageScanner *self,
+
+ static PyGetSetDef imagescanner_getset[] = {
+ { "results", (getter)imagescanner_get_results, },
++ { NULL },
+ };
+
+ static PyObject*