summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/zgv/files/zgv-5.9-Makefile-QA.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/zgv/files/zgv-5.9-Makefile-QA.patch')
-rw-r--r--media-gfx/zgv/files/zgv-5.9-Makefile-QA.patch56
1 files changed, 56 insertions, 0 deletions
diff --git a/media-gfx/zgv/files/zgv-5.9-Makefile-QA.patch b/media-gfx/zgv/files/zgv-5.9-Makefile-QA.patch
new file mode 100644
index 000000000000..e4569547d175
--- /dev/null
+++ b/media-gfx/zgv/files/zgv-5.9-Makefile-QA.patch
@@ -0,0 +1,56 @@
+diff -NrU5 zgv-5.9.original/src/Makefile zgv-5.9/src/Makefile
+--- zgv-5.9.original/src/Makefile 2009-09-28 15:31:29.000000000 -0600
++++ zgv-5.9/src/Makefile 2009-09-28 15:56:26.000000000 -0600
+@@ -45,11 +45,11 @@
+ readbmp.o readtga.o readpng.o readpcx.o \
+ readxvpic.o readmrf.o readxbm.o readxpm.o \
+ modesel.o readpcd.o readtiff.o readprf.o zgv_io.o
+
+ zgv: $(ZGV_OBJS)
+- $(CC) $(CFLAGS) -o zgv $(ZGV_OBJS) $(ZGV_LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o zgv $(ZGV_OBJS) $(ZGV_LIBS)
+
+ bdf2h: bdf2h.o
+ $(CC) $(CFLAGS) -o bdf2h bdf2h.o
+
+ install-info: install-info.c
+@@ -59,28 +59,28 @@
+ # installation. Not nice to put this in the install target,
+ # but it's likely to cause problems if I don't.
+ #
+ install: all
+ @if [ "$(BACKEND)" = SVGALIB ]; then \
+- echo $(RM) /usr/bin/zgv; \
+- $(RM) /usr/bin/zgv; \
+- echo install -m 4755 -o root -g root -s zgv $(BINDIR); \
+- install -m 4755 -o root -g root -s zgv $(BINDIR); \
++ echo echo /usr/bin/zgv; \
++ echo /usr/bin/zgv; \
++ echo install -m 0755 -o root -g root zgv $(BINDIR); \
++ install -m 0755 -o root -g root zgv $(BINDIR); \
+ fi
+ @if [ "$(BACKEND)" = SDL ]; then \
+- echo $(RM) /usr/bin/zgv-sdl; \
+- $(RM) /usr/bin/zgv-sdl; \
+- echo install -m 755 -s zgv $(BINDIR)/zgv-sdl; \
+- install -m 755 -s zgv $(BINDIR)/zgv-sdl; \
++ echo echo /usr/bin/zgv-sdl; \
++ echo /usr/bin/zgv-sdl; \
++ echo install -m 755 zgv $(BINDIR)/zgv-sdl; \
++ install -m 755 zgv $(BINDIR)/zgv-sdl; \
+ fi
+
+ uninstall:
+- $(RM) $(BINDIR)/zgv $(BINDIR)/zgv-sdl
++ echo $(BINDIR)/zgv $(BINDIR)/zgv-sdl
+
+ clean:
+- $(RM) *.o *~ zgv bdf2h fontbmps.h install-info
+- $(RM) rcfile_opt.h rcfile_var.h rcfile_short.h
++ echo *.o *~ zgv bdf2h fontbmps.h install-info
++ echo rcfile_opt.h rcfile_var.h rcfile_short.h
+
+ # Dependancies
+ 3deffects.o: 3deffects.c 3deffects.h font.h readnbkey.h zgv.h \
+ rc_config.h rcfile.h mousecur.h rbmenu.h
+ bdf2h.o: bdf2h.c