summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-07-01 00:07:11 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-07-01 02:03:37 +0200
commit04ddbd05f3f89fde01e38fcd64993b42cd45e64d (patch)
treeb535bb12352736e7830d166a9596e58a802960a6 /media-gfx
parentmedia-gfx/openmesh: src_configure cleanup (diff)
downloadgentoo-04ddbd05f3f89fde01e38fcd64993b42cd45e64d.tar.gz
gentoo-04ddbd05f3f89fde01e38fcd64993b42cd45e64d.tar.bz2
gentoo-04ddbd05f3f89fde01e38fcd64993b42cd45e64d.zip
media-gfx/openmesh: EAPI-6 bump
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/openmesh/openmesh-4.1.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/media-gfx/openmesh/openmesh-4.1.ebuild b/media-gfx/openmesh/openmesh-4.1.ebuild
index 33cb49ca2bb9..bea079ae6a4b 100644
--- a/media-gfx/openmesh/openmesh-4.1.ebuild
+++ b/media-gfx/openmesh/openmesh-4.1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
-inherit eutils cmake-utils
+EAPI=6
+
+inherit cmake-utils
MY_PN="OpenMesh"
MY_PV="${PV/_rc/-RC}"
@@ -24,6 +25,8 @@ RDEPEND="
DEPEND="${RDEPEND}
test? ( dev-cpp/gtest )"
+DOCS=( LICENSE/{LICENSE,README.txt} README CHANGELOG )
+
src_prepare() {
cmake-utils_src_prepare
@@ -55,11 +58,6 @@ src_configure() {
cmake-utils_src_configure
}
-src_install() {
- cmake-utils_src_install
- dodoc LICENSE/* README CHANGELOG
-}
-
src_test() {
cd "${BUILD_DIR}" || die
LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:${BUILD_DIR}/Build/$(get_libdir) ctest --verbose