summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2018-03-06 21:07:37 +1100
committerMichael Palimaka <kensington@gentoo.org>2018-03-06 21:07:49 +1100
commit2447ff09ba599abc0a850b24d30a3af857a3b295 (patch)
tree594be30481ed43af6f48041d38fc4b1673c53f86 /media-gfx
parentx11-misc/xscreensaver: Depend on x11-libs/libXft (bug #649532 by William Thro... (diff)
downloadgentoo-2447ff09ba599abc0a850b24d30a3af857a3b295.tar.gz
gentoo-2447ff09ba599abc0a850b24d30a3af857a3b295.tar.bz2
gentoo-2447ff09ba599abc0a850b24d30a3af857a3b295.zip
media-gfx/phototonic: version bump 2.0
Closes: https://bugs.gentoo.org/649186 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/phototonic/Manifest1
-rw-r--r--media-gfx/phototonic/phototonic-2.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/media-gfx/phototonic/Manifest b/media-gfx/phototonic/Manifest
index a83780e7a658..54755d057903 100644
--- a/media-gfx/phototonic/Manifest
+++ b/media-gfx/phototonic/Manifest
@@ -1 +1,2 @@
DIST phototonic-1.6.17.tar.xz 167264 BLAKE2B 39df863da3084454fbde2f4a02f4b4251be2487d0bb7628fb20a8a6b4ade653ea93324262815ac1f2d778310941f27d73b34ed6dc71aeade9a7236350674b011 SHA512 66c537c723b114de8a92692933a3671346919dde1ce028a9c067909403d91c0a161d5887e0c07e9309d524179308364fc93403c608b3226d74e28bc744e08cde
+DIST phototonic-2.0.tar.gz 283185 BLAKE2B 0c86fa991fd2c05721d19c603becd27f93139377416ff4c9b2749488c5d5753263d3223d3bd71d3a4670289243b471ccdcb7f937d2f080cbd7dd6442cf7257f4 SHA512 e72952c76332b592043a39a4920ab941f20b3494d66e9855becf09438e36c0edbdbf1a384a08a9b825c5e48ac4c87b5e4cb7d1eaff7076140ad2537868aa4357
diff --git a/media-gfx/phototonic/phototonic-2.0.ebuild b/media-gfx/phototonic/phototonic-2.0.ebuild
new file mode 100644
index 000000000000..46087619b847
--- /dev/null
+++ b/media-gfx/phototonic/phototonic-2.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils qmake-utils xdg-utils
+
+DESCRIPTION="Image viewer and organizer"
+HOMEPAGE="https://github.com/oferkv/phototonic"
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/oferkv/phototonic.git"
+else
+ SRC_URI="https://github.com/oferkv/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="svg tiff"
+
+RDEPEND="
+ dev-qt/qtwidgets:5
+ dev-qt/qtgui:5
+ dev-qt/qtcore:5
+ media-gfx/exiv2:=
+ svg? ( dev-qt/qtsvg:5 )
+ tiff? ( dev-qt/qtimageformats:5 )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}