summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-30 09:18:35 +0100
committerSam James <sam@gentoo.org>2022-07-30 09:18:41 +0100
commit362e9b8b81b47da9c015abf3af60a705609a0080 (patch)
treedac8ea411d3b0815b15be9dbfef0c5b0df7039c6 /media-gfx
parentprofiles/arch/ia64: mask USE=tcmalloc (diff)
downloadgentoo-362e9b8b81b47da9c015abf3af60a705609a0080.tar.gz
gentoo-362e9b8b81b47da9c015abf3af60a705609a0080.tar.bz2
gentoo-362e9b8b81b47da9c015abf3af60a705609a0080.zip
media-gfx/graphicsmagick: fix automagic deps; bashism in configure
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/graphicsmagick/files/graphicsmagick-1.3.38-configure-bashism.patch34
-rw-r--r--media-gfx/graphicsmagick/graphicsmagick-1.3.38-r1.ebuild160
-rw-r--r--media-gfx/graphicsmagick/graphicsmagick-9999.ebuild18
3 files changed, 207 insertions, 5 deletions
diff --git a/media-gfx/graphicsmagick/files/graphicsmagick-1.3.38-configure-bashism.patch b/media-gfx/graphicsmagick/files/graphicsmagick-1.3.38-configure-bashism.patch
new file mode 100644
index 000000000000..69d5fd50a1bf
--- /dev/null
+++ b/media-gfx/graphicsmagick/files/graphicsmagick-1.3.38-configure-bashism.patch
@@ -0,0 +1,34 @@
+# HG changeset patch
+# User Sam James <sam@gentoo.org>
+# Date 1659168362 -3600
+# Sat Jul 30 09:06:02 2022 +0100
+# Node ID aa77bc8461ee15501a0298dafd53c97447aa30d0
+# Parent 0a06f497d58839e4100b3be46bbdcd14d8147d75
+configure: fix bashism
+
+configure scripts need to be runnable with a POSIX-compliant /bin/sh.
+
+On many (but not all!) systems, /bin/sh is provided by Bash, so errors
+like this aren't spotted. Notably Debian defaults to /bin/sh provided
+by dash which doesn't tolerate such bashisms as '=='.
+
+This retains compatibility with bash.
+
+Fixes configure warnings/errors like:
+```
+checking for gs... /usr/sbin/gs
+./configure: 31719: test: #: unexpected operator
+checking for Windows fonts directory (location of arial.ttf)... /usr/share/fonts/corefonts/
+```
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -3148,7 +3148,7 @@ have_ralcgm='no' ; if test "$CGMDecodeD
+ AM_CONDITIONAL([HasPSDelegate],[test "$have_gs" = 'yes'])
+
+ # Tests for programs only used while in maintainer mode
+-if test "$MAINT" == '' ; then
++if test "$MAINT" = '' ; then
+ # Test for optional rst2html.py utility and define automake conditional HasRST2HTML if found.
+ AC_CHECK_PROGS([RST2HTML],[rst2html.py rst2html])
+
diff --git a/media-gfx/graphicsmagick/graphicsmagick-1.3.38-r1.ebuild b/media-gfx/graphicsmagick/graphicsmagick-1.3.38-r1.ebuild
new file mode 100644
index 000000000000..f3cdeac277df
--- /dev/null
+++ b/media-gfx/graphicsmagick/graphicsmagick-1.3.38-r1.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+MY_P=${P/graphicsm/GraphicsM}
+DESCRIPTION="Collection of tools and libraries for many image formats"
+HOMEPAGE="http://www.graphicsmagick.org/ https://hg.osdn.net/view/graphicsmagick/GM"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit mercurial
+ EHG_REPO_URI="http://hg.code.sf.net/p/${PN}/code"
+else
+ VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/bobfriesenhahn.asc
+ inherit verify-sig
+ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+ SRC_URI+=" verify-sig? ( mirror://sourceforge/${PN}/${MY_P}.tar.xz.sig )"
+ S="${WORKDIR}/${MY_P}"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+ BDEPEND="verify-sig? ( sec-keys/openpgp-keys-bobfriesenhahn )"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV%.*}"
+
+IUSE="bzip2 +cxx debug dynamic-loading fpx heif imagemagick jbig jpeg jpegxl lcms lzma"
+IUSE+=" openmp perl png postscript q16 q32 static-libs svg tcmalloc threads tiff truetype"
+IUSE+=" webp wmf X zlib zstd"
+
+RDEPEND="
+ dev-libs/libltdl
+ bzip2? ( app-arch/bzip2 )
+ fpx? ( media-libs/libfpx )
+ heif? ( media-libs/libheif:= )
+ imagemagick? ( !media-gfx/imagemagick )
+ jbig? ( media-libs/jbigkit )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ jpegxl? ( media-libs/libjxl:= )
+ lcms? ( media-libs/lcms:2 )
+ lzma? ( app-arch/xz-utils )
+ perl? ( dev-lang/perl:= )
+ png? ( media-libs/libpng:= )
+ postscript? ( app-text/ghostscript-gpl )
+ svg? ( dev-libs/libxml2 )
+ tcmalloc? ( dev-util/google-perftools:= )
+ tiff? ( media-libs/tiff )
+ truetype? (
+ media-fonts/urw-fonts
+ >=media-libs/freetype-2
+ )
+ webp? ( media-libs/libwebp:= )
+ wmf? ( media-libs/libwmf )
+ X? (
+ x11-libs/libSM
+ x11-libs/libXext
+ )
+ zlib? ( sys-libs/zlib )
+ zstd? ( app-arch/zstd:= )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.36-flags.patch
+ "${FILESDIR}"/${PN}-1.3.19-perl.patch
+ "${FILESDIR}"/${P}-configure-bashism.patch
+)
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local depth=8
+
+ use q16 && depth=16
+ use q32 && depth=32
+
+ local myeconfargs=(
+ --enable-largefile
+ --enable-shared
+ $(use_enable static-libs static)
+ $(use_enable debug prof)
+ $(use_enable debug gcov)
+ $(use_enable imagemagick magick-compat)
+ $(use_enable openmp)
+ $(use_with threads)
+ $(use_with dynamic-loading modules)
+ --with-quantum-depth=${depth}
+ --without-frozenpaths
+ $(use_with cxx magick-plus-plus)
+ $(use_with heif)
+ $(use_with jpegxl jxl)
+ $(use_with perl)
+ --with-perl-options=INSTALLDIRS=vendor
+ $(use_with bzip2 bzlib)
+ $(use_with postscript dps)
+ $(use_with fpx)
+ $(use_with jbig)
+ $(use_with webp)
+ $(use_with jpeg)
+ # Needs last-rited/unpackaged jasper
+ --without-jp2
+ $(use_with lcms lcms2)
+ $(use_with lzma)
+ $(use_with png)
+ $(use_with tcmalloc)
+ $(use_with tiff)
+ --without-trio
+ $(use_with truetype ttf)
+ $(use_with wmf)
+ --with-fontpath="${EPREFIX}"/usr/share/fonts
+ --with-gs-font-dir="${EPREFIX}"/usr/share/fonts/urw-fonts
+ --with-windows-font-dir="${EPREFIX}"/usr/share/fonts/corefonts
+ $(use_with svg xml)
+ $(use_with zlib)
+ $(use_with zstd)
+ $(use_with X x)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+
+ use perl && emake perl-build
+}
+
+src_test() {
+ unset DISPLAY # some perl tests fail when DISPLAY is set
+
+ default
+}
+
+src_install() {
+ default
+
+ if use perl ; then
+ emake -C PerlMagick DESTDIR="${D}" install
+
+ find "${ED}" -type f -name perllocal.pod -exec rm -f {} + || die
+ find "${ED}" -depth -mindepth 1 -type d -empty -exec rm -rf {} + || die
+ fi
+
+ find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} + || die
+}
diff --git a/media-gfx/graphicsmagick/graphicsmagick-9999.ebuild b/media-gfx/graphicsmagick/graphicsmagick-9999.ebuild
index ed7baccc45e1..c3cfd69b4baf 100644
--- a/media-gfx/graphicsmagick/graphicsmagick-9999.ebuild
+++ b/media-gfx/graphicsmagick/graphicsmagick-9999.ebuild
@@ -28,16 +28,17 @@ LICENSE="MIT"
SLOT="0/${PV%.*}"
IUSE="bzip2 +cxx debug dynamic-loading fpx heif imagemagick jbig jpeg jpegxl lcms lzma"
-IUSE+=" openmp perl png postscript q16 q32 static-libs svg threads tiff truetype"
-IUSE+=" webp wmf X zlib"
+IUSE+=" openmp perl png postscript q16 q32 static-libs svg tcmalloc threads tiff truetype"
+IUSE+=" webp wmf X zlib zstd"
-RDEPEND="dev-libs/libltdl
+RDEPEND="
+ dev-libs/libltdl
bzip2? ( app-arch/bzip2 )
fpx? ( media-libs/libfpx )
heif? ( media-libs/libheif:= )
imagemagick? ( !media-gfx/imagemagick )
jbig? ( media-libs/jbigkit )
- jpeg? ( virtual/jpeg )
+ jpeg? ( media-libs/libjpeg-turbo:= )
jpegxl? ( media-libs/libjxl:= )
lcms? ( media-libs/lcms:2 )
lzma? ( app-arch/xz-utils )
@@ -45,6 +46,7 @@ RDEPEND="dev-libs/libltdl
png? ( media-libs/libpng:= )
postscript? ( app-text/ghostscript-gpl )
svg? ( dev-libs/libxml2 )
+ tcmalloc? ( dev-util/google-perftools:= )
tiff? ( media-libs/tiff )
truetype? (
media-fonts/urw-fonts
@@ -56,7 +58,9 @@ RDEPEND="dev-libs/libltdl
x11-libs/libSM
x11-libs/libXext
)
- zlib? ( sys-libs/zlib )"
+ zlib? ( sys-libs/zlib )
+ zstd? ( app-arch/zstd:= )
+"
DEPEND="${RDEPEND}"
PATCHES=(
@@ -107,11 +111,14 @@ src_configure() {
$(use_with jbig)
$(use_with webp)
$(use_with jpeg)
+ # Needs last-rited/unpackaged jasper
--without-jp2
$(use_with lcms lcms2)
$(use_with lzma)
$(use_with png)
+ $(use_with tcmalloc)
$(use_with tiff)
+ --without-trio
$(use_with truetype ttf)
$(use_with wmf)
--with-fontpath="${EPREFIX}"/usr/share/fonts
@@ -119,6 +126,7 @@ src_configure() {
--with-windows-font-dir="${EPREFIX}"/usr/share/fonts/corefonts
$(use_with svg xml)
$(use_with zlib)
+ $(use_with zstd)
$(use_with X x)
)