summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-24 10:30:28 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-24 10:30:28 +0200
commit39475d0f0bd78c990693517044643cea39477369 (patch)
treedec06f3e806332e2d6758332c7b9f4bab18b3107 /media-gfx
parentsci-visualization/scidavis: add another missing dep (diff)
downloadgentoo-39475d0f0bd78c990693517044643cea39477369.tar.gz
gentoo-39475d0f0bd78c990693517044643cea39477369.tar.bz2
gentoo-39475d0f0bd78c990693517044643cea39477369.zip
media-gfx/libredwg: import from ::sci
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/libredwg/Manifest1
-rw-r--r--media-gfx/libredwg/libredwg-0.12.4.ebuild78
-rw-r--r--media-gfx/libredwg/metadata.xml12
3 files changed, 91 insertions, 0 deletions
diff --git a/media-gfx/libredwg/Manifest b/media-gfx/libredwg/Manifest
new file mode 100644
index 000000000000..1899b90fb653
--- /dev/null
+++ b/media-gfx/libredwg/Manifest
@@ -0,0 +1 @@
+DIST libredwg-0.12.4.tar.gz 18318912 BLAKE2B 21ff443881c19782c747ddf880eba23090295432edf4367161472aeef970e1b93983967e667ca2c3e140bf0b97e7b238bbe4a342815df365cee10bde83a04178 SHA512 df9424f475be512a6e9e02a1156a7d6a966f684f5753f420843593ee9dc236bd33bd10dbd627bab1b9adab9b8e7cb3a6b464c15e643ae755bc7e11974c05cd7a
diff --git a/media-gfx/libredwg/libredwg-0.12.4.ebuild b/media-gfx/libredwg/libredwg-0.12.4.ebuild
new file mode 100644
index 000000000000..f6d7f18dea12
--- /dev/null
+++ b/media-gfx/libredwg/libredwg-0.12.4.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DOCS_BUILDER="doxygen"
+# File is hardcoded to be run from ../ so we use this instead of DOCS_DIR
+DOCS_CONFIG_NAME="doc/Doxyfile"
+
+inherit docs python-single-r1 perl-functions
+
+DESCRIPTION="C library to handle DWG files"
+HOMEPAGE="https://www.gnu.org/software/libredwg/"
+SRC_URI="https://github.com/LibreDWG/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# https://github.com/LibreDWG/libredwg/issues/342
+RESTRICT="test"
+
+IUSE="debug python perl static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ python? ( ${PYTHON_DEPS} )
+ perl? ( dev-lang/perl )
+ dev-libs/libpcre2
+ dev-libs/pslib
+"
+DEPEND="${RDEPEND}
+ python? ( dev-lang/swig )
+ perl? ( dev-lang/swig )
+"
+
+src_configure() {
+ perl_set_version
+ local myconf=(
+ --enable-write
+ --enable-dxf
+ --enable-json
+ --disable-gcov
+ $(use_enable !debug release)
+ $(use_enable debug trace)
+ $(use_enable debug)
+ $(use_enable static-libs static)
+ $(use_enable python python "${EPYTHON}")
+ $(usex perl "--with-perl-install=vendor" "--with-perl-install=no")
+ )
+
+ if use python || use perl; then
+ myconf+=( --enable-bindings )
+ else
+ myconf+=( --disable-bindings )
+ fi
+
+ econf ${myconf[@]}
+
+ # Fix variable references itself error, fails in src_install otherwise.
+ # Can't put this in src_prepare and use eautoreconf because eautoreconf
+ # only works inside a git repository for this package.
+ sed -i -e 's/TEXINPUTS = "$(TEXINPUTS)$(PATH_SEPARATOR)$(TEXINFO_TEX_DIR)"/TEXINPUTS = "$(PATH_SEPARATOR)$(TEXINFO_TEX_DIR)"/g' doc/Makefile || die
+}
+
+src_compile() {
+ perl_set_version
+ emake
+ docs_compile
+}
+
+src_install() {
+ perl_set_version
+ default
+ use python && python_optimize
+ use perl && perl_domodule bindings/perl/LibreDWG.pm
+}
diff --git a/media-gfx/libredwg/metadata.xml b/media-gfx/libredwg/metadata.xml
new file mode 100644
index 000000000000..a65951be2662
--- /dev/null
+++ b/media-gfx/libredwg/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">LibreDWG/libredwg</remote-id>
+ <bugs-to>https://github.com/LibreDWG/libredwg/issues</bugs-to>
+ </upstream>
+</pkgmetadata>