summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-03-26 01:18:27 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-03-26 01:21:21 +0100
commit3d8c5adfaa40d1bdebd43d3e432917f81e8394d6 (patch)
tree61e4747b63dc741cca3a66475c263b89e1e2cb12 /media-gfx
parentmedia-gfx/exact-image: add support for slotted lua (diff)
downloadgentoo-3d8c5adfaa40d1bdebd43d3e432917f81e8394d6.tar.gz
gentoo-3d8c5adfaa40d1bdebd43d3e432917f81e8394d6.tar.bz2
gentoo-3d8c5adfaa40d1bdebd43d3e432917f81e8394d6.zip
media-gfx/exact-image: drop old version
Dropping all old versions, which do not support slotted lua. Closes: https://bugs.gentoo.org/634050 Closes: https://bugs.gentoo.org/712618 Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/exact-image/Manifest1
-rw-r--r--media-gfx/exact-image/exact-image-0.8.1-r3.ebuild95
-rw-r--r--media-gfx/exact-image/exact-image-1.0.2.ebuild97
-rw-r--r--media-gfx/exact-image/files/exact-image-0.7.5-libpng14.patch69
-rw-r--r--media-gfx/exact-image/files/exact-image-0.8.1-gcc6.patch139
-rw-r--r--media-gfx/exact-image/files/exact-image-0.8.1-libpng15.patch34
6 files changed, 0 insertions, 435 deletions
diff --git a/media-gfx/exact-image/Manifest b/media-gfx/exact-image/Manifest
index 139b6188894f..484e6b6fdbc1 100644
--- a/media-gfx/exact-image/Manifest
+++ b/media-gfx/exact-image/Manifest
@@ -1,2 +1 @@
-DIST exact-image-0.8.1.tar.bz2 283660 BLAKE2B 49aa68640b785da59fd0e04d0a0892ad06adbc286a98bf908e60e77cfd273263e83dce3c9eb75c30f422c2b6eef2178dd0585aada63f992291abf298b369f3aa SHA512 0adc51c5a29415e236a963cfdaf8f5527e628e9a645e87d00c69a7185e60639cfcd9b1c2b4c3abe1826c5364f0c5d45a0ebb8923cfed53d041d1d36b2604b565
DIST exact-image-1.0.2.tar.bz2 322174 BLAKE2B 67afefb4c5a52416459cd4ac6198012eb6d7895a73ea8363fae05286c7e7f62aa1a02166985f53b5638c7dc7b23b4dc1fb1c7b2272a9dc595ce329a7083ee1b9 SHA512 8ba5a198a236ddf5fa58f40c80f32ba9d300376c637a13a7acf3d2db7906fced373b33a7ecff9cff4d09d8b21de9ce1fb9f5bfb1f4522557bd01af0e3d6dcc65
diff --git a/media-gfx/exact-image/exact-image-0.8.1-r3.ebuild b/media-gfx/exact-image/exact-image-0.8.1-r3.ebuild
deleted file mode 100644
index 54e1fbe7f7f8..000000000000
--- a/media-gfx/exact-image/exact-image-0.8.1-r3.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit eutils multilib toolchain-funcs
-
-DESCRIPTION="A fast, modern and generic image processing library"
-HOMEPAGE="http://www.exactcode.de/site/open_source/exactimage/"
-SRC_URI="http://dl.exactcode.de/oss/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="expat jpeg lua openexr php perl png ruby swig tiff truetype X"
-
-RDEPEND="x11-libs/agg[truetype]
- sys-libs/zlib
- expat? ( dev-libs/expat )
- jpeg? ( virtual/jpeg )
- lua? ( dev-lang/lua:0= )
- openexr? ( media-libs/openexr )
- php? ( dev-lang/php:* )
- perl? ( dev-lang/perl )
- png? ( >=media-libs/libpng-1.2.43 )
- ruby? ( dev-lang/ruby:* )
- tiff? ( media-libs/tiff )
- truetype? ( >=media-libs/freetype-2 )
- X? (
- x11-libs/libXext
- x11-libs/libXt
- x11-libs/libICE
- x11-libs/libSM
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- swig? ( dev-lang/swig )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.7.5-libpng14.patch
- "${FILESDIR}"/${P}-libpng15.patch
- "${FILESDIR}"/${P}-gcc6.patch
-)
-
-src_prepare() {
- default
-
- # Respect user CFLAGS/CXXFLAGS.
- sed -i \
- -e '/C\(XX\)\?FLAGS =/s/-O2//' \
- -e "\$aCFLAGS += ${CFLAGS}\nCXXFLAGS += ${CXXFLAGS}" \
- Makefile || die
-
- # Show commands. Use qualified CC/CXX.
- sed -i \
- -e '/^Q =/d' \
- -e '/^\t@echo /d' \
- -e "\$aCC:=$(tc-getCC)\nCXX:=$(tc-getCXX)" \
- build/bottom.make || die
-
- # The copied string fits exactly. Use memcpy to reflect that a null
- # terminator is not needed.
- sed -i \
- -e 's/strcpy(\([^,]*\)\(,["a-zA-Z -]*\))/memcpy(\1\2, sizeof(\1))/' \
- codecs/tga.cc || die
-}
-
-src_configure() {
- # evas -> enlightenment overlay
- # bardecode -> protected by custom license
- # libungif -> not supported anymore
- # python -> allegedly not python3, but python2 only
-
- ./configure \
- --prefix=/usr \
- --libdir=/usr/$(get_libdir) \
- $(use_with X x11) \
- $(use_with truetype freetype) \
- --without-evas \
- $(use_with jpeg libjpeg) \
- $(use_with tiff libtiff) \
- $(use_with png libpng) \
- --without-libungif \
- --without-jasper \
- $(use_with openexr) \
- $(use_with expat) \
- --without-lcms \
- --without-bardecode \
- $(use_with lua) \
- $(use_with swig) \
- $(use_with perl) \
- --without-python \
- $(use_with php) \
- $(use_with ruby) || die
-}
diff --git a/media-gfx/exact-image/exact-image-1.0.2.ebuild b/media-gfx/exact-image/exact-image-1.0.2.ebuild
deleted file mode 100644
index de0d4b8a5af2..000000000000
--- a/media-gfx/exact-image/exact-image-1.0.2.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit eutils multilib toolchain-funcs
-
-DESCRIPTION="A fast, modern and generic image processing library"
-HOMEPAGE="http://www.exactcode.de/site/open_source/exactimage/"
-SRC_URI="http://dl.exactcode.de/oss/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="expat jpeg lua openexr php perl png ruby swig tiff truetype X"
-
-RDEPEND="x11-libs/agg[truetype]
- sys-libs/zlib
- expat? ( dev-libs/expat )
- jpeg? ( virtual/jpeg )
- lua? ( dev-lang/lua:0= )
- openexr? ( media-libs/openexr )
- php? ( dev-lang/php:* )
- perl? ( dev-lang/perl )
- png? ( >=media-libs/libpng-1.2.43 )
- ruby? ( dev-lang/ruby:* )
- tiff? ( media-libs/tiff )
- truetype? ( >=media-libs/freetype-2 )
- X? (
- x11-libs/libXext
- x11-libs/libXt
- x11-libs/libICE
- x11-libs/libSM
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- swig? ( dev-lang/swig )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-gcc6.patch
- "${FILESDIR}"/${P}-g++.patch
- "${FILESDIR}"/${P}-dcraw.patch
- "${FILESDIR}"/${P}-php.patch
-)
-
-src_prepare() {
- default
-
- # Respect user CFLAGS/CXXFLAGS.
- sed -i \
- -e '/C\(XX\)\?FLAGS =/s/-O2//' \
- -e "\$aCFLAGS += ${CFLAGS}\nCXXFLAGS += ${CXXFLAGS}" \
- Makefile || die
-
- # Show commands. Use qualified CC/CXX.
- sed -i \
- -e '/^Q =/d' \
- -e '/^\t@echo /d' \
- -e "\$aCC:=$(tc-getCC)\nCXX:=$(tc-getCXX)" \
- build/bottom.make || die
-
- # The copied string fits exactly. Use memcpy to reflect that a null
- # terminator is not needed.
- sed -i \
- -e 's/strcpy(\([^,]*\)\(,["a-zA-Z -]*\))/memcpy(\1\2, sizeof(\1))/' \
- codecs/tga.cc || die
-}
-
-src_configure() {
- # evas -> enlightenment overlay
- # bardecode -> protected by custom license
- # libungif -> not supported anymore
- # python -> allegedly not python3, but python2 only
-
- ./configure \
- --prefix=/usr \
- --libdir=/usr/$(get_libdir) \
- $(use_with X x11) \
- $(use_with truetype freetype) \
- --without-evas \
- $(use_with jpeg libjpeg) \
- $(use_with tiff libtiff) \
- $(use_with png libpng) \
- --without-libgif \
- --without-jasper \
- $(use_with openexr) \
- $(use_with expat) \
- --without-lcms \
- --without-bardecode \
- $(use_with lua) \
- $(use_with swig) \
- --without-python \
- $(use_with perl) \
- --without-python \
- $(use_with php) \
- $(use_with ruby) || die
-}
diff --git a/media-gfx/exact-image/files/exact-image-0.7.5-libpng14.patch b/media-gfx/exact-image/files/exact-image-0.7.5-libpng14.patch
deleted file mode 100644
index 7c62a6cbd726..000000000000
--- a/media-gfx/exact-image/files/exact-image-0.7.5-libpng14.patch
+++ /dev/null
@@ -1,69 +0,0 @@
---- a/codecs/png.cc
-+++ b/codecs/png.cc
-@@ -71,7 +71,7 @@
- /* Allocate/initialize the memory for image information. REQUIRED. */
- info_ptr = png_create_info_struct(png_ptr);
- if (info_ptr == NULL) {
-- png_destroy_read_struct(&png_ptr, png_infopp_NULL, png_infopp_NULL);
-+ png_destroy_read_struct(&png_ptr, NULL, NULL);
- return 0;
- }
-
-@@ -82,7 +82,7 @@
-
- if (setjmp(png_jmpbuf(png_ptr))) {
- /* Free all of the memory associated with the png_ptr and info_ptr */
-- png_destroy_read_struct(&png_ptr, &info_ptr, png_infopp_NULL);
-+ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
- /* If we get here, we had a problem reading the file */
- return 0;
- }
-@@ -99,7 +99,7 @@
- png_read_info (png_ptr, info_ptr);
-
- png_get_IHDR (png_ptr, info_ptr, &width, &height, &bit_depth, &color_type,
-- &interlace_type, int_p_NULL, int_p_NULL);
-+ &interlace_type, NULL, NULL);
-
- image.w = width;
- image.h = height;
-@@ -132,7 +132,7 @@
- #if 0 // no longer needed
- /* Expand grayscale images to the full 8 bits from 2, or 4 bits/pixel */
- if (color_type == PNG_COLOR_TYPE_GRAY && bit_depth > 1 && bit_depth < 8) {
-- png_set_gray_1_2_4_to_8(png_ptr);
-+ png_set_expand_gray_1_2_4_to_8(png_ptr);
- image.bps = 8;
- }
- #endif
-@@ -196,11 +196,11 @@
- for (int pass = 0; pass < number_passes; ++pass)
- for (unsigned int y = 0; y < height; ++y) {
- row_pointers[0] = image.getRawData() + y * stride;
-- png_read_rows(png_ptr, row_pointers, png_bytepp_NULL, 1);
-+ png_read_rows(png_ptr, row_pointers, NULL, 1);
- }
-
- /* clean up after the read, and free any memory allocated - REQUIRED */
-- png_destroy_read_struct(&png_ptr, &info_ptr, png_infopp_NULL);
-+ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
-
- /* that's it */
- return true;
-@@ -224,7 +224,7 @@
- /* Allocate/initialize the memory for image information. REQUIRED. */
- info_ptr = png_create_info_struct(png_ptr);
- if (info_ptr == NULL) {
-- png_destroy_write_struct(&png_ptr, png_infopp_NULL);
-+ png_destroy_write_struct(&png_ptr, NULL);
- return false;
- }
-
-@@ -244,7 +244,6 @@
- else if (quality > Z_BEST_COMPRESSION) quality = Z_BEST_COMPRESSION;
- png_set_compression_level(png_ptr, quality);
-
-- png_info_init (info_ptr);
-
- /* Set up our STL stream output control */
- png_set_write_fn (png_ptr, stream, &stdstream_write_data, &stdstream_flush_data);
diff --git a/media-gfx/exact-image/files/exact-image-0.8.1-gcc6.patch b/media-gfx/exact-image/files/exact-image-0.8.1-gcc6.patch
deleted file mode 100644
index 4871c99205a2..000000000000
--- a/media-gfx/exact-image/files/exact-image-0.8.1-gcc6.patch
+++ /dev/null
@@ -1,139 +0,0 @@
-Bug: https://bugs.gentoo.org/600380
-
---- a/bardecode/code25i.hh
-+++ b/bardecode/code25i.hh
-@@ -20,6 +20,12 @@
-
- #include "scanner_utils.hh"
-
-+#if __cplusplus >= 201103L
-+#define STATIC_CONST_DOUBLE static constexpr double
-+#else
-+#define STATIC_CONST_DOUBLE static const double
-+#endif
-+
- namespace BarDecode
- {
- struct code25i_t
-@@ -37,11 +43,11 @@
- #define w_hq 1.5
- #define tol 0.2
- #else
-- static const double n_lq = 15;
-- static const double n_hq = 5.3;
-- static const double w_lq = 5.2;
-- static const double w_hq = 1.5;
-- static const double tol = 0.2;
-+ STATIC_CONST_DOUBLE n_lq = 15;
-+ STATIC_CONST_DOUBLE n_hq = 5.3;
-+ STATIC_CONST_DOUBLE w_lq = 5.2;
-+ STATIC_CONST_DOUBLE w_hq = 1.5;
-+ STATIC_CONST_DOUBLE tol = 0.2;
- #endif
- static const usize_t min_quiet_usize = 5;
- //static const usize_t min_quiet_usize = 10;
---- a/codecs/bmp.cc
-+++ b/codecs/bmp.cc
-@@ -473,7 +473,7 @@
- std::cerr << "scanline " << row << " Seek error: " << stream->tellg() << " vs " << offset << std::endl;
- }
-
-- if (stream->read ((char*)row_data, file_stride) < 0) {
-+ if (!static_cast<bool>(stream->read ((char*)row_data, file_stride))) {
- std::cerr << "scanline " << row << ": Read error\n";
- }
-
---- a/codecs/dcraw.h
-+++ b/codecs/dcraw.h
-@@ -3958,22 +3958,22 @@
- -2,+0,+0,-1,0,0x06, -2,+0,+0,+0,1,0x02, -2,+0,+0,+1,0,0x03,
- -2,+1,-1,+0,0,0x04, -2,+1,+0,-1,1,0x04, -2,+1,+0,+0,0,0x06,
- -2,+1,+0,+1,0,0x02, -2,+2,+0,+0,1,0x04, -2,+2,+0,+1,0,0x04,
-- -1,-2,-1,+0,0,0x80, -1,-2,+0,-1,0,0x01, -1,-2,+1,-1,0,0x01,
-- -1,-2,+1,+0,1,0x01, -1,-1,-1,+1,0,0x88, -1,-1,+1,-2,0,0x40,
-+ -1,-2,-1,+0,0,(signed char) 0x80, -1,-2,+0,-1,0,0x01, -1,-2,+1,-1,0,0x01,
-+ -1,-2,+1,+0,1,0x01, -1,-1,-1,+1,0,(signed char) 0x88, -1,-1,+1,-2,0,0x40,
- -1,-1,+1,-1,0,0x22, -1,-1,+1,+0,0,0x33, -1,-1,+1,+1,1,0x11,
- -1,+0,-1,+2,0,0x08, -1,+0,+0,-1,0,0x44, -1,+0,+0,+1,0,0x11,
- -1,+0,+1,-2,1,0x40, -1,+0,+1,-1,0,0x66, -1,+0,+1,+0,1,0x22,
- -1,+0,+1,+1,0,0x33, -1,+0,+1,+2,1,0x10, -1,+1,+1,-1,1,0x44,
- -1,+1,+1,+0,0,0x66, -1,+1,+1,+1,0,0x22, -1,+1,+1,+2,0,0x10,
- -1,+2,+0,+1,0,0x04, -1,+2,+1,+0,1,0x04, -1,+2,+1,+1,0,0x04,
-- +0,-2,+0,+0,1,0x80, +0,-1,+0,+1,1,0x88, +0,-1,+1,-2,0,0x40,
-+ +0,-2,+0,+0,1,(signed char) 0x80, +0,-1,+0,+1,1,(signed char) 0x88, +0,-1,+1,-2,0,0x40,
- +0,-1,+1,+0,0,0x11, +0,-1,+2,-2,0,0x40, +0,-1,+2,-1,0,0x20,
- +0,-1,+2,+0,0,0x30, +0,-1,+2,+1,1,0x10, +0,+0,+0,+2,1,0x08,
- +0,+0,+2,-2,1,0x40, +0,+0,+2,-1,0,0x60, +0,+0,+2,+0,1,0x20,
- +0,+0,+2,+1,0,0x30, +0,+0,+2,+2,1,0x10, +0,+1,+1,+0,0,0x44,
- +0,+1,+1,+2,0,0x10, +0,+1,+2,-1,1,0x40, +0,+1,+2,+0,0,0x60,
-- +0,+1,+2,+1,0,0x20, +0,+1,+2,+2,0,0x10, +1,-2,+1,+0,0,0x80,
-- +1,-1,+1,+1,0,0x88, +1,+0,+1,+2,0,0x08, +1,+0,+2,-1,0,0x40,
-+ +0,+1,+2,+1,0,0x20, +0,+1,+2,+2,0,0x10, +1,-2,+1,+0,0,(signed char) 0x80,
-+ +1,-1,+1,+1,0,(signed char) 0x88, +1,+0,+1,+2,0,0x08, +1,+0,+2,-1,0,0x40,
- +1,+0,+2,+1,0,0x10
- }, chood[] = { -1,-1, -1,0, -1,+1, 0,+1, +1,+1, +1,0, +1,-1, 0,-1 };
- ushort (*brow[5])[4], *pix;
-@@ -6341,11 +6341,11 @@
- { 10793,-3791,-1146,-7498,15177,2488,-1390,1577,7321 } },
- { "OLYMPUS C80", 0, 0,
- { 8606,-2509,-1014,-8238,15714,2703,-942,979,7760 } },
-- { "OLYMPUS E-10", 0, 0xffc0,
-+ { "OLYMPUS E-10", 0, (short) 0xffc0,
- { 12745,-4500,-1416,-6062,14542,1580,-1934,2256,6603 } },
-- { "OLYMPUS E-1", 0, 0xfff0,
-+ { "OLYMPUS E-1", 0, (short) 0xfff0,
- { 11846,-4767,-945,-7027,15878,1089,-2699,4122,8311 } },
-- { "OLYMPUS E-20", 0, 0xffc0,
-+ { "OLYMPUS E-20", 0, (short) 0xffc0,
- { 13173,-4732,-1499,-5807,14036,1895,-2045,2452,7142 } },
- { "OLYMPUS E-300", 0, 0,
- { 7828,-1761,-348,-5788,14071,1830,-2853,4518,6557 } },
-@@ -6353,7 +6353,7 @@
- { 8961,-2473,-1084,-7979,15990,2067,-2319,3035,8249 } },
- { "OLYMPUS E-3", 0, 0xf99,
- { 9487,-2875,-1115,-7533,15606,2010,-1618,2100,7389 } },
-- { "OLYMPUS E-400", 0, 0xfff0,
-+ { "OLYMPUS E-400", 0, (short) 0xfff0,
- { 6169,-1483,-21,-7107,14761,2536,-2904,3580,8568 } },
- { "OLYMPUS E-410", 0, 0xf6a,
- { 8856,-2582,-1026,-7761,15766,2082,-2009,2575,7469 } },
-@@ -6399,23 +6399,23 @@
- { 9186,-2678,-907,-8693,16517,2260,-1129,1094,8524 } },
- { "PENTAX K2000", 0, 0,
- { 11057,-3604,-1155,-5152,13046,2329,-282,375,8104 } },
-- { "Panasonic DMC-FZ8", 0, 0xf7f0,
-+ { "Panasonic DMC-FZ8", 0, (short) 0xf7f0,
- { 8986,-2755,-802,-6341,13575,3077,-1476,2144,6379 } },
- { "Panasonic DMC-FZ18", 0, 0,
- { 9932,-3060,-935,-5809,13331,2753,-1267,2155,5575 } },
- { "Panasonic DMC-FZ28", 15, 0xfff,
- { 10109,-3488,-993,-5412,12812,2916,-1305,2140,5543 } },
-- { "Panasonic DMC-FZ30", 0, 0xf94c,
-+ { "Panasonic DMC-FZ30", 0, (short) 0xf94c,
- { 10976,-4029,-1141,-7918,15491,2600,-1670,2071,8246 } },
-- { "Panasonic DMC-FZ50", 0, 0xfff0, /* aka "LEICA V-LUX1" */
-+ { "Panasonic DMC-FZ50", 0, (short) 0xfff0, /* aka "LEICA V-LUX1" */
- { 7906,-2709,-594,-6231,13351,3220,-1922,2631,6537 } },
- { "Panasonic DMC-L10", 15, 0xf96,
- { 8025,-1942,-1050,-7920,15904,2100,-2456,3005,7039 } },
-- { "Panasonic DMC-L1", 0, 0xf7fc, /* aka "LEICA DIGILUX 3" */
-+ { "Panasonic DMC-L1", 0, (short) 0xf7fc, /* aka "LEICA DIGILUX 3" */
- { 8054,-1885,-1025,-8349,16367,2040,-2805,3542,7629 } },
- { "Panasonic DMC-LC1", 0, 0, /* aka "LEICA DIGILUX 2" */
- { 11340,-4069,-1275,-7555,15266,2448,-2960,3426,7685 } },
-- { "Panasonic DMC-LX1", 0, 0xf7f0, /* aka "LEICA D-LUX2" */
-+ { "Panasonic DMC-LX1", 0, (short) 0xf7f0, /* aka "LEICA D-LUX2" */
- { 10704,-4187,-1230,-8314,15952,2501,-920,945,8927 } },
- { "Panasonic DMC-LX2", 0, 0, /* aka "LEICA D-LUX3" */
- { 8048,-2810,-623,-6450,13519,3272,-1700,2146,7049 } },
---- a/codecs/raw.cc
-+++ b/codecs/raw.cc
-@@ -66,7 +66,7 @@
- if (!image.getRawData())
- return false;
-
-- return stream->write ((char*)image.getRawData(), image.stride()*image.h)
-+ return static_cast<bool>(stream->write ((char*)image.getRawData(), image.stride()*image.h))
- /* ==
- (size_t) image.stride()*image.h*/;
- }
diff --git a/media-gfx/exact-image/files/exact-image-0.8.1-libpng15.patch b/media-gfx/exact-image/files/exact-image-0.8.1-libpng15.patch
deleted file mode 100644
index 94c8906a874a..000000000000
--- a/media-gfx/exact-image/files/exact-image-0.8.1-libpng15.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- a/codecs/png.cc
-+++ b/codecs/png.cc
-@@ -16,6 +16,7 @@
- */
-
- #include <stdlib.h>
-+#include <zlib.h>
- #include <png.h>
-
- #include <iostream>
-@@ -104,7 +105,7 @@
- image.w = width;
- image.h = height;
- image.bps = bit_depth;
-- image.spp = info_ptr->channels;
-+ image.spp = png_get_channels(png_ptr, info_ptr);
-
- png_uint_32 res_x, res_y;
- res_x = png_get_x_pixels_per_meter(png_ptr, info_ptr);
-@@ -120,10 +121,13 @@
- // png_set_packswap(png_ptr);
-
- /* Expand paletted colors into true RGB triplets */
-+
-+ int num_trans;
-+
- if (color_type == PNG_COLOR_TYPE_PALETTE) {
- png_set_palette_to_rgb(png_ptr);
- image.bps = 8;
-- if (info_ptr->num_trans)
-+ if (num_trans)
- image.spp = 4;
- else
- image.spp = 3;