summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-10-27 17:02:11 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-27 17:54:35 +0200
commit54c2580a88455cca5fdfed46508513cc2d1977bd (patch)
tree9c6bf8a2c1208e35cd8c1aa6f7842068300e9aca /media-gfx
parentmedia-gfx/igal: EAPI7, drop superfluous || die (diff)
downloadgentoo-54c2580a88455cca5fdfed46508513cc2d1977bd.tar.gz
gentoo-54c2580a88455cca5fdfed46508513cc2d1977bd.tar.bz2
gentoo-54c2580a88455cca5fdfed46508513cc2d1977bd.zip
media-gfx/pngcheck: EAPI7, drop superfluous || die
Closes: https://bugs.gentoo.org/666296 Thanks-to: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/pngcheck/pngcheck-2.3.0.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/media-gfx/pngcheck/pngcheck-2.3.0.ebuild b/media-gfx/pngcheck/pngcheck-2.3.0.ebuild
index 9731e7c72fb2..4358988b8ba1 100644
--- a/media-gfx/pngcheck/pngcheck-2.3.0.ebuild
+++ b/media-gfx/pngcheck/pngcheck-2.3.0.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
+EAPI=7
+
inherit toolchain-funcs
-DESCRIPTION="verifies the integrity of PNG, JNG and MNG files with internal checksums"
+DESCRIPTION="Verifies the integrity of PNG, JNG and MNG files with internal checksums"
HOMEPAGE="http://www.libpng.org/pub/png/apps/pngcheck.html"
SRC_URI="mirror://sourceforge/png-mng/${P}.tar.gz"
@@ -20,10 +21,10 @@ src_compile() {
emake -f Makefile.unx \
CC="$(tc-getCC)" \
CFLAGS="${LDFLAGS} ${CFLAGS} -DUSE_ZLIB" \
- ZLIB="-lz" || die
+ ZLIB="-lz"
}
src_install() {
- dobin png{check,split,-fix-IDAT-windowsize} || die
- dodoc CHANGELOG README
+ dobin png{check,split,-fix-IDAT-windowsize}
+ einstalldocs
}